Jump to content
RESET Forums (homeservershow.com)

Motherboards and HBAs


oj88
 Share

Recommended Posts

I have a rather unusual set questions....

 

1. Should all off-the-shelf motherboards for either Intel or AMD typically support HBA cards?

2. If no, is there a way to find out just from regular research if a certain motherboard is likely to support an HBA? ie. Certain brands, models, chipsets, etc?

 

A bit of background:

I have an IBM ServeRAID M1015 (IT Mode) which has all my pool drives. It was initially setup way, way back in 2011 on an Asrock M3A785GM-LE. A few years later in 2016, I decided to upgrade to an ECS Golden Z77H2-AX. It was downhill from there. Even after a few days of tinkering with it, I wasn't able to get the HBA to appear (no POST from the HBA card) so Windows weren't able to see the pool drives. We don't have a solid return policy like in the US. In these parts, "compatibility is buyer's responsibility" so I'm being careful about my choice. Regardless, I was lucky to have been able to return the board after much persuasion.

 

Long story short, I ended up using a different motherboard, to which I'm still using to this day; a Gigabyte GA-Z97-D3H. Needless to say, this board was able to see the HBA.

 

Fast-forward to today, the board is getting a bit long in the tooth and I am now looking for a suitable replacement. I also need to add a 1050Ti video card for Plex to be able to do HEVC 10bit hardware decoding. The current board doesn't have enough PCIe slots.

 

Another thing.... I pretty much prefer building these myself using enthusiast/gaming motherboards and parts for two reasons: They're cheap and are quite abundant. Server and workstation boards are a rarity and can be very expensive, even from the pre-owned market. It would've been ideal if I could pick up a SuperMicro board from Newegg... but no. I've had zero reliability issues with these boards running 24x7 and I'll be happy to keep using these for as long as it can work with the HBA.

Edited by oj88
Link to comment
Share on other sites

So a few things come to mind.

1. There have been some firmware issues with compatibility. MS Gen8 had an NMI issue with certain versions of LSI firmware. 

2. Any new system you build will likely be UEFI BIOS. I have seen issues with older HBA not supporting UEFI. Sometimes you need to run the system in legacy BIOS to get it to work. Occasionally, the HBA will work, but you are unable to access the BIOS of the card while the system BIOS is in UEFI. 

3. You need to do research for OEM cards. HPE seems to jump back and forth from LSI/Broadcom and MicroSemi/Adaptec controllers. Both are good, just important to know what you have.

 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...