Jump to content
RESET Forums (homeservershow.com)

Replacing SSD OS in Gen8


Recommended Posts

pressieguy
Posted (edited)

hi everyone, 

looking for some advice and guidance and im a real noob at this.

When i first installed my Gen8, i fluked it and it worked the way i wanted to until a power outage busted my OS drive. 

 

my set up is as followed. 

SSD connected via sata

2 x 3.5" disks in the slots 

Setup is Jbod style.

 

i dont think i set up using iLo when i set it up and i cant get into the intelligence provisioning options. It tries to boot from NIC and then i get a non system disk error.

can i not replace the disk and reinstall windows on the new drive?

 

i was able to boot into the thumb drive where i have Windows install media however it wasnt able to detect any drives.

 

any suggestions would be greatly appreciated.

 

 

Edited by pressieguy
Link to post
Share on other sites
thiagotgc

Some questions:

 

1 - Are you using RAID to mount the drives?
2 - Did you install the latest version of Intelligent Provisioning?
3 - Put the pen drive with Windows bootvael, at the boot of the bios, press F10, and when other options appear, press F3, see if it worked.

Link to post
Share on other sites
schoondoggy

If you have the SSD on the ODD SATA port on the motherboard it will only boot if you have the storage controller set to B120i in the BIOS. If the BIOS is set to AHCI you can use a boot loader to boot from the SSD. With the B120i enabled, you would need to set each drive as an individual RAID0 drive to be JBOD like.

Link to post
Share on other sites
pressieguy

excuse my ignorance, but is intelligent provisioning = b120i?

 

when i try accessing intelligent provisioning,  https://1drv.ms/u/s!Aqv8hDrDiG0TrDcEA_EA7U_zhvjR?e=AOtP3z 

it continues to loop with this 

https://1drv.ms/u/s!Aqv8hDrDiG0TrDhPZcOUomzKaOY-?e=ncF6Kp

then this 

https://1drv.ms/u/s!Aqv8hDrDiG0TrDmhHyJtCibzO9pD?e=99UzZC

 

i dont recall how i mounted the drive as it was few years ago. i havent tried installing the latest intelligent provisioning but i will try to. 

 

i do notice my screen doesnt look like everyone elses, i dont see this Launch-RBSU-BIOS-F9-key-Gen8-Server4

Link to post
Share on other sites
schoondoggy

IP is an automated utility to install the OS.

From one of the screen shots I can see that you have the B120i RAID controller enabled.

When you booted Windows from the USB stick it did not see any drives because you need to have the driver for the B120i available. Download the latest driver for the B120i and put it on a USB as well. 

You should update the BIOS on the server as well. The latest BIOS does not require entitlement.

 

Link to post
Share on other sites
pressieguy

i decided to upgrade the latest BIOS first from

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_e9bfdf20809a426cb16ef9cd81#tab2 

and 

https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_671606ca210640bbb93ae3b683&swEnvOid=4184#

with the guide by John Strutsman.

 

im hitting a brick wall as its not wanting to boot from the drive. This is what i have from the guide

image.png.ce2cdd901e98538e4dd2dbfdcd7f12ce.png

 

and this is the 

error loop im getting now.

https://1drv.ms/u/s!Aqv8hDrDiG0TrDvjcgIDerPZ5y2u

 

would i have to install older BIOS upgrade first then upgrade to the latest? ive tried spamming f10 and it resulted in the same loop.

 

or would you guys recommend installing b120i drivers first? 

Thanks

 

 

Link to post
Share on other sites
pressieguy

i managed to make some progress with the installation and i think the driver has found my new ssd.

 

Is it normal for it to only display half of the space?

my drive is 120gb, and its only showing 60gb. 

Unable to test until tomorrow whether if i got a defective drive or I  am wondering if it has something to do with raid-0 or the driver.

thanks again 

Link to post
Share on other sites
schoondoggy

Check the partition to see if it is using the entire drive.

Link to post
Share on other sites
pressieguy
Posted (edited)

i get to this stage https://1drv.ms/u/s!Aqv8hDrDiG0TrDw3zCc6GAlk6ELH?e=OnaBDJ

 

it seems to only pick up 59gigs. ive checked and there is no other partitions on it. ive tested this drive on a working machine and its definately 120gigs available as i was able to format and test it. could you suggest another way i could check how i can get it to use the entire drive? or is this something to do with the raid controller?

thanks 

Edited by pressieguy
Link to post
Share on other sites
schoondoggy

Was the original SSD 60GB?

Use the HPE SSA utility to see how the B120i sees the SSD.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...