Jump to content
RESET Forums (homeservershow.com)

Failed to run RomPAQ firmware update


TomP
 Share

Recommended Posts

I created the USB key per HP instructions, put the key in the lower front USB socket, booted and updated the boot order first with a one-time USB permission, but that did not work, giving many errors then a message to "Enter the full shell command line"

 

I then updated the regular boot order and moved "USB Drivekey C:" to the top with "Hard Drive C:" second, but it continued to boot from my SSD C:. Hard booted again, checking that I had indeed altered the boot order but it still does not boot from the USB key.

 

I have tried to repeat the HPUSB process to re-initialise the USB Key but I now get a "cannot format drive" error so I re-formatted completely.

 

Trying the SP99427 > HPUSB.exe again, I now see that it has copied the entire contents of mu Downloads folder instead of the RomPAQ files so I can't have followed the right procedure and am confused, so can anybody help? Thanks

 

Can any body help? Thanks

Link to comment
Share on other sites

Thanks. I got Rufus and the RomPAQ link you gave me creates a SWSetup/SP99427/ROMpaq USB Key folder which contains 4 files...

 

4.1M .684 file) Is this an ISO file?

32k (.CPU file)

1k Readme.txt file

107k  ROMPAQ.exe file, which will not run on W10 or W7 Pro with error that it does not run on this machine OS

 

....so I'm not sure which should go on the USB key, but Rufus just asks 'disk or ISO Image or download' please select)' with no ability to select anything or start formatting the key.

 

There seem to be lots of folks that have installed W10 so it must work somehow. Please can you advise?

 

 

Link to comment
Share on other sites

Update: I just found this on the HPE site... 

https://support.hpe.com/hpsc/swd/public/detailswItemId=MTX_71b9ad7e388d434fb62f7542e3&swEnvOid=4104

 

Proliant Gen 8 online flash component ROM cp039540

 

...which is a firmware update dated 04/04/2019, compared to my current installed 06/06/2014 so is this the same as in the RomPAQ?

 

It does run (after looking for ILO4) and checks that the firmware is out of date, so should I install this?

Edited by TomP
extra info
Link to comment
Share on other sites

On 3/10/2020 at 1:24 AM, schoondoggy said:

yes

It worked, thanks !! I also managed to update the Broadcom firmware and driver, plus Matrox and B120i drivers.

 

I couldn't see anything to update AHCI / SATA, so is there an update somewhere, I am at version 0.84? and am I missing anything else?

 

Interestingly, having failed to get RomPAQ USB key to boot, I tried a known working key (MemTest) and it too failed to load by setting USB top of the BIOS F9 boot order, so I tried a on-time boot from the F11 Boot Menu and it did work. Is this expected behaviour?

Link to comment
Share on other sites

48 minutes ago, schoondoggy said:

What USB port are you using?

Only USB 2.0 ports are available at boot.

I used a front USB 2.0 port. I was aware that USB3.0 is only available after OS booting.

 

The F9 BIOS is set at...

 

IPL:1 USB DriveKey (C:)

IPL:2 Hard Drive 😄 (see Boot Controller Order)

 

...which seem strange that both are listed as C:

 

Link to comment
Share on other sites

1 hour ago, TomP said:

IPL:2 Hard Drive 😄

Should have read 

IPL:2 Hard Drive 😄

...don't know why the editor inserted an Emogee

Edited by TomP
keeps inserting Emogee instead of C:
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...