Jump to content
RESET Forums (homeservershow.com)

Odd problem with Microserver Gen8, will not boot from SSD with drives in bay


Recommended Posts

Hi All,


Have a Microserver Gen 8, 16GB ram and Xeon 1220 v2, I have had a few of these and never had any issues.


There is a ILO fault on the NAND on this one and I cannot get it to reformat using all the various procedures on the HP advisories (or indeed re-install IP, which is necessary after a NAND format), I can however upgrade the ILO firmware and it is currently on 2.72, BIOS all up to date also.


As a result I am unable to configure the array, usually would stick the SSD on the Optical port (5) and configure as RAID 0, Bays 1 & 2, get mirrored and Bays 3 & 4 Raid 0, this has worked happily without issue previously.


However without the array configuration that sits within intelligent provisioning I cannot set this up. So resort AHCI SATA mode and Windows 10 goes on just fine, until I add any drives into the LFF bays then it just refuses to see the Windows drive and ends up on a boot loop.


I then need to reboot the unit to get it to boot into Windows 10, have tried multiple configurations now and have a feeling I am going around in circles here.


Any thoughts on how to sort this would be greatly appreciated, can't help but think i am missing something obvious and hoping someone can point me in the right direction.



Link to comment
Share on other sites

Many thanks for that, I knew something like that existed but for the life of me I couldn't find it based on the search terms, no doubt hung up on it being the Storage Array Configurator or Intelligent Provisioning.


Will give it a try later and see how i get on, I either wasn't aware of the B120i limitation for booting ODD sata or knew it and had forgotten it since 2015!! :)

  • Thanks 1
Link to comment
Share on other sites

Surprisingly despite the fact that on posting the B120i was complaining about drives missing the SSA saw no B120i installed :(


I could install windows however not sure on this one but the SSD had been created as the 3rd logical drive, which I believe was why it refused to pick it up on boot. Wasn't brave enough to delete the array which was supporting the drive running windows.... so thought I would try something a little different.


Still have the NAND issue so no config from boot, however built a bootable USB Windows 10 on a mSATA enclosure I have an booted from that, it was slow to say the least but once up and running it was actually quite usable, no doubt having a Xeon and 16GB of ram was helping in that. installed the Windows HP Array Configuration utility, deleted all the arrays/logical drives and configured from scratch starting with the SSD.


Re-boot and re-install of Windows, couple of reboot later and Bays 1-4 reinstalled and it all now boot correctly, not a very elegant solution but hey it works. 


Now have to work out what I can use it for,because I wouldn't wish to inflict it on anyone else by selling it!

Link to comment
Share on other sites

Latest Bios

2019.04.04(A)(28 Jun 2019)

Latest ILO,

2.72(20 Dec 2019)


The B120i was updated when applying the last Gen8 service pack :( from memory.


However, all working now so all is well that ends well, I was wondering at one point if it was effectively going to write the machine off,  which is a shame.


My second youngest is now coming up for 6 and getting into Minecraft this may end up as his server now, I replaced the Microserver with an ML350p Gen8 which i got incredibly cheaply. Since they my servers have always lived in the garage it didn't make any difference noise wise. Although I am probably paying for it in electricity consumption.

Edited by Williek
  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...