Jump to content
RESET Forums (homeservershow.com)
VincenV

USB & ILO virtual media boot issues

Recommended Posts

VincenV

Hello Everyone,

 

I bought a HP Microserver G8 a few days ago for home server purposes (NAS, Home Assistant, homelab, etc..), and everything was fine with it. I installed some OS (ESXi, Linux distributions in native, etc..) in a last few days, because I wanted to do some benchmarking on the disks. The USB boot (from a pendrive) and the boot from ILO virtual media always worked well.

 

After a lot of benchmarking with dd and fio, I decided that put a smart array p410 in the gen8. The disk performance got a littlebit faster, but Linux sw raid in AHCI mode was still the best. So I dropped my plans with ESXi and with the p410, and tried to switch back to the inetgrated b120i/AHCI and Proxmox.

 

After removed the p410 and insertd the Proxmox iso I got a surprise:

 

- server don't boot from any USB port

- server don't boot from ILO virtual media

- intelligent provision not working

 

Of course a lot of install media (esxi, linux, windows, etc..) tried, and also try the existing/working OS (on pendrives). I always get a blinking cursor on the top left corner and the boot device check cycle restarts.

 

After this, I reset ILO and the bios, remove the mainboard battery, put back the p410, pull out the disks, but these things didn't help :(

 

I found two possible solution, but only work for a short time (4-5 reboot):

 

- reflash the ILO 2.70 firmware

- change the ILO NIC to shared port, or switch back to dedicated port

 

This is a painful problem, because the server may not boot from USB after a power outage :(

 

Do you have any idea or advice for a possible solution?

 

Some detailed parameters about this MS Gen8:

 

BIOS verison: j06 04/04/2019

ILO verison: 2.70 with advanced license

CPU: e3-1220v2

RAM: 8GB

HDD: 2x1TB WD green in the front bay

SSD: 2x250GB Samsung 860 EVO in the front bay

USB pendrive: I try with mixed brands and sizes

 

 

Thanks a lot!

Edited by VincenV

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...