Jump to content
RESET Forums (homeservershow.com)
TwoWheels

Failure of BMR in Essentials due to EFI partition error

Recommended Posts

TwoWheels

I'll try to give a l the pertainent details.

I have a Lenovo Flex 4 1580 that came with a 512GB Liteon SSD. That drive failed, and I'm trying to replace it with a 1TB Sandisk SSD.

I used network PE boot to launch the restore, and then used ctrl-alt-shift to run diskpart. In diskpart, I created the two partitions on the existing drive, a 1GB WINRE_DRV partition and the remainder of the disk (I think) as a primary NTFS partition (which came out to 930GB approx).

After restoring 100% (0% remaining, more precisely), it timed out and gave this error:

[08/19/2019 00:33:04  664] RestoreHelper::FixBootBlock: fixing boot block
[08/19/2019 00:33:04  664] RestoreHelper::ExtendVolume: extending the volume
[08/19/2019 00:33:27  664] Restoring ESP
[08/19/2019 00:33:27  664] existing offset: 0x0, size: 0x4400
[08/19/2019 00:33:27  664] existing offset: 0x4400, size: 0xfbc00
[08/19/2019 00:33:27  664] existing offset: 0x100000, size: 0x6400000
[08/19/2019 00:33:27  664] existing offset: 0x6500000, size: 0x8000000
[08/19/2019 00:33:27  664] existing offset: 0xe500000, size: 0xe891900000
[08/19/2019 00:33:27  664] Found existing volume
[08/19/2019 00:33:27  664] existing offset: 0xe89fe00000, size: 0x41000000
[08/19/2019 00:33:27  664] existing offset: 0xe8e0e00000, size: 0x1fbe00
[08/19/2019 00:33:27  664] FormatPartitionEsp called for disk \\?\PhysicalDrive0
[08/19/2019 00:33:27  664] Formatting ESP partition at offset 0x8100000
[08/19/2019 00:33:27  664] ERROR: FormatPartitionEx failed, error 0x80042405
[08/19/2019 00:33:27  664] ERROR: FormatPartitionEsp failed, error 0x80042405
[08/19/2019 00:33:27  664] RestoreHelper::T_Restore: failed to restore ESP, error 0x80042405
[08/19/2019 00:33:27  664] RestoreHelper::T_Restore: restore complete with return value 536870914
[08/19/2019 00:33:27  664] ERROR: CDialog_Restore::Completed failed, HR=0x80070002 (at func: CDialog_Restore::Completed, admin\serveressentials\backup\pc\bmr\restorewizard\dialog_restore.cpp (97)

I tried the instructions in Client BMR failed for UEFI machine in advanced mode , but the calculation in powershell yielded a non-integer, negative number of -2048.74120616913. 

Based on the article, I'm assuming that instead of padding, I need to reduce the size of SOMETHING by 2GB, but I'm not clear how to do that so it lands on precisely the same address, particularly because of my fractional results from the powershell calculation.

 

Is there a way to determine the EXACT sizes for the WINRE_DRV, Windows, EFI, and MSR partitions from the backup itself. It seems odd that it handles what should be a straightforward restore so poorly (and manually). the Restore UI provides "human readable" sizes, but what is really needed are exact sizes in MB blocks, apparently.

 

Thanks for your assistance. This was my primary client machine and I really need it back!

 

 

 

 

Share this post


Link to post
Share on other sites
TwoWheels

I should note that I originally relied on the steps in this article:

Restore a full system from an existing client computer backup

and used the diskpart steps verbatim - 100 and 128. 

So the confusing part to me is needing a negative 2048.xxx position for these, when creating a passing partition would create a positive offset?

Share this post


Link to post
Share on other sites
nrf

I have found that these restore processes can be quite fussy, even on the server when directly recovering from disk. One kludge I have developed is to format the c drive and do a windows install, then recover onto that. seeing the length of that article it seems microsoft should be embarrassed at how not convenient it is. I have taken to keeping around a thumb drive with another products's recovery bootable image for restoring it as that company builds the drivers into the restore media. Just saying, not so easy...

Edited by nrf

Share this post


Link to post
Share on other sites
TwoWheels
 

Update:

I tried again using diskpart to create a 2049 MB padding partition first. This time, I got this result:

[08/19/2019 12:25:27  420] existing offset: 0x0, size: 0x4400
[08/19/2019 12:25:27  420] existing offset: 0x4400, size: 0xfbc00
[08/19/2019 12:25:27  420] existing offset: 0x100000, size: 0x80100000
[08/19/2019 12:25:27  420] existing offset: 0x80200000, size: 0x6400000
[08/19/2019 12:25:27  420] existing offset: 0x86600000, size: 0x8000000
[08/19/2019 12:25:27  420] existing offset: 0x8e600000, size: 0xe852800000
[08/19/2019 12:25:27  420] Found existing volume
[08/19/2019 12:25:27  420] existing offset: 0xe8e0e00000, size: 0x1fbe00
[08/19/2019 12:25:27  420] FormatPartitionEsp called for disk \\?\PhysicalDrive0
[08/19/2019 12:25:27  420] Formatting ESP partition at offset 0x8100000
[08/19/2019 12:25:27  420] ERROR: FormatPartitionEx failed, error 0x80042405
[08/19/2019 12:25:27  420] ERROR: FormatPartitionEsp failed, error 0x80042405
[08/19/2019 12:25:27  420] RestoreHelper::T_Restore: failed to restore ESP, error 0x80042405
[08/19/2019 12:25:27  420] RestoreHelper::T_Restore: restore complete with return value 536870914

so hopefully the "existing offset" numbers being different here, but still getting the same error, are helpful? I tried some [failed] math, and this is a 3rd try with padding partition increased by 22MB - still same error:

[08/19/2019 23:43:52  194] existing offset: 0x0, size: 0x4400
[08/19/2019 23:43:52  194] existing offset: 0x4400, size: 0xfbc00
[08/19/2019 23:43:52  194] existing offset: 0x100000, size: 0x81700000
[08/19/2019 23:43:52  194] existing offset: 0x81800000, size: 0x6400000
[08/19/2019 23:43:52  194] existing offset: 0x87c00000, size: 0x8000000
[08/19/2019 23:43:52  194] existing offset: 0x8fc00000, size: 0xe851200000
[08/19/2019 23:43:52  194] Found existing volume
[08/19/2019 23:43:52  194] existing offset: 0xe8e0e00000, size: 0x1fbe00
[08/19/2019 23:43:52  194] FormatPartitionEsp called for disk \\?\PhysicalDrive0
[08/19/2019 23:43:52  194] Formatting ESP partition at offset 0x8100000
[08/19/2019 23:43:52  194] ERROR: FormatPartitionEx failed, error 0x80042405
[08/19/2019 23:43:52  194] ERROR: FormatPartitionEsp failed, error 0x80042405
[08/19/2019 23:43:52  194] RestoreHelper::T_Restore: failed to restore ESP, error 0x80042405
[08/19/2019 23:43:52  194] RestoreHelper::T_Restore: restore complete with return value 536870914
 

HELP!

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • pksparks
      By pksparks
      Hi, 
      been reading through this forum, and also 2012 r2 essentials, but somehow i am not getting my vpn to work
      my configuration:
       
      gen8 with 2 nics connected and ilo4 nic connected. Nic 1 is connected to internet, nic 2 to my internal network
      ip adresses:
      nic 1: 192.168.2.200, with gateway
      nic 2: 192.168.10.229, no gateway
      ilo: 192.168.10.37
       
      nic 1 is connected to 4g router. Portforwardings for ports 80, 443, 1723 to ip 192.168.2.200
       
      after installation of server 2016e activated a remotewebaccess.com adress at microsoft, and installed remotewebacces and vpn.
      remotewebacces with /remote option is working
       
      my windows 7 laptop is in the domain of my server, client connector installed, and backup etc working.
      when i am at my office, or connected via a hotspot of my iphone, i want to make a vpn connection.
      everytime i start this, i see shortly that username and login are checked, but that is it, connection stops.
       
      i know i am overlooking something, but as allways, the longer you look, less change of finding it.
       
      any suggestions?. No need to hurry, i can only test this again on saturday.😩😏. Have to work tomorrow.
       
      any help is appreciated
       
      rgds
      Patrick
       
       
    • Umfriend
      By Umfriend
      Hi all, new here and WSE noob.
      So I have a server running WHS2011 and I want to go WSE2016 (or WSE2019 if it will still offer client backups, web access etc.). So I installed a evaluation and am testing with old unused computers. Now I know that there are two things some talk about when using WSE in a SOHO setting: not joining the domain and not having WSE as the DNS server.
       
      Now my question is basically this: I connected a client with defaults (so no hacks) and now I am wondering "why bother"? I don't understand what the reasoning is behind not joining the domain for instance. As far as I can tell, the user sees no difference between connecting to WSE2016 or WHS2011. But people are talking about it so there must be a catch I don't get.
       
      Edit: My clients would be both fixed PCs as laptops which would have to be able to work on other networks (but not connected to other servers or anything).
    • mskaggs
      By mskaggs
      Hi,  
       
      Background: I had a WHS that I used as a backup machine for several PCs in my house. That one finally bit the dust a few years back with hard drive failure. Due to life I didn't rebuild it and when with an NAS for backup. 
       
      As one of my client PC's drive was failing a few years after WHS crashed, I did a local back up of that PC to an external hard drive. I used the "backup" software that was on the PC and thought I saved myself. 
      Looking at that backup drive now, I'm seeing what appears to be a backup created by a WHS with references to multiple PCs from my home network. I can't find a restore program that can access those files properly and now I'm wondering if I need to try the WHS client restore app. Unfortunately, I don't have the CD's any more. 

      So questions: 
      1. Is there a way to positively identify this back up as a WHS style backup? The top level of the drive has a file called QSM_VolumeID and a folder named DE. In the folder named DE are two folders named "folders" and "shares". There's also a file named DEguid. 

      2. Is the client recover software from WHS V1 available anywhere for download? 
      Any other thoughts, ideas or help would be appreciated. Also, if there's another topic that addresses this, pls point that out as I'm happy to read to save everyone's time. 
       
      Thx,
      Mark
       
    • judgeschambers
      By judgeschambers
      Hello, 
       
      Per my signature, I have WHS 2011 installed on a HP N54L that I built and have had in service since March 2013.  I have a CorsAir  60Gb SSD HD running on SATA #5 with the modded bios to allow  WHIS to install  on this small OS hard drive.
      I have a WD PCI-e USB 3.0 card with a 3 yr old Seagate Backup Plus 2Tb drive connected that WHS places the Server OS backups to. 
      The problems:
      With Windows updates, the 60 gb SSD has only 5 gb space available and I'm getting warnings as such. So, I want to install a new Sandisk 240 gb SSD to replace it.  When I run the WHS Server disk, the restore server OS process either locks up looking for the files on the Seagate usb drive or does not discover the files and the scan just runs and runs.   
      The processes:
      I remove all my storage drives from the N54L four bays.  Swap the old 60gb OS SSD for the new 240 GB SSD Plug in my LG portable DVD drive into the rear USB 2.0 and use it to spin the WHS disc Connect the Seagate Backup Plus USB 3.0 Drive to the N54L (this is where it takes four paths and all fail) (bios is configured prior for proper boot sequence of DVD first, new OS SSD 2nd) Since USB drives are backwards compatible, if it is connected to the N54L 2nd remaining 2.0 USB from boot up (post screen shows the DVD, the new SSD and the Segate USB Drive), I select Restore Files in the back up menu the screen goes black except for the WHS background image. Sits and never resolves.  Or leave the Seagate USB drive unconnected until I get to the Restore Files menu, connect, then select restore files/etc. The  scanning for back  up files dialog runs this time and never finds the files. Only way to get out is to hard reboot the server.  Same as #2 but skip the  initial file search and click advanced. Connect the USB  dirve and then click refresh and nothing shows up. Click scan and it too will run forever and not see the drive with the backup files.  Or resort to installing the PCIe drivers via a thumb drive and then connect the drive to the PCIe USB 3 and it will not recognize it in the list. Click search and it searches without success.   
      I'm thinking I need to transfer the WHS OS Backup files on the Seagate Backup Plus USB drive onto another bare hard drive and insert into one of the N54L HD bays and see if it will then find the backup files. Thus eliminating the whole USB 3/2 interface. 
       
      Thoughts?  
      Thanks in advance. 
    • tinkererguy
      By tinkererguy
      Once in a while, I write something, not expecting much. Months later, I realize the article's popularity continues to grow. Here's just such a piece, from back in Sep 2013 called:
       
      Rufus takes 5 minutes to create a UEFI bootable USB 3.0 flash drive for Windows 8.1 installation
      TinkerTry.com/rufus-takes-5-minutes-to-create-a-uefi-bootable-usb-3-0-flash-drive-for-windows-8-1-installation/
       
      Visitor davepermen was reading an article about using Rufus to create a bootable ESXi USB drive, for installation to itself. He apparently also owns a Surface Pro, decided to give Rufus a go, and found success, then typed up this comment.
       
      Free software, no adware, no catch. Just a simple and effective and fast utility I thought I'd share. Especiallyl given there seems to be less and less of it for Windows these days.


×
×
  • Create New...