Jump to content
RESET Forums (homeservershow.com)

NIC Teaming and Best Practice Analyzer Error


Dwain Pipe
 Share

Recommended Posts

I'm running Win 2016 Essential on a HP Gen 8 Microsoft.  I've recently expanded my LAN and can now run 3 cables to my server, so I've cabled the iLO, and both LAN NICs.

 

I've then created a NIC team using the default configuration. The NIC team has got green ticks on all the settings, and the server seems happy :-)

 

Then the Best Practice Analyzer runs and gives me an error...

 

"The network adapter <my NIC Team Name> does not list the local server as a DNS server; or it is configured as the first DNS server on this adapter."

 

With the really helpful advice to:

 

Resolution:
Configure adapter settings to add the loopback IP address to the list of DNS servers on all active interfaces, but not as the first server in the list.

 

So I've done as asked...  192.168.1.1 is my router that is configured with both my ISP and Google DNS services.

 image.png.1bdd6f30cc23ae35e06d91a86bc8cb8c.png

 

But, you've guessed it... the Best Practice error remains.  The server still seems happy, I'm getting no obvious network errors, although some of my client PC occasionally get a DNS probe error, but I reload the webpage and it works.

 

Any other ideas please?

Link to comment
Share on other sites

so just reverse them and you will be cool. I think there is a 'not' missing from the error message. after all these versions of essentials you would think they would spot that.

Edited by nrf
Link to comment
Share on other sites

I get more error from the BPA if I reverse the settings.  I swapped to...

image.png.d16af8acb821af0ea7fc9d67147f6805.png

 

All the errors are basically complaining that 192.168.1.1 is not a DNS server (it's a router).

 

Link to comment
Share on other sites

but does your router provide dns service? have you checked its settings? it can be both a router and a dns server. how about showing us the errors? my essentials2016 is clean in the BPA and I have it set up as 127.0.0.1 and 192.168.1.1 where my router does provide dns. at some point you may want to live with some of the bpa stuff if you are sure your setup is ok. on 2012r2 essentials it was always complaining that I didn't have a secondary domain controller, I ignored that.

Edited by nrf
Link to comment
Share on other sites

My router uses my ISP and Google DNS and provides that service on 192.168.1.1

 

When I swapped the DNS setting around the BPA gives more errors that 192.168.1.1 must provide:

  • Global Catalog resource records
  • LDAP resource records
  • PDC resource records
  • resolve names in the forest root domain name zone
  • resolve names in the primary DNS domain zone
  • resolve Kerberos resources records for the domain controller

Where as when the IPs are the other way around I only get one error, the loopback should be second error.

Link to comment
Share on other sites

yes I mentioned about a previous version wanting a backup domain controller. that one was server standard + essential experience

somehow my essentials 2016 instance has the exact same settings and is not firing that best practices complaint.

Link to comment
Share on other sites

I had the thought about the IPv6 causing the issue when I was troubleshooting the issue in the first place. 

 

I disabled IPv6 in the teamed NICs adapter properties, but it made no difference. 

 

I could try set the IPv6 DNS with the loop back second and then disable it, as perhaps the BPA is reading the settings regardless. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...