Jump to content
RESET Forums (homeservershow.com)
bondisdead

Remote access breaks out of the blue!

Recommended Posts

bondisdead

Googling around, and I ended up finding my own thread from about 4-years ago, but this is a different (but somewhat related issue)! I use remote access via the server somewhat regularly. I use WOL to turn on my main desktop PC, then log in via remote desktop (via the WHS web portal). Just the other day I was out of town, and attempted to log in, only to be greeted with "Runtime Error - Server Error in '/' Application." When I get back home, I can RDP into the server, and everything seems fine. Backups running, folders viewable, etc. However, when I look at the Remote Web Access section, status is reported as "The router is not working". I attempt repair, but no luck. The errors reported are: UPnP (which is understood, as I have this turned off in my Google Wifi router) and "Remove Web Access to your server is blocked." Nothing has changed in hardware over last few weeks. There were no firmware or software updates to the router. The only windows updates to the server are Windows Defender and .NET Framework. I contacted Spectrum, and they claim nothing has changed, and that ports 80, 443 or 4125 are not blocked. I verified these are still enabled for port forwarding in the Google Wifi router as TCP. I deleted these, and set them up again. I rebooted modem, router and server. When at home, I am using my cell phone via 4G (not Wifi) to test http://<domain>.homeserver.com. Using the web-site to check my ports reveals that 80/443/4125 are open. This has been working flawlessly since December 2019. I have been pulling out my hair, as nothing that I am aware of has changed! Any ideas??!!

Share this post


Link to post
Share on other sites
tmpr
Posted (edited)

Does the website work locally i.e. can you reach the site from the server using https://localhost ?

 

 

 

Edited by tmpr

Share this post


Link to post
Share on other sites
bondisdead
Posted (edited)

I didn't test that before, but I just did and get a slightly different error. From the server itself, I open Google Chrome, and enter https://server-name. I first get an error that "your connection is not private", but I can click Advanced, then proceed to the site. I am then greeted with cryptic error page: "Configuration Error - Server Error in '/' Application." This is quite similar to the error I had before. What is interesting is that this reports .Net framework errors. These are the recent windows updates.

 

 

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Could not load file or assembly 'Wssg.RootSite' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

Source Error: 
 


Line 57:                 <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 58:                 <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 60:                 <add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>
Line 61:                 <add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>


Source File: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config    Line: 59 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Wssg.RootSite' could not be loaded.
 


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
Edited by bondisdead

Share this post


Link to post
Share on other sites
bondisdead

Thanks for sharing that. I did have .NET v2 selected, so I switched to v4. I also deleted temp files as suggested by one poster. None of that worked, unfortunately. I even uninstalled the most recent .NET windows updates, and no go. 😞

 

Looked at the log file listed, and it doesn't help me much. Sadly, this might become my excuse to go with server 2016 essentials. Or a dedicated NAS.

 

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error: 

 


			


Source File: C:\Program Files\Windows Server\Bin\WebApps\RemoteAccess\web.config    Line: 192 

Share this post


Link to post
Share on other sites
tmpr
Posted (edited)

That's weird. I just had a look at my web.config and line 192 is

 

<compilation debug="false" targetFramework="4.0">

 

Did you reboot the server after making the change?

 

There's some more DotNet related setting in IIS you could check. If you open IIS, click on the server node in the left pane and open ISAPI and CGI Restrictions in the main pane, there should be a list of ASP.Net versions allowed. On mine both 32bit and 64bit versions of ASP.NET v2.0.50727 and ASP.NET v4.0.30319 are allowed.

 

Failing that you could always try the DotNet Framework repair tool.

https://www.microsoft.com/en-us/download/details.aspx?id=30135

 

Sorry I haven't been much help :(

 

 

Edited by tmpr

Share this post


Link to post
Share on other sites
bondisdead
Posted (edited)

Yeah, I rebooted the PC many times! I tried the .NET repair. It indicated two potential issues, fixed them, then rebooted. Ran updates, and there was nothing. Didn't help. Opened IIS, then the "ISAPI and CGI Restrictions" like you mentioned, and there were two ASP.NET v4.0.30319 entries where were set to "Not Allowed" Restriction level. I changed them both to "Allowed" and rebooted. No help!

 

Which version does your server have for .NET framework? I seem to be at 4.7.2 in windows updates, but if I look at C:\Windows\Microsoft.NET\Framework64, I only see v4.0.30319. I opened up the registry editor, and according to Microsoft site, I have 4.7.2 installed. I am not sure whether I need additional entries in the windows folders and IIS.

Edited by bondisdead

Share this post


Link to post
Share on other sites
tmpr

The folder under C:\Windows\Microsoft.NET\Framework64 is v4.0.30319 but the version string in the registry under ' HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full. ' says

4.7.03062

 

 

 

Share this post


Link to post
Share on other sites
bondisdead

Yeah, I have the same Version string. The Release string has 461814.

 

Thanks so much time for the time you are providing me to help debug this!! 🙂

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...