Jump to content
RESET Forums (homeservershow.com)

Unable to connect to NAS from a specific computer


JROrtiz
 Share

Recommended Posts

I've been banging my head for a few days now trying to figure this out and I've run out of ideas. Hoping the very intelligent crew here can help me out.

 

I have a Drobo 5N and a Synology RS816 on my network, both of which have been working without issue for quite some time now. I've always connected to both via Windows Explorer by simply going to the network address i.e., \\N5 and \\SYN (sample names). 

 

I recently got a new desktop which is where the issues are coming up. When I try to go to \\N5, it results in a message saying it cannot find that location. However, \\SYN works just fine. What's strange is that I can see and manage the Drobo through the Drobo Dashboard software. What could be preventing Windows from seeing the Drobo on the network? 

 

I've already enabled the SMB 1.x protocol, ensured the workgroup names are the same, rebooted both the machine and the Drobo, made sure network sharing is enabled, and even did a fresh install to ensure that some program I installed didn't cause the issue. Every other machine I have can access the Drobo without issue. It's just this new desktop, and everything is running Windows 10.

 

Another strange phenomenon that I discovered is that if I go to "\\DROBO" (verbatim, not a sample name) it leads me to the Synology. Where is Windows getting the mapping from that it is directing that address to the Synology?

 

This is driving me nuts so any advice would be greatly appreciated.

Link to comment
Share on other sites

I have occasionally run into similar issues on my network. 

 

There have been a few cases where I couldn't figure out why PC-A wouldn't find NAS-B despite having what you've outlined set up.  Rather than spend more time on it, I've just made the NAS IP address static and mapped it in the hosts file in Windows (C:\Windows\system32\drivers\etc\hosts).  Then the PC always finds the NAS. 

 

I've never actually spent the time to figure out WHY this happens -- this is just a workaround that has always worked for me.  Once it's working, I lose my motivation for figuring out the issue's root cause and just use it.

 

Link to comment
Share on other sites

2 hours ago, BSR said:

I have occasionally run into similar issues on my network. 

 

There have been a few cases where I couldn't figure out why PC-A wouldn't find NAS-B despite having what you've outlined set up.  Rather than spend more time on it, I've just made the NAS IP address static and mapped it in the hosts file in Windows (C:\Windows\system32\drivers\etc\hosts).  Then the PC always finds the NAS. 

 

I've never actually spent the time to figure out WHY this happens -- this is just a workaround that has always worked for me.  Once it's working, I lose my motivation for figuring out the issue's root cause and just use it.

 

 

Thanks for the advice. I just gave it a shot and unfortunately that didn't work either. Still digging around to see what else I can try.

Link to comment
Share on other sites

After digging through tons of forums and sites and even trying to reach out to Drobo support, I was able to find a roundabout way of getting it to connect. I used the Drobo Dashboard software to mount one of the shares. As soon as I did that, I was able to see the Drobo on the network and access everything else, even after unmounting the share from the Dashboard. I still have no clue what was preventing this machine from seeing it on the network, but looks like once the Dashboard exposed it to the machine, it was able to pick it up. 

 

So strange but at least it's up and running now.

Link to comment
Share on other sites

Another update:

Looks like everything reset once I reboot. I have to remount a share through Drobo Dashboard again in order to be able to see it through explorer. I really wish I could figure out what is actually preventing it from showing up on this specific machine while the Synology works just fine.

Link to comment
Share on other sites

Welcome to the asylum!

 

There is another thread on this forum which offers some options, typically tinkering with Windows services. From memory one has to get about 4 ducks in a row … but no-one gave an explanation of the problem cause.

I had the same issue network-wide across W10 Pro machines running 1803.

None of the 'fixes' worked for me and I tried headbanging too 😞

 

1803 was the version where MSFT removed Homegroup.

I noticed (by accident) that the last devices to be upgraded from 1709 could all see others on the network.

So my best guess is MSFT screwed something up.

 

When I moved to 1809 I decided to go nuclear: I did a clean install of W10 1809 on ALL my machines.

No problems anywhere now.

 

SMB 1 … I thought that was unsafe and deprecated and a recommended removal?

Everyone should be using SMB 3 now - the best part of Windows 8.

https://blogs.technet.microsoft.com/josebda/2012/06/28/the-basics-of-smb-multichannel-a-feature-of-windows-server-2012-and-smb-3-0/

Does DROBO insist on SMB 1?

 

 

Edited by JackoUK
Link to comment
Share on other sites

I was thinking that this being a newer Windows machine might be the issue as well. Even though my other machines are on W10, they started with an "older" version of W10 compared to this one. 

 

SMB1 has been deprecated but I went in and enabled the SMB1 service manually and even then it doesn't work. At one point, it did pop up in the network neighborhood briefly but disappeared after a few minutes. It could very well be something to do with SMB1, but it works fine on all my other machines so I feel like there must be something else at play here. I've also tried disabling SMB1 on the Drobo to force a more up to date protocol and it didn't make a difference. For now I'll just have to have one of the shares mounted by the Drobo Dashboard. That seems to have gotten me around the issue until I find a proper solution. Definitely not giving up on this.

Link to comment
Share on other sites

"I was thinking that this being a newer Windows machine might be the issue as well. Even though my other machines are on W10, they started with an "older" version of W10 compared to this one. "

 

I guess it is the other way round: devices having been upgraded 'in place' rather than via 'clean install' do not interoperate properly with 1809's interface.

 

"It could very well be something to do with SMB1, …"

 

Most unlikely: I disabled SMB1 everywhere once the advisory came out. MSFT had long since abandoned SMB1, were removing Homegroup and upgrading to SMB 3: the new stuff, or the upgrade process thereto, is probably the cause.

 

"Definitely not giving up on this."

 

Wish you well … and have booked your appointment for head-trauma surgery … I'll probably be joining you after 1903 😉

Link to comment
Share on other sites

13 hours ago, JackoUK said:

...

 

Wish you well … and have booked your appointment for head-trauma surgery … I'll probably be joining you after 1903 😉

 

Haha! Thanks!

 

2 hours ago, schoondoggy said:

Not sure if it helps, but the latest Drobo firmware and dashboard allows you to turn if SMBv1.

 

Yeah I saw that and disabled it but it didn't solve the issue unfortunately

Edited by JROrtiz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...