Jump to content
RESET Forums (homeservershow.com)

Stock 200W PSU (DPS-200PB-189A) too weak to power a 1240 v2?


Recommended Posts

I recently bought a used 1240 v2 but can't get it to work properly in my Microserver Gen8.


It POSTs fine, but 9/10 times fails to boot FreeNAS (returning "panic: unrecoverable machine check exception" followed by some seemingly CPU-related error messages), and the one time it managed to boot it crashed from the slightest load.

When I run Memtest with the 1240 v2 in it, it constantly reboots at test #6 "Block move".

With a 1265L v2 in it it runs flawlessly - FreeNAS boots without an issue and there are no errors in Memtest.


I contacted the seller believing the CPU was faulty, then he told me that he had the same issue getting in to work in his Microserver Gen8, and that the solution was to use another PSU.

I haven't gotten around to try another PSU yet, but I find it a bit weird that the PSU would be the issue, because surely 13A @ 12V (156W) should be enough to power a 69W TPD processor.

I even tried disconnecting all the drives to leave as much power to the CPU as possible, to no avail...

And on top of that I've seen loads of posts from people having upgraded to 1230s, 1240s and even 1270s with no mentions of upgrading the PSU.


I'm running the lastest BIOS (2018.05.21) along with upgraded cooling (Akasa K25), so those shouldn't be the reason either.


Has anyone ever heard of this before?

Link to comment
Share on other sites

Highly doubt the psu is at fault here.

The specific error poins to ram. Or (by extension) the memory controller, which is part of the cpu!

Do you still have the original cpu? Replace the xeon and retest the server if you can. Should be the easiest way to rule out bad components.

Link to comment
Share on other sites

3 minutes ago, richu75 said:

Do you still have the original cpu? Replace the xeon and retest the server if you can. Should be the easiest way to rule out bad components.


Yes, I've put the original E3-1265L v2 back in and gave it a run in Memtest. After roughly 1h 15m it completed a full pass with 0 errors, whereas the E3-1240 v2 always fails and reboots at test #6, roughly 5 min into the pass.


I'm going to try the presumably faulty E3-1240 v2 in another system and see if I run into the same issue.

Link to comment
Share on other sites

That's my belief as well, unfortunately.

The seller claims it'll work flawlessly in another system, so I'll have to give his claim a shot, even though it sounds implausible.

Will get back once I've tried it in another system.



Link to comment
Share on other sites

This is starting to get weird now...


My mate tested it in his Ivy Bridge-based Dell workstation and it worked flawlessly...

One pass in Memtest with 0 errors and it booted his Windows-install without any issue.

The seller was right after all.


Next step is putting it back in my Gen8 and trying it out with another PSU.

Link to comment
Share on other sites

Ask the seller, what other system he tried it in? He may have popped it in a socket 1155 desktop motherboard without ECC memory. The memory issue may be related to the memory controller handling ECC memory. In your test did the Dell workstaion have ECC memory?

Link to comment
Share on other sites

10 hours ago, schoondoggy said:

Ask the seller, what other system he tried it in? He may have popped it in a socket 1155 desktop motherboard without ECC memory. The memory issue may be related to the memory controller handling ECC memory. In your test did the Dell workstaion have ECC memory?


Turns out it was non-ECC memory in the system my mate tried it in where he got it to work, so you seem to be spot-on.


In fact, I just tried it again in my Gen8 with a different PSU and got the exact same results.

I.e. the CPU works in a non-ECC system but fails in an ECC-system, so everything points to a bad memory controller in the CPU, as you said.


Now I'll just have to hope the seller accepts a return...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Cap_peeps
      By Cap_peeps
      Hellooooo everybody.
      As time has finally come and all required parts has arrived, I am presenting you my long struggling upgrade of the CPU + Noctua cooler.
      All is reversible with no permanent destruction. (At least, I hope ). And CPU fan is working according main case FAN.
      Upgrade is about to have a new CPU: Xeon E3-1270 V2 with noctua fan: NH-L9i, installed together and cpu fan would work according main case fan.
      (so if case fan spinning fast, cpu fan too. And vice versa).
      1, CASE:
      At first, the case needed to be modified little bit. I didnt want to drill out the original passive cooler mounting holders so I did a small workaround.
      I filed a holes for the screw headers on the outside frame (1) and also a longer hole in the ("I dont know reason why is there" ) "mountain" below CPU (2).
      pic 1:
      pic 2:
      2, SCREWS:
      As there was a hole in the screw holder on the motherboard plate, I had to find out the size of the screws, thread, diameter and so on.
      But in another topic on this forum I was asking for the help with that, and somebody replied that I can use application and screw compared with different sizes.
      So I did that and found out that the right size of screw is: #6-32.  So I had to ordered them (toghether with screw nuts) from China because I couldnt find them in our country stores.
      3, BRACKETS:
      It is known, that Noctua original brackets were longer in size, 75 vs 65 mm. So I had a luck and asked our local CNC machining store if they could make a new brackets for reasonable price.
      So here we are: 65 mm brackets for Noctua fan.
      pic 3:
      (The new ones are not labeled)
      4, COMPLETING:
      After months of waiting, I've got all necessary parts and installed them together:
      https://ibb.co/0D2rN5g - screws in the motherboard plate.
      https://ibb.co/w74Z27B - Noctua fan cooler mounted with screws and nuts.
      https://ibb.co/RBNMfRX - with fan.
      https://ibb.co/nC94fs1 - reason for the hole.
      5, FAN - Most tricky part
      This was interesting part as we all know that the signal in the case fan is inverted and it is hard to workaround it. But after some hours of googling I found the solution.
      There is IC chip existing which can invert the signal in the opposite way. The chip is: 74HC04 and you should be able to get it easily.
      So with this scheme I found, it was really simple to create a new CPU fan cable: 
      Here is mine: (I also used the mentioned guide with power sourcing from separate molex, another topic on this forum)
      https://ibb.co/YfKZWh8 - on the left - it is first attempt. I didnt like it much so I created a new one on the right. Much better result.
      https://ibb.co/CQ5Kw0z - completed setup. I changed the case fan connector to usual one. The cable with chip inside was put into shrinking tube. 
      So with all this, I installed everything together and now the new CPU fan works the exactly same way as the main case fan.
      The next steps I would like to finish are: (probably more software-ish).
      As I still have the original BIOS, firmware and all this, I would like to update them.
      So maybe the question will be put here: what do you recommend to update first ? Or is there any guide how to update all possible things on this server ? in the correct way ? is it deppend on the right order ?
      Also I realized that I am still using the system SSD disk on the first slot in the bay, so is there any way how to use SSD disk independently and the whole 4 bay slots for the storage disks ?
      Another thing is that when I run some "stress" test on the server, all 8 cores at 100%, they went to 80 degrees and increasing, but when I checked the iLO, I saw the the fan was spinning only on 18%.
      After some time on 21%, what I guess is not much. So I need to check the cooling options which are in BIOS, I guess. Also I am not sure if this is because the old BIOS ? Shouldnt be fan spinning more if the CPU has big load ? 
      I think that's all my thoughts, ideas and I hope that maybe it helps somebody.
      Many thanks again for all your hints and help.
      Have a great days. cheers
    • Mikey70
      By Mikey70
      After a shutdown my perfectly working HP Microserver gen8 with Windows Server 2016 didn't start again. In the HPE Smart Storage Administrator everything looks fine, the arrays are in place, but Windows don't seem to recognize it anymore. If I try to boot from the installation media I'm unable to load the b120i driver, the installtion just hangs. If I use Intelligent Provisioning I'm afraid to start the installation because it sais:
      Pressing continue will install the  selected operating system and will reset all drives to a freshly installed state. Data currently on this server will be lost. This is normal when installing an operating system.
      I choose to keep all array settings in the beginning of the guid. I'm ok with my system disk being wiped clean, but I don't wan't to loose the stuff that's on the other disks, there are photos, documents there that I need.
      Does anyone know if the other disks are safe if I press continue? Or if there is a way to get the smart array recognized by Windows Server again?
    • ColinBrough
      By ColinBrough
      I've a N36L Proliant Microserver that has been happily sitting on a shelf doing NAS type stuff since 2011. I was away last week, and came back to it dead. It now won't switch on at all. No lights, no flickers of LEDs when power on switch pressed, nothing - so no real diagnostics! Checked fuse, checked mains power, all OK.

      I'm presuming its a blown PSU - is that a good guess?

      And, given the age of the machine, I'm suspecting it is likely to be best to simply replace it with a Gen8 replacement rather than faffing around trying to replace a PSU (which may or may not be the cause of the failure). Or is it worth trying to salvage?

      (I'm hoping the disks in the machine survived the failure - there's a 6TB WD Green, a 2TB WD Green, a 250GB Seagate and a 750GB Samsung in there at the moment. Running XUbunutu.)
    • BJWTech
      By BJWTech
      I have the OEM PSU for my 2 G7 Microservers. One is a N36l and the other is a N40l. About one year ago I replaced the 40MM Fan on both with a lower noise Sunon fan. They were pulled whilst working.
      I will charge $20 for each plus shipping.
      Let me know If you are interested!
      Edit: Typo....
    • ravikk
      By ravikk
      Hello Everyone,
      I am new here. I am the system administrator for a compute cluster in a Research group in MIT. I am looking for an answer to a specific issue, that is currently causing a downtime for our Cluster. The Distributed file system linked to the server has two hot plug, redundant Power Supply Units, and both of them have failed. The PSU's are made by company called t-win and I can't find anything online about it, except for a few sites in Russian. Any advice on where I can procure the same part, or any other alternatives that I can find in US that would match my requirement would be incredibly helpful. I have left all details I can find about the PSU below:
      1) Make: t-win
      2) Model Number: PSM-SRA10E-Z-R  (ROHS)
      3) AC INPUT: 100-240 V, 43-63 Hz, 15-7A
      4) DC OUTPUT: 1010W (MAX)
      +12V    83A    -12V   0-0.8A
      +5VSB   0-3.5A
      SER. NO: T11948794 26E1190089
      P/N: B013450001
      I have attached a couple of pictures of the PSU along with the post.
      Thank You,

  • Create New...