Jump to content
RESET Forums (homeservershow.com)

Windows 10 Will Not Upgrade - Legacy SATA an option?


skinfreak
 Share

Recommended Posts

Hi there,

Over the many years of using the Gen8 there always seems to be some problem!! ;-)

 

I have Windows 10 Pro install to a HDD in the ODD. The 4 3TB drives in the other bays, configured via Storage Spaces. BIOS set to AHCI and I have made use of the usb boot key to map the boot to the ODD bay. All has been resonably well for well over a year however I was never able to get Windows to update. Now I'm getting warnings that the software will be unsupported and have tried several times to do an upgrade but frequently get errors such as the installer cannot detect how much space is availble. I think that's because of the USB key.

 

I don't want to go back to square one and reinstall if I cannot help it but has anyone else experienced this? I seem to recall having problems with using the B120i but cannot for the life of me remember why I stopped using it... but I know that changing to Legacy SATA should remove the need for the USB boot mapping.

 

Thanks!

Edited by skinfreak
Link to comment
Share on other sites

Ha ha! I solved it. The answer should have been obvious as the answer was hidden in my problem but for anyone interested:

 

1. Change the boot priority in the BIOS to boot to SATA drives. One time boot will not work as Windows needs reboots to put the updates through.

2. Switch off the server

3. Pull all drives apart from the ODD.

4. Reboot and run windows updates.

5. Once complete, change the BIOS back to boot from USB and reinsert the data drives.

 

Fun times!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...