Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
NorthantsAndy

ProxMox, MDADM, Lost Raid after Reboot

Recommended Posts

NorthantsAndy

Hi all

 

I have two microservers: a Gen 10 and a Gen 8.

 

Decide to rebuild both and the Gen 8 went fine, the Gen 10 has an annoying issue.

 

I am using ProxMox VE and so, am using MDADM to create the raids (in this instance RAID5).

 

Using the instructions at https://www.petermstewart.net/proxmox-software-raid5-on-hp-microserver-gen8/ I have got /dev/md0 RAID drives running happily.

 

HOWEVER

 

The Gen10 on reboot loses the raid array everytime.

 

I can get it back with the following code:

 

mdadm --create --verbose /dev/md0 --level=5 --assume-clean --raid-devices=4 /dev/sd[b-e]

(my drives are sdb, sdc, sdd, sde)

 

When I run 

 

update-initramfs -u -v

(Update, verbose mode)

 

A few times I was told the UID doesn't tally between mkconf and mdadm.conf sort this out.

 

A few other times I was told there was no issue at all.

 

For each outcome above, rebooting leads to the same result: no /dev/md0 

 

I create a file on /dev/md0 (simple text file) and every time I 'recreate' /dev/md0 it's still there.

 

Now, by running the mdadm code above everytime I reboot, I can access and use the RAID drive, but it's bitty and I want to get this sorted, it's annoying me.

 

Any ideas? Is it a uniquely Gen10 thing?

Edited by NorthantsAndy

Share this post


Link to post
Share on other sites
schoondoggy

Is the Gen10 BIOS set to UEFI or legacy boot?

Share this post


Link to post
Share on other sites
schoondoggy

Are the drives that are dropping, just the four in the front bays? At one point in time I think Proxmox had issues with Marvell controllers like the 88SE9230 used in the Gen10. I would look into that.

Share this post


Link to post
Share on other sites
NorthantsAndy

Sorry for the delay.

 

I can access them if I re-run mdadm and ignore the disk states.

 

On reboot the four at the front (not the ssd I have to boot off) are lost and the /etc/fstab settings don't work.

 

Thanks for the headsup SD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...