Jump to content
RESET Forums (homeservershow.com)

Windows 10 poor performance on SSD


Nite
 Share

Recommended Posts

Hi All,

 

New user here & long time owner of the old N40L which has been performing really well for numerous years now. Now that the Gen8 is end of life and the Gen10 has started to become available I ran into some luck with one of my local suppliers last week who happened to still have a single Gen8 Microserver in their warehouse & offered it to me at the same price I paid for my N40L back when HP were still offering rebates on the purchase. Now, I'm completely new to servers in general so mucking around with things like iLO and RAID on this Gen8 is a bit daunting and I'm still trying to come to terms with how to do things in the proper manner however over this weekend I made a homemade FDD to SATA power adapter & installed a Transcend 128GB SSD in the ODD port, I then proceeded to create a single disk RAID 0 array on the SSD (did this by hitting F8 during boot when it showed the B120i startup test/info) and boot off of a USB to start the Windows 10 install.

 

First problem I ran into was the RAID drivers however I managed to get a link to ones that worked somewhere in the forum, next hurdle was the setup seeing the disk with 3 varying partitions and refusing to install however I managed to get past this by deleting all of the partitions so that the setup sees the disk as unallocated space and then having the setup create it's own partitions. This worked well enough and Windows installed shortly thereafter however since then I have been experiencing extremely poor performance within Windows where it takes abnormally long to boot, windows takes long to respond when trying to do things such as open the file explorer or launch programs and also has the habit of freezing for 3-4 seconds. I've seen vague svchost info logs in the Event Viewer where it complains about cache files taking longer than expected to write as well and the Windows doesn't seem to want to shut down properly (guessing this is something to do with Win10 fast startup, reboot works without issue)

 

I've still got some troubleshooting I need to do once I have the chance to cover all my bases however I thought I would post here to see if anyone has experienced something similar & could point me in the right direction? Most of the stickies & useful links seem to be more directed to Win 7 & 8 and I'm never quite sure what info is still relevant due to age. I did Windows updates to install any drivers it might have and also ran the driver update utility from DRP.su to update all the drivers I could, currently the only driver I seem to have issues with updating on the DRP app are for the RAID controller and I'm wondering if this could possibly be the root cause of the issue? I also ran the Intelligent Provisioning as a last resort to do the firmware updates, IP proceeded to update iLO as well as did an update for Intelligent Provisioning, this caused a new problem for me, if I now try access IP by pressing F10 during boot it loads the first screen where you select your country, time & timezone etc and instead of autodetecting this via internet it all remains blank & I can do nothing other than force power down the machine (mouse cursor moves but I can't seem to interact with anything on the screen). I also noticed iLO mention that some or other self test failed when I last started up the server but haven't had the chance to log into iLO yet to see what the problem is. 

 

TL;DR

1) has anyone experienced poor or abnormally slow performance with a clean Windows 10 install on an SSD in the ODD port (B120i enabled, disk in RAID 0) or have advice on how to troubleshoot? Possibly even point me in the direction of up to date Storage Controller drivers for the server that work in Windows 10 (I've tried the Server 2016 drivers from HP's site, installer refuses to run due to incorrect OS, did not try extract the drivers yet to manual install via device manager)

2) Is there a n00b friendly guide to getting the BIOS & related firmware up to date? I'm busy downloading the SPP from the link posted by Robertomcat at the end of page 6 on the HP Microserver Gen8 - Service Pack for ProLiant - 24th Oct 2016 thread with the hopes of being able to figure out what to do with it when it's done (also hoping that's the current SPP)

The plan is to use the server as an HTPC, home NAS and maybe even couch gaming PC so I'm hoping to stick to Windows 10 (also the only OS I currently have a license for). Once I've had the chance to check the error in iLO and maybe get the Intelligent Provisioning functioning again (it worked all of once for me, starting to think I shouldn't do firmware updates haha) the plan was to deploy Server 2016 eval to the SSD through Intelligent Provisioning to see if there's any difference in performance on a "supported" OS. Other than that I guess I could set the SATA to AHCI mode in BIOS and see if that makes a difference and just use the MicroSD card guide when I install the storage drives. 

 

Any help or advice would be greatly appreciated, even if it's to point out that I did something stupid.

 

Regards,

Mark

Link to comment
Share on other sites

You should register the MS Gen8 with HPE, as it is new you should have access to SPP and BIOS straight from HPE. Server 2016 drivers work with Windows 10. If you switch to AHCI you will need a boot loader on the microSD to boot from the 5th SATA port.

Link to comment
Share on other sites

Hi schoondoggy, thanks for the response. Didn't have as much free time as I would have liked last night but I did try register the server with HPE as suggested, unfortunately for some reason I had no luck registering the server against my HPE Passport. Decided from there to just write the SPP I grabbed from the forum link (from what I can tell this is the current one) to USB and boot from that, this had an additional iLO update (think it was to v2.65) as well as a Broadcom update. Once the updates were completed I booted into the iLO to try see what error it had complained about yesterday morning however all was healthy and this time Intelligent Provisioning was functioning (might have been a user error, I had a bootable flash drive plugged in with Server 2016 install media on it which might have caused the issue), tried to register the server through IP against my HPE account however that also failed :( Also couldn't figure out how to use Intelligent Provisioning to install Server 2016 using a bootable flash drive nor with an ISO on a USB drive, going to read up on how that works a bit more today as well as apply for the iLO Advanced trial license to try mounting the ISO to virtual CD/DVD.

 

Only issue I'm left with currently is still the poor SSD performance within Windows 10, next plan of action is to just get Server 2016 installed through IP and if that performs well I at least know it's a software/driver issue.

Link to comment
Share on other sites

Hi all,

 

Just an update if someone comes across this post with the same issue, it seems I've managed to come right, only gripe I have with the system now is the cruddy Matrox integrated display. I ended up deleting the RAID array for the SSD in the storage manager and then recreated it, after this I re-installed Windows 10 and it performed a lot better than previously. I also managed to install the Server 2016 storage drivers by extracting the downloaded file with 7-Zip, running the extracted setup file seemed to bypass the OS check (if that makes sense). Next step will be to get a GPU and disable the Matrox one, really wish they'd used Intel's integrated display

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...