Jump to content
RESET Forums (homeservershow.com)
RyanG8

HP Proliant ML350p G8 Watercooling!

Recommended Posts

ook4mi
31 minutes ago, XeonUnicorn said:

OS - W10

How the hell did you successfully install Windows 10 ? From USB or CD ? Is it a familly edition or pro one ? Did you upgrade from a lower version of Windows ?

 

I did a memory test and all memory sticks are OK no error :(

 

Where you from ? US ? Engineer ? What is your speciality ? Electricity ?

Share this post


Link to post
Share on other sites
XeonUnicorn

I don't have a good grasp on the software side per se. This is the realm of my tech friend, I can do basic end user software tasks. We used USB to install W10. 

 

I am an unqulified engineer in the field of CNC precision engineering, and General fabrication. I apply this knowledge to fabrication of hardware and computer components. 

Share this post


Link to post
Share on other sites
XeonUnicorn

More updates to follow, very drunk lawls! 

Share this post


Link to post
Share on other sites
XeonUnicorn

Hi all, 

 

I think it has been mentioned previously that pwm for the fans is BIOS controlled, this has some interesting implications, some theory, some tested and confirmed. 

 

Theory one is that fans one and four are pwm based on ram temp sensors, later testing may confirm this. 

 

Theory number two (very strong reason to believe this) is that fans two and three are pwm based on cpu temp sensing. CPU temp goes up and fans modulate accordingly. Currently getting temps of 22-37 degrees average at idle. 

 

Through testing we confirmed that whatever the case is pwm is always happening even when the system is off but power is still being supplied i.e. power button flashing orange. With a fan connected by an external 12v supply and being given a pwm signal from the fan connector pwm occurs.

 

With this information in mind we got to work. RyanG8 has achieved pwm from a software side using CorsairLink and a Corsair Commander device and I had it in mind to do the same thing and may do so if theory one proves false but we wanted to play around and see what we could do. 

 

At first we tried to be way to clever and build an arduino device that read the pwm from the fan controller and then managed the pwm through some code to stay within the limitations of the AIOs fans.... to hard basket lol. In the end we kept it very simple and built a module that has its own 12v supply and a pwm only from the fan connector:

 

 

20200209_182028.thumb.jpg.ff05a966cdac8875bfbef839eb5868fe.jpg

 

The two front headers are being given a pwm signal from fan twos pwm and the third header is given a signal from the theoretical ram pwm or fan four. The two pin header is the pwm supply, 12v supply is from a sata power cable. 

20200209_182046.thumb.jpg.e9c2166270066294d23dc810218bbc67.jpg

The fan connector now looks like this under the heat shrink

 

20200209_182111.thumb.jpg.c62bdfa552718764000ec3013e1f8192.jpg

Running without issue and no erroneous errors during post. I will post again when more testing has occurred for the "ram" pwm which will go out to two 80mm fans mounted at the rear of the chassis. 

Edited by XeonUnicorn
  • Thanks 1

Share this post


Link to post
Share on other sites
XeonUnicorn
On 2/9/2020 at 10:53 AM, ook4mi said:

How the hell did you successfully install Windows 10 ? From USB or CD ? Is it a familly edition or pro one ? Did you upgrade from a lower version of Windows ?

 

I did a memory test and all memory sticks are OK no error :(

 

Where you from ? US ? Engineer ? What is your speciality ? Electricity ?

Try resetting your bios and installing from USB. Failing that try an Ubuntu (Linux) install to see if it can load up an OS. Remember though this string is for hardware mods around cooling so looking in another string will probably be better. 

Edited by XeonUnicorn

Share this post


Link to post
Share on other sites
ook4mi

You looks to have a lot of fun. :D

 

how is your build now ?

 

 I tried Pop Os (I have a Nvidia graphic card). I can play on it the only problem : it detected only one cpu :o .

 

 I updated intelligent provisioning and I successfully installed Windows but it goes to recovery each time I tried to boot on it. 
 

It is driving me crazy. 

Share this post


Link to post
Share on other sites
XeonUnicorn

Are you trying to install W10 Home or Pro? 

Share this post


Link to post
Share on other sites
ook4mi
On 2/15/2020 at 11:00 PM, XeonUnicorn said:

Are you trying to install W10 Home or Pro? 

I tried both without any success... At the moment, I'm running PopOS (Linux). All is running pretty well so I'll stay with Linux. Thanks for your help ;) .

 

How is your build ? What did you improve ? Last time you show sata cable so did you add HDD ? How many ? ;)

Share this post


Link to post
Share on other sites
XeonUnicorn

That's a strange one mate, I'm stumped for ideas on your OS install. 

 

In the process of some more case mods, will come back with info in a month or so. 

Share this post


Link to post
Share on other sites
DenKarp

Hello all, 

 

I have previously posted before on this thread and have been using my ML350P G8 server as a home computer for the past 3-4 months successfully after doing some hardware changes to make the unit cooler and quieter (thank you RyanG8 for the wonderful guidance in regards to tying the grounds on the fan connectors!).

 

Here is what I have so far and could maybe help someone that is deciding to Frankenstein the same (similar) machine. 

 

Some specs to start: 

 

System_Summary.thumb.PNG.0518ef6e931bfc0edb61b69097e66228.PNG

 

I have put in a AMD Radeon R9 390x Sapphire Nitro 8GB GDDR5 Graphics Card in order to play some games and work on some CAD software. Does really well actually, considering its a 5 year old card. Here are some Star Swarm Test results. These are settings at extreme. Note: I have also included a manual voltage regular that I can adjust myself. I kept voltage on this test at 7v (max allowed is 10.9. Restriction due to the regulator unit and not power supply.) Will mention the fans I utilized instead of the stock in a bit, but if I bumped up voltage to max the results would be better with the excess cooling.

 

Oxide Games
Star Swarm Stress Test - ©2013
Version 1.10
12/24/2019 08:18
===========================================================

== Hardware Configuration =================================
GPU:        AMD Radeon (TM) R9 390 Series
CPU:        GenuineIntel
               Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
Physical Cores:            16
Logical Cores:            32
Physical Memory:         137402523648
Allocatable Memory:        140737488224256
===========================================================


== Configuration ==========================================
API:                DirectX
Scenario:            ScenarioFollow.csv
User Input:            Disabled
Resolution:            1920x1080
Fullscreen:            True
GameCore Update:        16.6 ms
Bloom Quality:            High
PointLight Quality:        High
ToneCurve Quality:        High
Glare Overdraw:            16
Shading Samples:         64
Shade Quality:            Mid
Deferred Contexts (D3D11):        Disabled
Small Batch Optimized (Mantle):        Enabled
Temporal AA Duration:        16
Temporal AA Time Slice:        2
Detailed Frame Info:        Off
===========================================================


== Results ================================================
Test Duration:            360 Seconds
Total Frames:            11802

Average FPS:            32.78
Average Unit Count:        4304
Maximum Unit Count:        5544
Average Batches/MS:        555.43
Maximum Batches/MS:        1062.15
Average Batch Count:        17724
Maximum Batch Count:        123227
===========================================================
 

Below is what I did/used for the replacement of the very loud Delta fans. As mentioned in previous posts on the thread, this unit will not function and will give you post codes regarding fans if the fan ground inputs are not tied (or fans are disconnected).Tying the two ground black wires on the connector side for the delta fans does the trick. Was NOT able to bypass this in any way since there are really no fans out there available that are quite and fast enough in order to mimic the deltas rpm pulse. Here is a photo of what each fan slot (4 of them) in the bay looks like after jimmy rigging. 

 

(note: the 4 slot rigged wire corresponds to the two black wires on the connector)

20190720_170738.thumb.jpg.edde5abe1ef053547b9fe01bb5480bc4.jpg

 

(Note: I used some connectors from a junked computers sata power ports that has 4 slots. Since I needed to only tie the two black wires, it works as required. Decided not to cut the wires directly from the connectors on the fan chassis since maybe one day I would need them for my delta fans. Could just pull them off and reinsert originals)

20190720_170813.thumb.jpg.8f1943ebcd07184849c239d4a4207b44.jpg

 

Since I needed to use different fans and the connector would not fit in its original retaining bracket with the fans I just tucked everything in all nice nice. (Note: four wire wire in the background is from the new fans.) 

 

20200220_193437.thumb.jpg.04fc3b04b8daf621a05646e88811ba2b.jpg

  

At one point I thought I would keep the delta fans on here and create a sort of tunneling effect towards the CPU's original heat-sink but that didn't work out very well. They just blow (pun intended) at keeping the CPU's at proper temps. At Idle it was about 10 degrees C cooler or so but once i started putting some load on, the fans just revved up and created a lot of noise. 

 

20190720_174120.thumb.jpg.ca321c872bb980889a3ef488682f2c05.jpg

 

Even tried to apply the tunneling affect to the newer quieter fans with the closed ground connector jimmy rigging and it was doing a lot better than my previous attempt (whilst also placing little cheap fans near the CPU's) and it would just thermal throttle (at 92 degrees C) under stress and just said screw it, will get myself some proper, beefier heat-sinks. 

 

Note: Sorry cannot upload any more images due to to size restriction. Will continue on a different thread post. 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Sokoban
      By Sokoban
      Hi 
      My HP Proliant Microserver Gen 8 won't install HP Tools when I have running HP Smart Update Manager. 
      even when I have trying to install via Intelligent Provising, Windows Server 2019.
       
      Se image below 🙂 That's I missing.. ;-(
       

    • Karazzi
      By Karazzi
      Hi everyone.
       
      New to this forum.
      I have a gen8 microserver running at home, where I have installed an SSD in the ODD sata slot. On the SSD I have installed Ubuntu Server 18.04.
      I have then created a logical volume witht the raid controller and can then boot to the SSD. So far so good.
      My problem emerges when I reboot the system. The logical volume disapears and it gives the error: "boot logical drive is configured but is missing or offline".
      I then have to go into the utility and reconfigure the logical volume. Kind of annoying, when trying to run a headless setup.
       
    • Mark Belanger
      By Mark Belanger
      Greetings,
       
      I'm new to the HPMSG8 world and so far I'm loving it. I have a stock Xeon with 16G of aftermarket memory with iLO patched to 2.70. Next up is adding a RAID card, so I can put my boot SSD on the onboard RAID. I picked up a LSI SAS9211-8i on Amazon, but am struggling to flash it to IT mode on the MicroServer. Is this even possible? Unfortunately, the only other system I have with PCI slots is 32-bit.
       
      Any pointers would be greatly appreciated.
       
       
      -MB
    • iwilltry
      By iwilltry
      Hi there,
      I hope this topic fits here just right.
      So a few days ago, I moved my Microserver Gen8 to a friend's place and resetted it.
      When we set it up with new disks, the raid-creation in OpenMediaVault (Debian 9.6) failed.
      `smartctl` tests passed just fine though and vendor-tools also didn't report any drive errors.
      What happened?
      - I start the Raid creation via `mdadm` and after a while (random blocks and times), it fails and the second disk seems to fail (e.g. sda and sdb are creating a raid, then sdb gets "kicked out" and reread as e.g. sdd, sometimes even with only a few GB of space instead of 3TB).
      I tried attaching the second disk on ata2 and ata3, but it keeps failing. The one on ata1 works just fine though.
      I tried different disks and vendors, but get the same results.
      There are some errors in `dmesg`, but I don't know what they mean. I pasted them here: https://pastebin.com/raw/XASQJ6cy
      What I did here: I stopped the raid to re-create it, but then didn't do anything for a while and the error still came up.

      Can someone help me with this? (As a wild guess, I'd say that somethings wrong with the SATA connections at least on ata2 and ata3).

      Thanks in advance
    • stoney73
      By stoney73
      Wonder if anyone can point me in the right direction here. Have just replaced the CPU on my gen 8 microserver. Went according to the video above. Upon booting the server up, there is a clicking sound coming from the main board. Regular as clockwork, and the server isn't posting. Any ideas? I've swapped back to the G1610T CPU, but still the same issue. And just make it interesting, I don't have access to a monitor or keyboard.
       
      https://photos.app.goo.gl/zyLJWBZQ4mTQ818o2


×
×
  • Create New...