Jump to content
RESET Forums (homeservershow.com)

Network cards in "Safely Remove HW list"???


npapanik
 Share

Recommended Posts

As in screenshot the Network cards of the Gen10 are shown in the removable list... As you can see I have the latest drivers and firmware for the two cards. This is a very annoying issue since you can accidentally lose network connectivity while ejecting an external USB device.

 

FYI the four disks installed at the front bays (Marvell controller) had the same issue but I fixed it by following MS's article:

https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media  

eject.JPG

Link to comment
Share on other sites

Windows Server 2016 Std, b1607.

 

I opened a ticket to HPE but after a bunch of useless back and forth emails they said its the OS... (surprise!).

 

I found the solution myself yesterday and will post the steps later on.

Edited by npapanik
Link to comment
Share on other sites

- Go to "Device Manager" and right click "Properties" of the Network Card 

- Go to Tab "Details", Property "Device Instance Path" and copy the last number (after the last "\")

- Go to registry to the path "[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI"

- Search for the value that you have copied earlier (from the Device Instance Path)

- Look at the right pane: you will see a REG_DWORD named "Capabilities" with the value "14" (Hexadecimal).    Change it to "10". If you get a permissions error you will have to change ownership to the specific key and put your account to have full control.

- Do the exact same for the key exactly below (the other network card of the Gen10)

Note that after reboot the value reverts to default (14) so:

- Create a reg file e.g. removenetwork.reg with contents (change to your values  accordingly):

Windows Registry Editor Version 5.00

 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_14E4&DEV_165F&SUBSYS_22E8103C&REV_00\000070106FCA7D9200]
"Capabilities"=dword:00000010

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_14E4&DEV_165F&SUBSYS_22E8103C&REV_00\000070106FCA7D9301]
"Capabilities"=dword:00000010

- Create a batch file e.g. remove.bat with contents:

reg import your path\removenetwork.reg

Create a Schedule task to run this batch file when you a user logs on...

 

That's it!

 

 

Capture1.JPG

Capture2.JPG

Capture3.JPG

Capture4.JPG

Edited by npapanik
Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • BooyaK
      By BooyaK
      Hi all
       
      Apologies for hijacking a new thread as I couldn’t easily find an existing post which described this..
       
      I have an original HP Microserver N36L from 2012 that am Iooking to upgrade to a Gen 10 Plus.
       
      In the N36L I have added a Smart Array P410 with 256MB FBWC (via ebay) configured with 4 x 2TB WD Green drives with RAID5 (6TB logical) along with a 256GB SSD as a boot system drive in the ODD bay (with the BIOS mod of course) plus a PCIe x1 video card.
       
      The server is running Windows Server 2012 R2 but looking to uplift to 2019 (and maybe 2022 once it comes out) for general home enthusiast use mainly as a file server and to test VMs for labs.
       
      Am I able to “lift and shift” the drive array subsystem from the old to new server? I have done this on the DL380s in the past as the controllers and drives hold the RAID config.
       
      I guess I’m happy to get a new boot SSD if required (maybe boot issues between AMD and Intel CPU) but may have constraints mentioned below with the 5th interface.
       
      Have read from the various great posts by schoondoggy etc. that the P410 has issues with UEFI etc, so looking at a compatible option that’s not the “latest and greatest” eg something that can bought via ebay second-hand and relatively inexpensive (the E208i-p maybe stretching it…) and can of course read the existing RAID5 array config from the drives.
       
      Once moved across, I plan to progressively update them to larger HDD or SSDs and use the Smart Array expansion utility to expand the RAID-5 logical drive size once array rebuilds are complete.
       
      From what I understand I can’t add the 5th drive as there is no onboard NVMe or SATA connector. There is USB3 to boot off a thumb drive of course which is great for VMWare ESXi but maybe not for Windows…
       
      If I add the Smart Array card I guess it may limit my options as I understand it only has one PCIe x16 slot so can’t do both.
       
      Does anyone have any suggestions or other techniques (for example I’m not fussed with the expansion iLo slot but I think dedicated for that purpose only)?
      I have also looked at some of the great Servethehome reviews and benchmarks too but these are early 2020 and things may have evolved since then.
       
      Thanks in advance!
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • DonTen
      By DonTen
      I have Windows Server 2016 Essentials (an in place upgrade from 2012R2 - I know but that is what it is).
       
      I have two modern clients: Dell XPS 13 7390, which fail to load the WinPE / Full Client Restore wizard both from the network and from a USB key. They blue screen with a KMODE_EXCEPTION_NOT_HANDLED error. Older clients load the Full Client Restore wizard successfully both from the key and the network.
       
      I have tried installing the latest Windows 10 ADK (2004) and re running the Client Restore Service set up from the Dashboard. Although this creates new folders in the ClientRestore folder within Program Data it does not update the version of WinPE reported in the boot images in Windows Deployment Services which is 6.3.9600 (Windows 8.1). This seems as if it may be a hangover from the 2012R2 installation. 
       
      There was no WinPE or ADK application to uninstall before I installed the latest ADK, so installed it and hoped for the best.
       
      Has anyone any suggestions as to how I can get the Client Restore service to use a later version of WinPE without breaking the Essentials set up?
    • hfournier
      By hfournier
      I'm putting together a build for a non-profit client and I want to make sure they're getting the best bang for their bucks.
       
      Current server:
      HP MicroServer N40L 8 GB WS2012E Plextor PX-256M5Pro SSD - OS drive SAMSUNG HD103SI 1TB (x2) - Data drives (Storage Spaces) WDC WD20EZRX 2TB (x2) - Data drives (Storage Spaces)  
      On the new server, I'd like to setup the OS on SSDs (RAID 1) for speed and redundancy. Trying to squeeze extra SSDs on the Gen 10 Plus lead me to using the PCIe card. I guess on the Gen 10 there's enough room and SATA connections to put a couple of SSDs in the Optical bay instead. And, I'm leaving 1 drive bay empty to add another 2 TB should they need it, which is not likely.
       
      New Server Option 1 ($2084 CDN):
      HP MicroServer Gen 10 X3418 (P07203-001) 8 GB 8 GB Module - DDR4 2400MHz (Kingston KTH-PL424E/8G) WS2016E StarTech.com Dual M.2 PCIe SSD Adapter Card - x8 / x16 Dual NVMe or AHCI M.2 SSD to PCI Express 3.0 - RAID & JBOD (PEX8M2E2) Samsung 970 EVO 500GB NVMe M.2 Internal SSD (MZ-V7E500BW) (x2) - OS Drives (RAID 1) WD Gold 2TB (x3) - Data drives (Storage Spaces, or can I RAID 5 them?)  
      New Server Option 2 ($2362):
      HP MicroServer Gen 10 Plus (P16006-001) 16 GB WS2016E StarTech.com Dual M.2 PCIe SSD Adapter Card - x8 / x16 Dual NVMe or AHCI M.2 SSD to PCI Express 3.0 - RAID & JBOD (PEX8M2E2) Samsung 970 EVO 500GB NVMe M.2 Internal SSD (MZ-V7E500BW) (x2) - OS Drives (RAID 1) WD Gold 2TB (x3) - Data drives (Storage Spaces, or can I RAID 5 them?)  
      So two questions for all of you:
      If anything, what would you change and why? For the extra $278 (13% more), is the Gen 10 Plus worth it?  
      Thanks.
       
    • Angelus
      By Angelus
      Good day all
       
      i bought a gen 10 x3216 MicroServer and I have been trying to install windows server 2016 on it with a usb and I get it to boot into the usb with the iso on it but I can not get past the one install step where u supposed to select the drive.
       
      instead it says to download storage drivers and browse to select driver. I have downloaded every single storage driver from the hpe site or is sure does feel like it.
       
      if I try to select the driver I have to do so manually by unticking show only compatible drivers because if I leave it ticked there is nothing compatible. Iam stumped on what the correct driver is.
       
      ok so what Iam trying to do isssssss I want to install the os onto the usb that I have attached inside the box the one that is directly coming off the board. Is that a different driver ? 
       
      In bios/boot up options I can see all usb connected.
       
      can anyone please help me with this 
×
×
  • Create New...