Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
razormw

Microserver Gen10 CPU limit

Recommended Posts

razormw

Hi, I have an HPE Proliant  Microserver Gen10  x3216  with ubuntu server installed. 

 

Recenty i decided to check my CPU frequency (in ubuntu and in the EFI) and i realised that it only runs at 1.6Ghz max even though specifications claims that it can go up to 3.0Ghz.

Do you know if there is something i can do about it? I´ve already called HPE to ask for help but the only answer i got was "we do not support overclock" even though it´s not overclock because the values are withing the factory limits that they claim it can work.

 

I tried to make several stress test and put the server under heavy CPU loads but all i can get is 1.6Ghz.

 

Sorry if i made any mistakes , english it´s not my first language.

 

link to APU specs: https://www.amd.com/en/opteron

Edited by razormw
link to specs

Share this post


Link to post
Share on other sites
schoondoggy

What did you use to stress test it?

Share this post


Link to post
Share on other sites
razormw

Stress and cpuburn,  in single and multi thread mode. I´m aware of this AMD CPU limitations regarding CPU boost when all cores are active.

I did a little research and the issue seems to be related to AMD CPB(core performance boost),  when all cores are enabled the CPU doesn't enter in boost mode, only enters when 1/2 or less of the cores are idle.

 

 

Share this post


Link to post
Share on other sites
schoondoggy

Good research, good to know. I would have expected it to enter boost regardless of cores active.

Share this post


Link to post
Share on other sites
npapanik

On my Windows Server 2016 Gen10, my X3216 (2 core) CPU cores run between 2.1GHz and 2.5GHz when I stress it with Prime95! Consider that the Graphics cores are not used, so its TDP allows the boost... In all other (less stressful) scenarios both CPU cores go to 3.0GHz easily.

x3216.JPG

Edited by npapanik

Share this post


Link to post
Share on other sites
itx

@razormw

CentOS 7.4 , amd-gpu drivers installed , x3216 CPU

[itx@localhost ~]$ sudo cpupower monitor
    |Mperf               || Idle_Stats         
CPU | C0   | Cx   | Freq || POLL | C1   | C2   
   0| 87.85| 12.15|  2863||  0.00|  9.28|  3.26
   1| 88.97| 11.03|  2831||  0.00|  8.20|  2.69
As you see 2.8Gz CPU freq under load (loading Oracle 12)

 

Edited by itx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • npapanik
      By npapanik
      FYI, I have just installed Windows Server 2019 Standard (Desktop Experience) using the latest (WS2016) HP AMD chipset & VGA driver. Everything is recognised in Device Manager and stable.
    • TonyTheTechie
      By TonyTheTechie
      I need to update the firmware on a HP Proliant Microserver Remote Access Card installed in my N40L.
       
      Can someone please explain what I need to do to create a boot device that will update the firmware on the Remote Access Card?
       
      Thanks
       
      Tony Self
    • Joe_Miner
      By Joe_Miner
      I installed a BU50N Blu-ray 4K drive in my HPE ProLiant Gen8 MicroServer.  Worked out well, I'm using PowerDVD13 -- I had to restart the "Machine" several times before it saw the ODD but "Machine" finally figured it out.
       
       
       
       
       
       








    • Henrik
      By Henrik
      Hi Community,
       
      First, my specs (briefly):
      MicroServer Gen10
      AMD Opteron X3216
      Win Server 2016
      [...]
       
      Problem:
      The Taskmanager shows only 1 CPU-core instead of 2.
      (ref. image 1)
       
      Solutions tried:
      checked msconfig...no CPU-Limit set checked, whether other users see the same amount of CPU-cores in task-manager (ref. image-link (internal) 2)  
      Anyone out there with an idea to solve this?
       
      Greets
      Henrik
       



×
×
  • Create New...