Jump to content
RESET Forums (homeservershow.com)
lordcroci

Proxmox - xpenology + vpn

Recommended Posts

lordcroci

Hi there!
I'm new around here, looked for the presentation thread but haven't found any! 
Anyway I hope to be able to contribute (as far as my newbie's knowledge will be useful :) )....

Speaking about what I'm trying to do, I have this amazing microserver gen8, on which I have 2 3tb wd red as storage and an ocz 125gb ssd on 5° port.. Installed a couple of days ago mr. PROXMOX (I'm a complete newbie to it too ) and configured the xpenology 6.0 that runs amazingly!
Now.. I'm just wondering which is the best option to configure a vpn (possibily openvpn) and from my inexperience I found a couple of options:
- try a container with turnkey debian 8 OpenVPN
- install ubuntu on a VM and setup openvpn
- try the vpn server on xpenology

 

or the least pleasurable
- install openvpn on my windows 10 pc and leave it turned on in way to access the microserver through vpn.. 
What do you think is better to do? Considering that I am a real noob and will need some guide or some tutorial (already googled something and Have found a lot of material on the openvpn site.. but honestly can't find so much about proxmox and vpn)

PS: sorry for my english, but I'm italian and I'm still learning! :)

 

thanks a lot!
Lordcroci

Share this post


Link to post
Share on other sites
scorpi2ok2

You can try to install an openvpn server directly on PROXMOX.

I think you don;t need to install another VM just for vpn.

You can user openvpn as for example.

All OpenVPN Access Server downloads come with 2 free connected devices for testing purposes.

It comes with a nice WEBUi interface.

 

 

 

Share this post


Link to post
Share on other sites
lordcroci
On 2/7/2018 at 11:51 AM, scorpi2ok2 said:

You can try to install an openvpn server directly on PROXMOX.

I think you don;t need to install another VM just for vpn.

You can user openvpn as for example.

All OpenVPN Access Server downloads come with 2 free connected devices for testing purposes.

It comes with a nice WEBUi interface.

 

 

 

Thanks a lot, I did that and it worked! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • Al_Borges
      By Al_Borges
      hey forum member,  need some help
       
      this evening ,   there has been continual attempts to remotely log onto my QNAP Nas
       
      about every 15 seconds
       
      see the attached notification screen shot
       
      I have disabled the default admin account and the real obscure administrator account has a very secure password
       
      what should I do next?  should I be worried?
       
       

    • pksparks
      By pksparks
      Hi, 
      been reading through this forum, and also 2012 r2 essentials, but somehow i am not getting my vpn to work
      my configuration:
       
      gen8 with 2 nics connected and ilo4 nic connected. Nic 1 is connected to internet, nic 2 to my internal network
      ip adresses:
      nic 1: 192.168.2.200, with gateway
      nic 2: 192.168.10.229, no gateway
      ilo: 192.168.10.37
       
      nic 1 is connected to 4g router. Portforwardings for ports 80, 443, 1723 to ip 192.168.2.200
       
      after installation of server 2016e activated a remotewebaccess.com adress at microsoft, and installed remotewebacces and vpn.
      remotewebacces with /remote option is working
       
      my windows 7 laptop is in the domain of my server, client connector installed, and backup etc working.
      when i am at my office, or connected via a hotspot of my iphone, i want to make a vpn connection.
      everytime i start this, i see shortly that username and login are checked, but that is it, connection stops.
       
      i know i am overlooking something, but as allways, the longer you look, less change of finding it.
       
      any suggestions?. No need to hurry, i can only test this again on saturday.😩😏. Have to work tomorrow.
       
      any help is appreciated
       
      rgds
      Patrick
       
       
    • Himaro
      By Himaro
      So I'm trying to replace my ageing HP Proliant Microserver N54L. It's used as a general dogs body server, running Blue Iris, Plex and as my NAS server.
      I'm on a pretty tight budget but the poor server is always at 90% + CPU because of the CCTV and I'm looking at adding a second camera soon.
      Is there such a thing as a reasonably priced ECC home server build?
      My MVP is 8GB ECC memory, with 4 threads on the CPU. 
      I'd prefer a small form factor but that's like gold dust unless you throw a lot of $$££€€ at it. I've got to get this past my partner you see 😅
      Any ideas? I'm not loyal to any particular brand, so long as it works.
    • nrf
      By nrf
      A recent change in my ISP setup forced me to deal with an issue I have been keeping on the back burner. A while back, I had to change to a new VPN client for work. I had difficulty connecting as it told me a firewall must be blocking IPSEC or UDP. Blaming it on the router I had circled thru several with some initial success but ultimately failure. Having no choice now, I have narrowed it down to my network switch. the VPN is IPsec to a cisco vpn server (port 4500 and all).
       
      Bottom line, with switches like GS108Tv2 and GS-1100-5 between my work pc and router (currently Sophos UTM 9) no problem. But my fancy tplink t1600g-28ts, no go. it validates the password ok but can't connect the vpn itself. 
       
      Any seasoned veterans out there have an idea how this switch could be messing it up?
      thanks in advance!
      nrf


×
×
  • Create New...