Jump to content
Boogieshoes

Certificate error fix?

Recommended Posts

Boogieshoes

Hi folks,

 

I have had my install of WHS2011 for some time and with a static IP have been able to use remote access by switching on that service albeit not using microsoft's domain name registration.

 

The system has worked for about 5 years but is now grumbling about certificates when I login either remote or using one of my PCs on the local home network using mstsc.   The error message is attached.    Clearly if I click yes and ignore the error I can continue as I can when accessing the server using the static IP.  

 

I have looked at various posts about certificates and buying certificates for domain names etc. most of which the responses go over my head.

 

Any assistance that could help me address this would be gratefully received.

 

Boogie.

 

 

CertErr.png

Share this post


Link to post
Share on other sites
nrf

 so if you check "don't ask me again for connections to this computer" does it shut up in subsequent attempts?

From time to time I get this around home after windows updates but they can easily be muted

Share this post


Link to post
Share on other sites
Drashna Jaelre

This is actually 100% normal. 

 

The only way this doesn't happen is if you have signed certificates from a Certificate Authority that the system trust.  Which is not normal here.

Share this post


Link to post
Share on other sites
Boogieshoes

Thank you for your replies.

 

nrf - I suspect that checking that box would fix it as a simple 'ignore the message route' but I like to understand these things and fix them.  Microsoft have as usual washed their hands of any support which I feel they pretty much did the day they launched WHS. Nothing like feeling like a valued customer :).

 

Drashna - If this warning is 100% normal then why has it only just started doing this?

 

If I look in the certificates admin tool area I can see that there are certificates that have been produced over years, the last one ended in December.    I can find no explanation as to how these certificate were generated and other posts I have researched seem to show people purchasing certificates form DNS providers which I have never done.

 

regards

Boogie

Share this post


Link to post
Share on other sites
PHo

Definitely don't pay for a cert! If you want to get rid of the error then standup a CA and sign your own certs.

Share this post


Link to post
Share on other sites
Boogieshoes

Hmm....

 

Seems nobody knows.   To show what I mean about certificates the image is a portion of 138 certificates that are listed in the WHS Certification Authority utility  under the 'issued certificates' tab.   None of these were purchased, but were presumably generated by the server to prevent the issue.

 

Can anyone explain why I can see this thread on the Forums home page as being under WHS2011 but then it doesn't appear on any of the 15 pages.... is it something I did wrong to post the thread?   AT present I retain a shortcut favourite to get back to it because of this.

 

Boogie.

issued_certs.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Teetime
      By Teetime
      I have my WHS 2011 client PC database on its own dedicated drive. This drive is now showing errors, and the client pc backups are now not completing. I have a replacement drive and a backup of the client PC database made before the failure. How can I replace the client PC backup drive, restore the client PC database, AND have WHS 2011 continue to use the restored client PC database?
    • santacruzskim
      By santacruzskim
      I have a WHS 2011 box with no special networking-related settings going on. Accessing shares on all the PCs in my house get around 100MB/s read and write. All macs are getting around 25MB/s.  Tried mounting shared volumes as cifs and smb.  I've found a few forums of people reporting the same with various forms of windows servers and though there are 100 hack-y suggestions, nothing has ever worked for me.
       
      Anyone have any ideas on what I could do to improve performance? If i can't get this working well, it'll mean a lot of buying decisions, completely reworking my network storage.
    • Nelg
      By Nelg
      Hi All,
       
      I am setting up a MicroServer with Windows Home Server 2011 running as a file server at my home (local area network).
       
      On my old file server, I was able to scan documents at my Brother MFC and send them directly to a the user's folder on the file-server via FTP.
       
      WHS 2011 is proving a little more challenging to setup.  Could someone please help with how to configure WHS2011?
       
      I've seen the youtube video by Mike on setting up WHS 2011 and FTP, but it only enables one central storage folder, rather than sending scanned documents to a user's individual folder.
       
      any help much appreciated.
       
      Thanks
       
    • RWG3
      By RWG3
      I recently added a new Windows 10 PC to my home network, I can access shared directories on the server fine... but I'm having trouble saving files back to the shared drives.  I've check the account for the new PC on WHS and the permissions details under WHS on each shared folder.  What Am I missing?  

    • GabonPhil
      By GabonPhil
      Hi everyone, does anyone have WHS 2011 successfully backing up their Windows 10 PCs? On my PCs WHS connector installs okay and connects with the WHS 2011 box, but the back ups always fail. Attached is a screen shot of the back up failure message. Any help or suggestions gratefully received. Cheers, Phil.
       
      PS I'm using Windows 10 Version 1511 for x64-based Systems (KB3118754)
      WHS back up fail message.pdf


×