Jump to content
RESET Forums (homeservershow.com)

Datastore access randomly lost in ESXI 6.5U1


xenom
 Share

Recommended Posts

Hello I have ESXI 6.5U1 custom HP installed with b120i driver downgraded to 5.5.0-88 because I had slow disk performance.

 

Here is my setup : 

- ESXI on 16 Gb usb stick 

- 1 HDD in Raid 0 on bay 1 for datastore

- 2 HDD in Raid 1 on bay 3&4 for storage 

 

My problem is I have random errors (timeout, crash, nothing appears) in the ESXI web client. After some troubleshooting I see that my errors in the webclient appears at the same time than multiple access errors to the datastore.

My HDD isn't faulty according to SMART. Any ideas ? 

 

disk lost.JPG

 

The errors were already there before my driver downgrade from 102 to 88. I hoped it would disappear but nope :(

Edited by xenom
Link to comment
Share on other sites

Since Tuesday I made several test and removed my HDD on bay 3&4 to focus on bay 1 for the datastore :

- I made a slow format and did a full chkdsk without error

- I checked the smart health which showed nothing particular

- I recreated the  Raid 0 array and tried changing the bay of the hdd

- Tried various commands from esxcli or webclient 

Everything without success, each time I create new datastore and do any operation (transfer ISO, create a VM) on it I have lost access warnings.

 

However, I found an old 80Gb 2.5" HDD at home to compare, and everything is fine when I switch.

It seems to be directly related to my first HDD but can't understand why as it is not faulty at all when I diagnose or use it on home computers. Several people from my french forum had same problems with their SSD having the same errors and were obliged to use their microserver in AHCI mode rather than b120i.

Do you see any reason why a particular hardware would not work in b120i ? 

Link to comment
Share on other sites

It is an old Samsung HD501LJ for testing purposes.

 

Before buying a new SSD I need to be sure it's an incompatibility problem with my HDD (even if I can't understand why). 

Some people on my forum bought a Crucial BX300 240 Go to put on the ODD port and had exactly the same errors for the same configuration : 

Gen8 with last patches, ESXI 6.5U1 custom HP with 88 downgraded driver.

Link to comment
Share on other sites

Yep i think so, every SPP installed :

 

Dynamic Smart Array B120i Controller    4.50    
HP Ethernet 1Gb 2-port 332i Adapter    bc 1.39 ncsi 1.3.16.0 
iLO    2.55 Aug 16 2017  
Intelligent Platform Abstraction Data    0.00    
Intelligent Provisioning    1.63.192  
Redundant System ROM    J06 06/06/2014  
Server Platform Services (SPS) Firmware    2.2.0.31.2  
System Programmable Logic Device    Version 0x06   
System ROM    J06 11/02/2015    
System ROM Bootblock    02/04/2012

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...