Jump to content
RESET Forums (homeservershow.com)
Ikon-TNG

Windows 10 NIC teaming

Recommended Posts

itGeeks

Adding to what I said above please open your NIC properties-->power management and DISABLE 

"Allow the computer to turn off this device to save power"

 

Next go threw the advanced settings for the NIC and turn off/disable anything related to "Green Power/Low Energy"

Now go into the driver tab for the NIC and click update driver.

 

After you have done everything in my last two post, Open an elevated command prompt and PING the gateway and switch IP address and please post the average ping time for both and if there where any dropped packets... Now PING google.com and post results.

 

Open a web browser and run a speed test using speedtest.net and let me know if it matches what you should be getting aka what you pay for...

 

At this point we will at least know everything with your network is healthy then if there still problems we will take a closer look at the server to see whats going on.

 

 

 

Edited by itGeeks

Share this post


Link to post
Share on other sites
Ikon-TNG

Hi @itGeeks and thanks very much for all your questions and suggestions. I was waiting a while before reporting the results of one of your first questions/recommendations: that is, " make sure the hard drives are not set to power down".

 

You were bang on. Since making sure the drives don't power down I have not had a single incident of delayed server access. It's been perfect. Thanks much. :)

Share this post


Link to post
Share on other sites
itGeeks

My pleasure, Glad we got you sorted. I would still go in to your NIC properties click on drivers-> update driver and make sure you have the current driver. Also why you are there click on-->power management and DISABLE 

"Allow the computer to turn off this device to save power"

 

Next go threw the advanced settings for the NIC and turn off/disable anything related to "Green Power/Low Energy"

 

This will make sure the NIC stays alive and runs at full speed.

 

 

 

 

Share this post


Link to post
Share on other sites
Ikon-TNG

Update server's NIC driver: already up to date

Server NIC's Power mgmt: was set to allow turn off; now it's not

Server NIC Advanced settings: no green settings I could find. I did change Jumbo Packets from 1514 to 9014. Man, did this make a difference. My connection suddenly jumped way up in performance. So I checked my desktop PC (the one I'm using to write this) and changed it to 9K MTU. Remote Desktop into my server is now blazing fast.

 

The NIC in the server is a Marvell Yukon 88E8057 PCI-E Gigabit. The NIC in my desktop is a Realtek PCIe GBE

Share this post


Link to post
Share on other sites
itGeeks

Hmmm, I would not play with those settings, Leave MTU at the default settings of 1500. If you change it could cause lots of problems. Same goes with using Jumbo frames, Back in the day it solved a problem but using Jumbo frames today could and probably will do more harm then good. You need to have a good understanding of these technology before trying to use them. If not configured rite you will end up with dropped frames and all kinds of problems. I have never found a need in home networking to play with those settings, If your networking is sound then the performance will be plenty fast enough...

Edited by itGeeks

Share this post


Link to post
Share on other sites
Ikon-TNG

I'll keep that in mind: i.e. I'll be on the lookout for issues. So far, the performance boost is intoxicating :)

Share this post


Link to post
Share on other sites
itGeeks
3 minutes ago, Ikon-TNG said:

I'll keep that in mind: i.e. I'll be on the lookout for issues. So far, the performance boost is intoxicating :)

Well I guess like Dave says and how the Reset podcast came about, There is usually a reset if you screw something up :), Good luck

Share this post


Link to post
Share on other sites
Ikon-TNG

Well, that didn't take long. I went to access some shares on the server (actually, going to check backup logs) and couldn't access them. So, disabled Jumbo Frames and got connectivity back. OK, back to ground zero. Changed Jumbo Frames to 2K. No problem; access still great; performance really good. Changed JF to 4K. Oops; no good. Changed to 3K. Nope, still no good. Changed back to 2K; yep, all is good.

 

So, it seems I can have the server at 9K, but not the desktop. Do you know, do the computers at each end negotiate the highest value they can both use: i.e. since my desktop is set to 2K, all traffic to/from my server will use 2K?

Share this post


Link to post
Share on other sites
itGeeks

Correct, Everything needs to agree. The NIC in your desktop "Realtek" is the worst of the crop, Intel best, Broadcom 2nd best, Realtek junk. Motherboard manufactures put them in because there cheap

Edited by itGeeks

Share this post


Link to post
Share on other sites
Ikon-TNG

Which makes it really interesting that the performance is so much better if the JF is only at 2K. I mean, using Remote Desktop to the server is really noticeably faster than it was.

 

I also wonder if the ability to use JF varies with the make/model of NIC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...