Jump to content
RESET Forums (homeservershow.com)
Ikon-TNG

best way to remote print

Recommended Posts

Ikon-TNG

I have a project that could use the  expertise of you talented members. As you all know, my father is dead, but my mother is very much alive. She doesn't live a horrible distance from us, but it's far enough that we don't just run there on a whim. With that in mind, here are some factors I'm considering:

 

  1. I do all her banking, bill paying, etc. Of course, I do it online. She used to be a teller in a bank, so she still very much likes to keep her own records. To help with that, I used Word to create a 'bank book' for her that gives a great deal more room for entries than what is normally provided by typical cheque books. At the moment, I have to print new blank sheets at home, then take them to her. Of course, I love to visit her, but sometimes she needs new sheets at a time when I'm too busy, or I'm away. Being able to print some remotely at her condo would be a benefit.
     
  2. Sometimes, friends and family send me emails intended for her, because she doesn't have a computer. She's never used a computer in her life, and she says she has no intention of starting at her age. Being able to remotely print them at her condo would also be beneficial.
     
  3. We have an Epson WF-7510 printer. It used to be the main printer on our network, but I replaced it with an Epson Eco-tank printer because the ink is so much cheaper per page. We print a lot more than my mother, so I was thinking the WF-7510 would be a great printer for remote printing.
     
  4. I did take the printer to her condo, and connected it to her Cisco cable modem. I then, after considerable trial and error, managed to get it set up to work with Epson Connect. It was working pretty well that way, until I tried to print out some medical record sheets for her. It was a PDF, and it got royally messed up. It seems the document is too complicated (or something) for Epson Connect to handle.
     
  5. So I'm looking for a better way to enable this remote printing. I know google has a cloud printing service, but it requires the use of the Chrome browser. My father always warned me off Chrome, saying it was insecure and he refused to use it for anything. In fact, he basically didn't use google for anything. He once told me to never trust a company that says they're not evil. He recommend I use FireFox, so that's what I've done for years. Also, since Epson Connect screwed up, I'm a little leery about using another cloud printing service.
     
  6. I know how to use Remote Desktop. My father taught me how to use it to administer my server. I thought it might be a solution. I could set up a tiny ASrock computer I have on the shelf at her condo, connect the printer to it, then use RDP to connect to the ASrock, copy over whatever document needs printing, and print it from the ASrock directly. That should work, shouldn't it? I could even keep documents she needs regularly on the ASrock permanently, so I wouldn't have to copy them over each time. My only concern is my father told me Remote Desktop isn't really all that secure over the Internet.
     
  7. I've also heard of VPN. I was wondering if it might be an option since, from what I've read so far, it seems to be secure over the Internet

 

Any ideas, suggestions, recommendations, or other feedback would be most welcome.

Share this post


Link to post
Share on other sites
mattb75

Hi

I’d do a mix of 6 and 7 (local PC and VPN).

If the option exists to create a VPN on the local router (rather than having to put the VPN software on the PC and do some port forwarding on the router to the PC) you may be able to get away with just using the VPN and a LAN connection from the router to the printer, but suspect having a local pc in place would simplify any troubleshooting with the setup.

Share this post


Link to post
Share on other sites
ShadowPeo

I held off posting this earlier as it is a little overkill and a little more complicated and involved than plug and play and possibly, ney probably outside the realms of what you want to do.

 

However, having said that what my first though was, is a piece of software that is called PaperCut (local company to me which is good, actually started less than 5 minutes walk from one of my larger clients, but global support and use extensively especially in large business, government and education sectors) and I use extensivly professionally and they do offer a way to do this, either via what they call webprint, or via a couple of other methods, but webprint is the one that would most likely suit your situation, it does require extra hardware though and a little skill to setup (not hard but a basic understanding of networking and print services). 

 

Extra hardware is probably the biggest issue or the need for an extra licence of some software (if everything is PDF at upload, however, this would be moot, only requires extra software if you want to print word documents etc. but this can be overcome by simply saving as PDF and printing the PDF)

 

Oh, whilst I am thinking about it. I bring it up as the base version (under 5 users) is free. It mainly exists for cost control and auditing but has many other features

Share this post


Link to post
Share on other sites
Ikon-TNG

Thanks for the replies gentlemen.

 

@mattb75, the cable modem/router is, I believe, a Cisco DPC3825. From my limited research, it appears it cannot be a VPN Server, only a client. So that option is out.

     However, as I mentioned, I have an tiny ASrock computer. I pulled it off the shelf last night. It's an ION 330 and it has Windows 8 installed.

     I did a bunch of online reading last night. Using what I read, I went to Control Panel>Network and Internet>Network Connections and created a new Incoming Connections entry. I did this on the ION 330. From my Windows 10 computer I was able to connect to the ION 330 and see shared folders. I installed the WF-7510 printer driver on the ION 330, shared it, and was able to send a print job to it from my Windows 10 computer.

     My main concern is that all this is happening on my local network, not over the Internet. I don't think I have any way to test it over the Internet, since I only have 1 Internet link. My Windows Phone will let me share Internet connections, but I don't know how I would be able to connect to it using my Windows 10 desktop.

 

@ShadowPeo, I agree, this seems a bit overboard for my needs. However, the info is interesting to know, so thanks for posting.

Share this post


Link to post
Share on other sites
mattb75

What you’ve tested won’t work over the internet.

Take a look at OpenVPN and install the server role on the ION330. Put the client software on your Windows 10 Machine and your Windows Mobile. By doing some port forwarding on your own router (give the ION330 a static IP and then forward port 1194 for UDP traffic to the ION330 in your router settings) you should be able to test the VPN is working from your mobile cellular connection before you take any equipment over to your Mom’s.

https://community.openvpn.net/openvpn/wiki/Easy_Windows_Guide

Once you’ve got the VPN working between your mobile and the ION330 PC you should be able to use the Remote Desktop app on Windows Mobile to connect to the ION330 via cellular. You can test it only works via VPN by killing the VPN connection on the ION330 and it should drop the Remote Desktop link as well.

Once you’ve got that all working, take the ION330 over to your Mom’s, make the same router port forwarding changes on her DPC3825 modem/router and test again using your mobile - this time with the right external IP address for your mom’s connection.

(Note you will need to know what your external IP address is for both your house and your Mom’s when doing this testing - may need to look into Dynamic DNS services if your IP addresses change).

When you’ve got it working over mobile to the ION330 you should be able to replicate the connection on your Windows 10 Machine once you’re back home.


It was all much simple when LogMeIn was available in a free version - pretty certain you don’t want to shell out $299 per annum though!!

Share this post


Link to post
Share on other sites
Ikon-TNG

Thanks @mattb75. I will look at that.

 

I think I found a way to test. I have my father's old Surface Pro w/Windows 10. I can link it to my phone for testing.

 

I used this link to try to set up a VPN using only Windows features: http://www.diaryofaninja.com/blog/2012/09/11/setting-up-a-vpn-server-on-windows-7-or-windows-8-ndash-secure-your-internet-use-while-away. It seems to work, up to a point. I can connect to the ION 330 over the Internet. However, I can't see anything on the ION 330; no shared folders or printers: just nothing. I had to create a port forward on my Untangle box, sending port 1723 to the ION 330.

 

UPDATE: I just had a real quick look at the OpenVPN instructions. Wow, they look complicated. So much stuff about certificates. I'm not even sure why I would want a certificate.

Edited by Ikon-TNG

Share this post


Link to post
Share on other sites
Ikon-TNG

OK, so I've tried to set up OpenVPN, but it isn't working at all. I can't even get it to connect. And, holy Santa's nuts, does the build-dh step ever take a long time to complete. At this rate I'll be just using RDP. At least I can get it working.

Share this post


Link to post
Share on other sites
Jason

I have a new HP printer that has a free service which allows you to email docs to a public email address registered to my printer (thru Hp). Anything emailed to that address will print at home while I’m remote. You might look into this. I believe they call it HP ePrint. It’s surprisingly simply and reliable.

Share this post


Link to post
Share on other sites
Ikon-TNG

Epson has a similar feature but, like I said, it totally screwed up on this one document.

 

I also just realized I totally missed something regarding the OpenVPN: it has to be run on both the server and the client. I didn't start it on the server :unsure: So, I've started the OpenVPN setup process again. It's now doing the build-dh. I'm going to leave it doing that while I go to bed and look at it again in the morning.

 

Also, I remembered that I have a couple of my father's old laptops here. One has Win7x32 on it, so I'm going to use it to test OpenVPN. Maybe I'll get it sorted out yet.....

  • Like 1

Share this post


Link to post
Share on other sites
Ikon-TNG

OK, I officially give up on OpenVPN. After more research, especially looking at the log files on the server and client, I realised that the instructions on https://community.openvpn.net/openvpn/wiki/Easy_Windows_Guide are rubbish.

 

There are so many inconsistencies between what the instructions say, and what actually happens when you carry them out, that it's almost impossible for someone who is not a VPN guru to figure out what's going on. For example, the instructions say to copy a file named dh1024.pem to a directory. It turns out there is no such file; it's actually called dh2048.pem. OK, so no big deal, just copy dh2048.pem to the directory. Except, the actual encryption is done using 4096, not 1024 or 2048. So, when OpenVPN-GUI tries to initialise, it fails. That's just one example; there are a bunch of others. I don't have the knowledge to sort them out.

 

@mattb75, I'm not pointing this out as any kind of criticism of you. I'm sure you pointed me to the guide in good faith, and I thank you for the effort. Rather, I'm giving a warning to anyone else who might read this thread and be tempted to set up OpenVPN themselves.

 

I set up RDP on the ION 330 and linked to it from the laptop. No problems. Took all of 5 min.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Ikon-TNG
      By Ikon-TNG
      Continuing to work on Windows 10 networking, I found another error by reading more posts in forums. This one, as the title says, relates to NET VIEW. When I run this command on my Windows 10 desktop computer I get the 'dreaded' 1231 error. I haven't got it resolved. If anyone has any ideas, please post them. I'm now looking at something called lanmanworkstation. The post recommends changing running "sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi". No idea what that does. Then I'm supposed to run " sc.exe config mrxsmb20 start= disabled". Again, no idea.
       
      Anyway, I think I will do a backup of drive C: before even attempting anything like this.
       
      Oh, and Paragon Backup cannot find my server at all.
    • ChrisB1488993274
      By ChrisB1488993274
      Hi there,
       
      New to this forum site, so apologies if the post is not in the best category etc....
       
      Have had a Surface RT for a couple of months now - given to me as a xmas present - and I have to say, I absolutely love it.
       
      I also have a new Nokia Lumia 925 running Wp8.
       
      I wondered whether any apps existed, like Smartglass for Xbox 360 / Xbox One, that enabled use of a wp8 handset as a mouse or trackpad to control the surface rt? Doesn't need to be full on remote support etc, just a simple additional control, like a bluetooth mouse.
       
      Any help would be much appreciated.
       
      Many thanks
       
      Chris
       
       
    • reiaya
      By reiaya
      sometimes, whenever I turn off the surface pro 2, with winsows 8.1 and then turn it on, i find out that it doesnt detect my internet, i click on the torubleshooting and it says that maybe is the dirver that haw not beimg read, so i need to restart it, and it happens so often that im not sure what to do, since the troubleshootinf thingy does mothing, and im driving nuts about needing to restart it over and over again.
       
      aaahhhh! i want to love my surfacepro and every week is a different nasty error with windows. today suddenly it stopped to functionnthe touch mode...and again need to restart it again. grrr... amy ideas?
    • Joe_Miner
      By Joe_Miner
      One of my HTPC's that starts to the MS account (N40L running Windows 10 Pro)  -- the Launch Pad would Load & Log in OK but the icon's are not visible (i.e. Backup, Remote, Shared Folders, Dashboard) but everything worked and from my WHS2011 it was backing up OK etc -- I was going to mess with it when I had a block of spare time then I noticed that another of my PC's that also starts up to another MS account (Z68 with i5 running Windows 10 Pro) started showing a blank Launch Pad also!  
      Has one of the W10 updates trashed this?  
      Anyone else experiencing the same?
       
      What the french Toast!
    • krom
      By krom
      Fry's has the Logitech Harmony Link available for $79....regularly $99
       
      http://www.frys.com/product/6839016?site=frysecampaign
       
      PCDoc did a review of this device in this post here:
       
      http://homeservershow.com/logitech-link.html


×
×
  • Create New...