Jump to content
RESET Forums (homeservershow.com)
scruffters

RAID cards in the Gen10

Recommended Posts

scruffters

Thanks for trying this out both. I guess we have an answer about the likelihood of using a MegaRAID with the Gen10 :huh:

Share this post


Link to post
Share on other sites
schoondoggy

I did have a LSI HBA working in the Gen10. I will try a few things when I get a chance.

Share this post


Link to post
Share on other sites
scruffters

I think the Marvell controller is fine as a HBA though, right?

 

Mostly I wondered about hardware RAID's with this system.

 

I'm not sure how well the built in AHCI is suited for ZFS, for example, but the hardware has been supported in Linux generally for a while.

Share this post


Link to post
Share on other sites
Tighernain

I spoke to a guy in the UK over the weekend and he has got a IBM LSI ServeRAID M1015 SAS/SATA PCIe RAID Controller working in his, so it should be possible. I am going to borrow an HP P410 Raid Card next and will give that a try.

Share this post


Link to post
Share on other sites
schoondoggy

I picked up a SAS 9261-8i, it is actaully a SUN/Oracle 375-3701. I installed it in the MS Gen10. I have Windows 10 running on a drive connected to the ODD SATA port. I have  the server set to UEFI. I could not get to the MegaRaid setup during post. In Windows I was able to load the MSM and configure an array. It all seems to be working. I will try to switch it back to legacy BIOS and see if I can get to the Megaraid setup during POST.

Let me know if there are specific things you would like me to check out.

Share this post


Link to post
Share on other sites
schoondoggy

Screenshots:

MRM.PNGmrm2.PNG

Share this post


Link to post
Share on other sites
scruffters

Thanks for doing this Schoon, it's very helpful!

 

Did the system POST slowly with the LSI card installed? I remember the gen8 would hang for a few minutes with a none HP RAID controller installed, then eventually continue.

 

It seems strange that you can't get into the RAID BIOS? Do you see the prompt for this, or is it somehow hidden?

Share this post


Link to post
Share on other sites
schoondoggy

Post has been getting slower on the MS Gen10 the more I expirement. I think I need to clear the BIOS and start clean.

With UEFI boot enabled the MegaRAID login screen never shows in post.

I set the BIOS back to legacy boot and now the MegaRAID login is available during POST.

The firmware is very old, I will update that next. I have the last version from SUN/Oracle.

Still trying to determine what the latest Broadcon/Avago/LSI firmware is for a 9261-8i.

Share this post


Link to post
Share on other sites
schoondoggy

Current boot time legacy mode from power button push to Windows login is one minute fifty eight seconds.

I got the firmware updated to 2015:

new msm.PNG

RAID5

raid5.PNG

RAID10

raid10.PNG

 

The drives I am testing with are older and slower, HDS5C3020ALA632.

When I get a chance I will flip it back to UEFI boot and see what happens.

 

Share this post


Link to post
Share on other sites
schoondoggy

Fun day playing in the lab.

I installed a HPE H220 HBA and it worked fine in the MS Gen10.

So, then I pulled my P222 out of my MS Gen8 and installed it in the MS Gen10. With the server in legacy boot it worked fine!

SSA.PNG

I set up a RAID5 array.

raid5 p222.PNG

When I have time I will go back and try UEFI boot. 

I assume I had the server in UEFI boot the last time I tested. I was also running an older BIOS, perhaps that was part of the issue.

I rebooted several times and all is working.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...