Jump to content
RESET Forums (homeservershow.com)

RemoteWebAccess DynDNS error


TheFreaker86
 Share

Recommended Posts

Hallo!

I am new here. I am a little desperate because despite the fact my job is IT I don't get it to work. My homeserver is running Server 2012 R2 Essentials and because somehow the AD and file shares did not work properly anymore I decided to reinstall the OS from scratch. After reinstallation I reconfigured anywhere access and reobtained my remotewebaccess.com-subdomain which worked fine except for the the remotedesktopgateway did not get the certificate properly which I fixed with this guide here. This step was not necessary when I installed the OS some years ago for the first time.

 

Up until the first forced reconnect from my ISP the IP-adress of my router matched with the one in the DNS-record. But after that it did not refresh anymore. The error message in the Dashboard says (I hope this matches the english version of the message): The dynamic DNS information cannot be updated. Details to this message says furthermore: The DNS-information cannot be updated because no connection to the domain name provider can not be established. Contact your domain name provider. And after the lifespan of the DNS-record expires additionally the error message appears that the domain name can not be resolved...Unsurprisingly.

 

The weird thing is that DynDNS for AnywhereAccess/RemoteWebAccess has never been an issue with the old and now overwritten OS installation. In desparation I made a bare metal recovery from the old OS installation to check the behaviour of DynDNS which worked still just fine. A second WS2012R2E-installation inside a VM was a bit contradictory. The original remotewebaccess.com-domain could not be reinstated but a new one registered. Though I haven't checked if the new domain can update the DNS-record.

 

Now with the once again reinstalled OS DynDNS acts as described above. Port forwarding (Port 443) on my router has been set up for testing purposes both via UPnP and after that manually. Didn't matter before reinstallation because it worked both ways. I deliberately left out Port 80 for security reasons.

 

I have searched through the eventlog and the Internet, to no avail. The only remotely useful hint was to change the Windows Live-password had no effect. And the Eventlog is so overwhelmingly packed with events of any kind :blink: I also ran several times the repair wizard from the Dashboard with always the same error. I even was unable to release my subdomain through the configuration wizard.

 

I can imagine that the public certificate from GoDaddy needs to be imported somewhere for authentication to make DNS-record updates possible. But that would make the Windows Live-login obsolete.

 

Has someone any advice how I can get the DynDNS-service back up running? Or where I have to search for more detailed hints for the cause? I have already considered that it is not a "broken service" of the OS but rather an external issue beyond my control (which suggests the error message). But that contradicts the fact that the recovered installation was able to update the external DNS-record. If the cause is really external who is the correct contact? GoDaddy or Microsoft?

 

Edit: Maybe do I miss some windows updates or update rollups that do not come through Windows Update? I have updated the OS only via the OS-internal Windows Update function and right after installation some with wsusoffline.

Edited by TheFreaker86
forgot something to mention
Link to comment
Share on other sites

  • 2 weeks later...

To make sure, you're using the built in web stuff, right?  As in the "Anywhere Access" using a ".remotewebaccess.com" domain, correct? 

 

If so, then once you've logged into the account, it should configure everything for you. Nothing that you need to do, as it's all automated, at that point. 

 

If that's running into issues, then you may want to check the "actual" logs ("C:\ProgramData\Microsoft\Windows Server\Logs", and note that this is "programData" and not "program files", and is hidden by default).

 

The alternative is to set this all up "by hand". Which isn't entirely free. Unfortunately. 

Link to comment
Share on other sites

Hallo and thank you for your answer!

yes, its supposed to be all the built in stuff. As I wrote above it doesn't work out with the configuration and repair wizard. I got myself an Lets Encrypt-SSL certificate and installed it on the IIS and the remotedesktop gateway in combination with my router doing the DynDNS thing as a workaround. And I have gone already through the logs but wasn't able to find any hint. I picked those with names that might contain networking. Maybe I have searched in the wrong logs? Can you please tell me in which logfile the DynDNS stuff can be found?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...