Jump to content
RESET Forums (homeservershow.com)

Recovering from a failed system disk in a Thecus W5000


Steve Pitts
 Share

Recommended Posts

Folks,

 

Earlier this week the system disk (a 500GB SSHD) in my Thecus W5000 running Windows Storage Server 2012 R2 Essentials died without warning. Since I had a day off work today I've ended up spending most of the day failing to get it restored from the server backups.

 

I think the crux of my problems (ignoring the fun and games with UEFI/BIOS boots and the blind alley that was the Thecus restore disk) is that that disk was partitioned into a 90GB C: drive and a 390ish GB D: drive. The latter was used for stuff that I wasn't bothered about losing (like installation files) and thus was not included in the backup regimen. None of the 'user data' was stored on that disk, that was handled by four 3TB drives managed by DrivePool. The only spare drive that I had to hand was a 120GB SSD, which is big enough for the system partition but that doesn't seem to be good enough.

 

The first time I got the restore process to start (it finds the backups fine - albeit that searching for them initially takes more than an hour on this shonky little system - and reports 'EFI System Partition, C:' as the Drives in backup) it failed with "No disk that can be used for recovering the system disk can be found." (plus a whole raft of suggestions which didn't seem particularly applicable, especially since I'd selected all bar the empty disk as being excluded from the process, since I don't want my data trashed) despite the fact that the 120GB SSD was empty. A trawl around the Internet suggested using diskpart from the command line and doing a clean against the disk I want to restore to. That changed the error message to "The computer needs to be restarted to finish preparing a hard disk for restore" which seems to be spurious but Googling suggests is related to the target disk being smaller than the original disk (ignoring the partition situation) and when I tried again it had reverted to the 'no disk' error.

 

I'm somewhat at a loss now as I've tried all of the options I can think of/Google for, but hope that I have the following options, in decreasing order of desirability:

 

1. find a way of wrangling the existing process into restoring the system partition. I've found suggestions on using wbadmin from the CLI of the restore environment, but those require a backuptarget partition parameter and the USB disk on which the backups are placed doesn't seem to get a drive letter (which is something that seems to have been done deliberately by the WSS backup process

 

2. spend a third of the cost of a new Thecus W5810 on a 500GB SSD to replace the 120GB one I had lying around and (with everything crossed) hope that the restore process will restore to it

 

3. use the Thecus recovery disk to create a 'back to factory default' version of the OS and figure a way of reconfiguring everything so that I can see the DrivePool disks. I guess that at a minimum all of the old client backup data would be useless, but that would be better than losing all of the data (which is where I seem to be now - when I originally used the recovery process and looked at the four drives they all showed as having a single apparently empty file, which was worrying and what led me to dig deeper into how I was supposed to restore the server in my scenario)

 

Any advice, guidance, past experience or other comments will be welcome, but please don't point and laugh too loudly. Had this been a virtual infrastructure then I'd have found a way of testing such a restore when I first set it all up, but being a physical box (and a frankly underpowered one at that) I wasn't able to see any way to test it all in advance of a genuine failure.

 

Cheers, Steve

 

 

 

Link to comment
Share on other sites

  • 3 weeks later...

First, have you tried contacting their support?  They may be able to help you more, as this may be a hardware/configuration related issue. 

 

Secondly, try running a clean install (if possible) on a blank/empty drive, and *then* try running a restore (i've found this helps a LOT). 


Additionally, make sure that the destination drive is the same size or larger than the original drive that you're replacing.  

 

 

Also, it may be worth reading up on the manual: http://ftp2.thecus.com/~thecus/wss/iso/WSSE_QIG_20160415.pdf

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...