Jump to content
RESET Forums (homeservershow.com)

Pin Connections on 10pin to 8pin connector cable in ML30 G9


Joe_Miner
 Share

Recommended Posts

I've powered down my ML30 Gen9 and visually followed the Pin connections for the 10pin to 8pin connector cable:

Capture.JPG

WP_20170623_14_10_01_Pro.jpg

WP_20170623_14_10_23_Pro.jpg

WP_20170623_14_33_44_Pro.jpg

WP_20170623_14_33_56_Pro.jpg

WP_20170623_14_34_07_Pro.jpg

WP_20170623_14_34_14_Pro.jpg

WP_20170623_14_40_05_Pro.jpg

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Joe_Miner
      By Joe_Miner
      By: JohnStutsman
       
       
       

       
      Figure 1 – HPE ProLiant ML30 Gen9 on static mat ready for Windows 10 pro x64 install via iLO4
       
       
       

       
      Figure 2 – This shows my Samsung 840 Pro (This will be my OS drive) set up in a single drive RAID0 in the B140i using SSA
       
       
       
      After manually installing Windows Server 2016 easily on HPE’s ProLiant ML30 Gen9 I was anxious to see if an install of Window 10 Pro would be just as trouble free. It was!
       
      Besides having Hyper-V capabilities, Windows 10 Pro, is being looked on by many as the basis of a low cost Home Server as illustrated in “Building a Windows 10 Home Server – Anniversary Update Edition”. Check out HPE’s Operating System Support Matrices for insights on the many OS’s that the ML30 Gen9 supports. But, what will work goes beyond what’s officially supported by HPE in the “Matrices”. Windows 10 Pro is not listed in the Matrices but Windows Server 2016 is and Server 2016 shares much of the code with Windows 10 Pro as does Server 2012R2 shares with Windows 8.1 pro and Server 2012 shares with Windows 8. In order to manually load Windows 10 Pro I downloaded drivers for Server 2016. The simplest procedure, for me, is to use SPP to update all the ML30 Gen9 firmware first, then use the drivers for the B140i to load Windows 10 Pro, then after Windows 10 Pro is loaded and updated use HPSUM to load all the relevant drivers and software into Windows 10 Pro.
       
      Like Server 2016, Windows 10 Pro has its own generic drivers that will work with the ML30 Gen9’s NIC and Video so the B140i drivers is all that’s needed to get Windows 10 Pro onto the ML30 Gen9! HPSUM run (with Administrator Privileges) will load all of the missing HPE drivers I need in one step – including the NIC’s, Video, and SSA – just to name a few.
       
       
       
      Step-By-Step: Windows 10 Pro on HPE ProLiant ML30 Gen9
       
      I used iLO4 to remote into the ML30 Gen9 and began to install Windows 10 Pro x64 manually (i.e. without using IP) in the following general steps:
       
      Since I had just recently done steps 1-7 not long ago I skipped to 5 then did 7 through 16 below.
      Download Service Pack for ProLiant (SPP) from Hewlett Packard Enterprise Support Center – Drivers & Software – the current version is 2016.10.0 (24 Oct 2016) – check also threads about SPP at HSS Forum MS Gen8 Load the SPP ISO in “virtual drives” in remote desktop of iLO4 Boot the ML30 Gen9 – with no drives in the ML30 Gen9 in my case – and let SPP run automatically and update all firmware – See Figure 3 below. Shut down the ML30 Gen9 Next: I removed the Samsung 840 Pro 256GB that I had loaded Server 2016 on (giving me the flexibility to switch OS’s by switching SSD’s in the ML30 Gen9) and loaded another Samsung 840 Pro 256GB into drive 1 of the Icy Dock ToughArmor MB994SP-4SB-1 Go to the Hewlett Packard Enterprise Support Center – Drivers & Software – and download the file cp028631.exe that is the Dynamic Smart Array B140i Controller Driver for 64-bit Microsoft Windows Server 2012/2016 Editions (Since Windows 10 has the same core as Server 2016 I plan to use it for manual installation of Windows 10 64-bit Pro in the ML30 Gen9 – the HPE Drivers & Software site does not have Drivers & Software for non-server OS’s) – the current version is 62.12.0.64 (24 Oct 2016) Extract the files in cp028631.exe and load those into a file folder that I then attach/load in “virtual drives” of remote desktop of iLO4 (during Windows install this will be the folder I browse to so that Windows 10 can pull in the driver and see the Samsung 840 Pro ) Load the Windows 10 Pro x64 ISO in “virtual drives” of remote desktop of iLO4 Boot the ML30 Gen9 During boot go into IP (press F10) and select SSA (Smart Storage Administrator) In SSA I set up the Samsung 840 Pro as a single drive RAID0 to be used as my OS drive – See Figure 2 earlier. Exit SSA & IP and Restart the ML30 Gen9 Proceed with the normal Windows 10 Pro x64 install – During install Windows 10 will ask for location of drivers so it can see the drive(s) – in browse lead it to the location to the file folder of B140i driver(s) in the “virtual drives” C: -- if your OS drive had been previously formatted as MBR you will have to delete that so it can be formatted as GPT. See Video 1 below. After Windows 10 is installed and updated – reattach SPP ISO in remote desktop of iLO4 In the Windows desktop go to the SPP ISO in File Explorer and Execute the Batch file for HPSUM (i.e. execute: launch_hpsum.bat as Administrator) – I chose “Localhost Guided Update” – Automatic Mode After running HPSUM (and rebooting) the HPE software shown in Figure 4 below was installed. Enjoy!  
       

       
      Figure 3 – After running SPP’s ISO the firmware of the ML30 Gen9 is up to date.
       
       
       
       
      Video 1 – Browsing to select the file folder with B14i S2016 drivers during install of Windows 10 Pro on HPE ProLiant ML30 Gen9
       
       
       

       
      Figure 4 – Software installed by HPSUM in Windows Server 2016
       
       
       

       
      Figure 5 – Temperatures in the ML30 Gen9 via iLO4. BIOS is set on optimal cooling and my single System Fan is running at 6% and the two 40mm fans on the MB994SP-4SB-1 are turned on.
       
       
       

       
      Figure 6 – System information showing Windows 10 Pro as the OS
       
       
       

       
      Figure 7 – Basic information showing Windows Server loaded onto my HPE ProLiant ML30 Gen9 running from a single SSD RAID0 in bay 1 of the Icy Dock ToughArmor MB994SP-4SB-1
       
       
       
      All in all Windows 10 Pro was easy to load onto the HPE ProLiant ML30 Gen9 providing a relatively cheaper platform (compared to Windows Server 2016) for a home lab for setting up and testing applications in Hyper-V for instance.
       
      In the As-Built that follows I list how this ML10v2 is loaded. Be sure to check out more on this at ML10 and ML10v2 Forum and Windows 10 Pro on HPE ProLiant ML30 Gen9 Forum Thread.
       
       
       
      As-Built (I named my Computer: Serenity)
      HPE ProLiant ML30 Gen9 (Product No. 830893) Xeon E3-1240v5 (SkyLake LGA 1151) 8GB ECC RAM (Expandable to 64GB) OS: Windows 10 Pro B140i Dynamic Smart Array: Ports 1-4: (4*3.5” Drive Tray Caddies for Main Drive-Cage Assembly Bays 1-4) B140i Dynamic Smart Array: Ports 5-6: Icy Dock MB994SP-4SB-1 in Top 5.25” half-height Bay; with/ 2*18” SATA III (6 Gb/s) cables attached to Bays 1 & 2 (Bays 3 & 4 are available for future); Molex to Molex & Fan Y-Connector Cable; Samsung 840 Pro 256GB in Bay 1;  
       
      Please join us in the HomeServerShow Forums to discuss this and tell us what you are building at home.
       
       
       
      References:
       
      Check HSS Forum Post: Other HSS ML30 Blog Postings: http://homeservershow.com/tag/ML30
       
       HSS HP ProLiant ML30 Forum postings (In HSS Forum ML10 & ML10v2): http://homeservershow.com/forums/index.php?/forum/98-ml10-and-ml10v2/
       
      HP MicroServer Gen8 – Service Pack for ProLiant – 24th Oct 2016 http://homeservershow.com/forums/index.php?/topic/12034-hp-microserver-gen8-service-pack-for-proliant-24th-oct-2016/
       
       iLO Advanced License Keys http://homeservershow.com/forums/index.php?/topic/9511-ilo-advanced-license-keys-1850-2400/
       
       Icy Dock “ToughArmor” MB994SP-4SB-1 http://www.icydock.com/goods.php?id=142
       
      Scsi4me.com 3.5” Drive Tray Caddy 4 HP ProLiant ML350e ML310e SL250s Gen8 Gen9 G9 651314-001 http://www.ebay.com/itm/231001449171
       
       HPE ProLiant ML30 Gen9 Server QuickSpecs http://h20195.www2.hp.com/v2/GetDocument.aspx?docname=c04834998&doctype=quickspecs&doclang=EN_US&searchquery=&cc=us&lc=en
       
      HPE ProLiant ML30 Gen9 Server “Maintenance and Service Guide”; Part Number: 825545-002; November 2016; Edition: 2 => http://h20565.www2.hpe.com/hpsc/doc/public/display?sp4ts.oid=1008556812&docLocale=en_US&docId=emr_na-c04905980 Or go to => http://h20565.www2.hpe.com/portal/site/hpsc/public/psi/home/?sp4ts.oid=1008556812&ac.admitted=1489520211680.125225703.1851288163#manuals
       
       Check out my HPE ML30 Gen9 Play-List:
    • Joe_Miner
      By Joe_Miner
      By: JohnStutsman
       
       
       

       
      Figure 1 – Preparing to install new 64GB of RAM
       
       
       
      I upgrade the stock 8GB to 64GB of RAM in the HPE ProLiant ML30 Gen9 using 4 DIMMs (“Sticks”) of Kingston KVR21E15D8/16.
       
       
       

       
      Figure 2 – Kingston KVR21E15D8/16
       
       
       

       
      Figure 3 – 64GB RAM about to be installed in HPE ProLiant ML30 Gen9
       
       
       
       
       
      Figure 4 – HPE ProLiant ML30 Gen9 – System Board Components & Memory “Type” requirement from “QuickSpecs” – DIMMs removal & installation instructions from “Maintenance & Service Guide” (see links in References below)
       
       
       

       
      Figure 5 – HPE ProLiant ML30 Gen9 – Memory & DDR4 memory population guidelines from “QuickSpecs” (see links in References below)
       
       
       
      I upgraded to 64GB of RAM in my HPE ProLiant ML30 Gen9 using Kingston KVR21E15D8/16 from Newegg. The KVR21E15D8/16 was suggested by Schoondoggy on the forum thread RAM for ML30 Gen9.
       
       
       
       
      Video 1 – 64GB RAM in HPE ProLiant ML30 Gen9.
       
       
       

       
      Figure 6 – View of the four new DIMMs installed for 64GB of RAM. Time to replace the air baffle, tower bezel, and side panel then hook up the ML30 Gen9 and see if it works!
       
       
       
       
       

       
      Figure 7 – IT WORKS! Screen during first post showing 64GB RAM - for the first time!  Thank you Schoondoggy!!
       
       
       

       
      Figure 8 – System Summary Information showing 64GB RAM installed
       
       
       

       
      Figure 9 – System Information with Installed Physical Memory (64GB RAM) Highlighted
       
       
       

       
      Figure 10 – Task Manager showing 64GB of DDR4.
       
       
       

       
      Figure 11 – iLO4 System Information – Memory Information showing four 16GB DIMMs installed.  Status is "Good, In Use".
       
       
       

       
      Figure 12 – Temperatures appear well within range while system fan speed was a consistent 6% - BIOS set to Optimal Cooling (Note that the two 40mm fans in the Icy Dock ToughArmor MB994SP-4SB-1 were also running).
       
       
       

       
      Figure 13 – HPE ProLiant ML30 Gen9 running with 64GB RAM and using 30.1 Watts. Everything seems to be working well – time to think about adding more drives and turn on Hyper-V!!
       
       
       
      As-Built (I named my Computer: Serenity)
      HPE ProLiant ML30 Gen9 (Product No. 830893) Xeon E3-1240v5 (SkyLake LGA 1151) 64GB ECC RAM – Kingston KVR21E15D8/16 OS: Windows 10 Pro B140i Dynamic Smart Array: Ports 1-4: (4*3.5” Drive Tray Caddies for Main Drive-Cage Assembly Bays 1-4) B140i Dynamic Smart Array: Ports 5-6: Icy Dock MB994SP-4SB-1 in Top 5.25” half-height Bay; with/ 2*18” SATA III (6 Gb/s) cables attached to Bays 1 & 2 (Bays 3 & 4 are available for future); Molex to Molex & Fan Y-Connector Cable; Samsung 840 Pro 256GB in Bay 1;  
       
      Please join us in the HomeServerShow Forums to discuss this and tell us what you are building at home.
       
       
       
      Reference:
       
      RAM for ML30 Gen9 http://homeservershow.com/forums/index.php?/topic/14807-ram-for-ml30-gen9/
       
      ValueRAM Decoder https://www.kingston.com/us/memory/valueram/valueram_decoder
       
      ValueRAM KVR21E15D8/16 Specs Sheet http://www.kingston.com/dataSheets/KVR21E15D8_16.pdf
       
      Check HSS Forum Post: Other HSS ML30 Blog Postings: http://homeservershow.com/tag/ML30
       
      HomeServerShow Forum for ML10’s & ML30’s http://homeservershow.com/forums/index.php?/forum/98-ml10-and-ml10v2/
       
      HPE ProLiant ML30 Gen9 Server Maintenance & Service Guide http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c04905980-1.pdf
       
      HPE ProLiant ML30 Gen9 Server QuickSpecs http://h20195.www2.hp.com/v2/GetDocument.aspx?docname=c04834998&doctype=quickspecs&doclang=EN_US&searchquery=&cc=us&lc=en
    • Joe_Miner
      By Joe_Miner
      To see if it would work I moved the Drive Cage from the ML30G9 to my ML10v2 and hooked it to my P222 with 4 5TB drives.  Then hooked a SAS/SATA breakout cable to the MB SAS connector and attached two SSDs to ports 1 & 2 -- Port 1 SSD has my OS (Windows 8.1) and Port 2 SSD has my HyperV VMs.  Ports 3 & 4 I ran to an Icy Dock that can hold 4 2.5" HDDs in a 5.25" ODD slot.  I also ran SATA cables from MB Ports 5 & 6 to the Icy Dock and in the Icy Dock I have 4 1TB 2.5" HDDs.
       
      So far so good!
       
      I added two 60mm fans to the ML10v2 which is now keeping the P222 temps in the 50sC (climbed up to 85+C when I first tired it without the fans- Yikes).
       
      If this setup works after some burn-in I plan to use it to duplicate my entire main home server's data
       
      Planning a move (to the Buckeye State)  in the not to distant future which has kept me quite busy with little time to spend on the boards or just playing with Tech so it was nice to spend part of a rainy afternoon with the ML10v2 and ML30!
    • Joe_Miner
      By Joe_Miner
      Step-By-Step: Server 2012R2 Installation on HP ProLiant ML30 Gen9
       
      NOTE: I think this is complete regarding what I have/plan to do but your circumstances may be different and YMMV – this is my recollection of what I have done
       
      Unless otherwise stated all ISO files I ran in iLO4 (after installing Advanced Key) attached to my ML30 Gen9 as virtual image files CD ROM/DVD and folders were attached as virtual folders
      ·         After my first power up with a Monitor and Keyboard attached so that I could get the IP address – I got into the machine via iLO4 and installed an Advanced Key  http://homeservershow.com/forums/index.php?/topic/10736-advanced-ilo-key-on-ml30-gen9/
      ·         I next went into HP Smart Storage Administrator (“SSA”) by selecting F5 during Post to create a Logical Drive (“LD”) that I can load my OS (i.e. Server 2012R2) onto
      ·         Created LD01 with 2 Samsung Pro 840 SSDs in RAID0 (attached to Ports 5 & 6) – I chose Ports 5 & 6 off of the System Board because my Hot-Swap HDD Caddy’s had not arrived yet  https://youtu.be/KQXhtoyczxw
      ·         No other drives were attached to the ML30 Gen9
      ·         Shut down the machine
      --
      Server 2012R2 Installation
      ·         Attached Server 2012R2 ISO
      ·         Selected IP “Intelligent Provisioning” F9 during Post and selected custom to retain the OS Logical Drive I had already created
      ·         IP completed the installation https://youtu.be/i8MU9daRi7Q
      ·         I next:
      o   Changed screen resolution (personal preference YMMV);
      o   Ran NETPLWIZ (personal preference YMMV – for awhile there will be a lot of reboots & updates so this is just a time saver for me);
      o   Set Time Zone (personal preference YMMV);
      o   Enabled Hyper-V (personal preference YMMV – this will be in my home lab);
      o   Install desktop function
      o   Install server Backup
      o   Reboot;
      o   I had Set Computer Name during IP – but if I hadn’t this is when I would do it (personal preference YMMV);
      o   Reboot;
      o   Make sure Updates is set to include all Microsoft products;
      o   Began running recommended Updates – multiple reboots;
      ·         When all Server 2012r2 updates are done then I attached SPP and ran HPSUM in Windows Server to update &/or add missing Drivers (including anything missing in Device Manager) and including install SSA in Windows Server
      ·         Later in Windows 2012r2 I would run SSA (added earlier by HPSUM) to set up additional logical drives which I would then have to format in (Windows Server) Drive Manager
       

       
       
       
       

       
       

       
       

    • Joe_Miner
      By Joe_Miner
      After I had installed an Advanced Key for iLO4 I set up my OS Logical Drive in the B140i on my ML30 Gen9
       
      During Post I hit F5 which took me into the SSA and I selected the two SSDs I had attached to Ports 5 & 6 and created a Logical Drive RAID0 of those two SSDs
       
      Worked like a charm -- just like working in SSA on MS G8, DL320e, and ML10v2 -- NICE
       

       
       
       
       
       
       

×
×
  • Create New...