Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoticons maximum are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • adih2001
      By adih2001
      Hello! Recently I've been thinking to upgrade the CPU in my HP ProLiant ML10 v2. It currently has a Intel® Pentium® G3240 (I got the model of this server that comes with the Intel® Pentium® G3240) and according to the manual I should be able to upgrade the CPU to a Intel® Xeon® E3-1220v3. Is this true? Do I need to change / get anything else? Thanks.
    • acidzero
      By acidzero
      Hello,
       
      So, after several days of testing various different configurations, creating custom ESXi install ISOs and numerous reinstalls, I've managed to get ESXi 6.5U1 installed on my Microserver Gen8 and have working HP Smart Array P410 Health Status showing. For those that are struggling to do the same, firstly here's how. I used original VMWare ESXi 6.5U1 ISO, build 5969303 then made the following modifications:
       
      Remove driver "ntg3" - If I left this in, I had a weird network issue where Port 1 or 2 would repeatedly connect/drop every few seconds. This forces ESXi to use the working net-tg3 driver Remove driver "nhpsa" - this Smart Storage Array driver is what causes array health monitoring to not work. Remove to force ESXi to use working "hpsa" driver Add the Nov 2017 HPE vib bundles Remove hpe-smx-provider v650.01.11.00.17 - This version seems to cause the B120i or P410 to crash when querying health status Add hpe-smx-provider v600.03.11.00.9 (downloaded from HPE vibsdepot)
      Add scsi-hpvsa v5.5.0-88 bundle (downloaded from HPE drivers page)
      Add scsi-hpdsa v5.5.0.54 bundle (downloaded from HPE drivers page)
       
      I did the above by getting a basic/working ESXi/VCSA installation and then creating a custom ISO in VCSA AutoDeploy and exporting it. But the same can be achieved by installing VMWare's original ISO and modifying via the esxcli command.
       
      I have a SSD connected to the SATA port, onto which I am installing ESXi. The 4 front drive bays are connected to the P410.
       
      Configure the Microserver Gen8 B120i to use AHCI mode - the B120i is a fake raid card so only reports physical disks to ESXi. Leaving in RAID mode works but I got a false Health Alert on Disk Bay 5 Install my modified ESXi ISO to the SSD  
      With these modifications I have a working ESXi 6.5U1 on my Gen8 with fully functioning HPE tools and array health monitoring:
       

      I also tested disabling the vmw_ahci driver, which is why the AHCI controller shows it is using ahci in the above image.

       
      If I pull out a disk to test a raid failure, when the health status next updates I can see a raid health alert in the ESXi WebGUI:
       

       
      However I'm now stuck at the next stage - getting this storage health to pass through to VCSA. VCSA can successfully see all other health monitors (under System Sensors in ESXi) just not the storage, which is the most important.
       

       
      Does anyone know how I can get the storage health working in VCSA?
       
      Thanks.
    • Anatoli
      By Anatoli
      I've pinged Schoon about some questions I had regarding the Gen8 upgrade but I guess a community discussion will be more fun.
       
      The ultimate config
      The final config I'm planning to have is the following:
      E3-1265L CPU found on eBay at around $90 (no cheaper ones ) 16GB RAM which I'm still looking for (and want a cheap one, c'mon!) Main Drive made of two SSDs in RAID 1: Samsung MZ-75E500B/EU 500GB SSD Crucial CT500MX500SSD1(Z) 500GB SSD Storage Drive made of four HDDs in RAID 10 (I'll probably get some large Seagates)  
      Basically, what I would like from the Gen8 is to be a container host as well as a data storage unit. The OS and the VMs will be located on the SSD mainly, if larger storage is needed it could be nice to link it to the 4 disk array. I would like to RAID the thing using mdadm and virtualize using KVM so I would more likely use FreeNAS, Debian or Ubuntu as OS. Any thoughts about this? Suggestions?
       
      Getting down to the ports
      After looking into it for quite a long time now, I see the Gen8 motherboard has a max 5 disk capacity using all SAS/SATA ports. This won't fit my need since I need the 6th drive, and I need to get a RAID controller but since I'm going to RAID via software I won't need that and can definitely go for just a SATA PCI-e card with ya boy Marvell 88SE9215 instead.
       
      What do you think about this? Am I doing good at computers so far?
    • RyanG8
      By RyanG8
      Hi all, Thought I would make a post about a recent project I started as it may be of some use as it's a fairly good base for a home server.
       
      I recently bought a HP Proliant ML350p G8 on eBay for around $350, It had no drives, a very low spec E5-2609 4-core and 8GB of ram.
       
      My first problem with this server was that it was loud, not really rack mount loud but too loud for me in a quiet room. So I thought hey! why not watercool it, so I set out doing research. I removed all three 92mm delta fans and spent an evening working out how to fool the system into thinking it still had them so it would let me boot it and see that all the fans were working, this was done using jumper cables in the hot plug slots; connecting the two black grounds and the single yellow signal pins together in each 5-pin header, there was no documentation on this anywhere that I could find so it was all trial and error, I hope this helps if you are considering watercooling any G8/G9 Proliant server as I imagine its fairly similar.
       
      I also wanted a bit more punch so I had a look around and settled for a E5-2630v2 6-core from eBay for $70
       
      Next was sourcing watercooling for it, I have gone for a single closed loop Corsair H90 $65 and a Asetek 2011 Narrow ILM ring adaptor $8 found HERE to fit the 2011 sockets found on the ML350, these bits are being delivered in the next few days so I will update with photos and results when the H90 is fitted! I might get another 2630v2 if all goes well as it has two 2011 sockets available.
       
      This box will be used as a development environment eventually, probably running Hyper-V but I may throw a graphics card in it before and see how it does in some games just for the fun of it   
       
      Hope this is of interest.
       
      Ryan,
       
    • npapanik
      By npapanik
      As in subject, Service Pack for ProLiant 2018.03.0 (SPP) does not support Microserver Gen 10?
       
      Any explanation?
       
      TIA


×