Jump to content
RESET Forums (homeservershow.com)

HP Microserver Gen8 SATA AHCI 4TB drive not recognized


Recommended Posts

Hi to all,


I have bought a Microserver Gen8 to make a small home server. I have bought also some Western Digital GOLD 4TB hard drives and I have tried to install one of those in the front slot 1.


Before installing the drive (that was checked for errors with wd utility full test to be sure that was ok), I have decided to set the controller to SATA AHCI mode, so later I can use software raid for controlling the storage array and have a raid5 option.


Something strange happens.


When I have booted the microserver for the first time with hard drive installed the hard drive was recognized (I have seen it on the boot sequence) but with a strange message "ATA security state of this disk is invalid". After restart/shutdown of the microserver the drive wasn't recognized anymore. I have tried everything, from re-insert the drive in the slot, check backplane cables, check again the drive on another pc with wd utility, nothing, no errors on it, the drive is ok but isn't recognized anymore.

If I listen the sound it emits when it is installed on the microserver, at the start I can hear the usual spin-up of the motor, then when the boot sequence arrives at "HP AHCI SATA controller....initializing" I can hear the the motor spin-down and it isn't recognized (no message). Reset the server don't restart the the hard drive motor, the only thing is a shutdown of the microserver.


Later I have tried to set again the controller in HP Smart Array RAID MODE and with F5 I have entered the smart array manager setup. Here I can see that the drive is recognized again. Changed again the controller in SATA AHCI and it isn't recognized anymore, same as before.

The diagnostic of the microserver is ok, no errors. The microserver is new HPE 2017 version. BIOS is obviously the last J06 (11/02/2015). And for be sure before using the server I have used the SPP from usb for check that all is updated.


Do you have some suggestions or maybe someone know something more about this problem? Like I have said before. when I have booted the microserver for the first time and the hard drive was recognized (the only time) what could be that strange message: "ATA security state of this disk is invalid" ? Someone who has his drive recognized can gently confirm me that he sees the same message during boot on his hard drive? from what I know is a security feature used most on laptop but for sure it was not enable on my WD GOLD. The drive was perfectly new, never used and sealed on his antistatic cover.


Many thanks to all for your precious help


Edited by Tyon3r
  • Like 1
Link to comment
Share on other sites

UPDATE: I have done some more tests and, when the controller is set in AHCI mode, the disk isn't recognized when installed in bay1 or bay2, but is recognized in bay3 and bay4. When the controller is set in RAID mode the hard disk is recognized also in bay1 or bay2. Definitely not a problem of the hard drive or a backplane/cable problem. Is HP that has crippled something from working when you set the controller in AHCI mode? 

Link to comment
Share on other sites

Sorry if it doesn't help but I can only report my (simple) usage.

On both Gen7 and Gen8 servers I use the machines as they come: no bios updates, no service packs, no iLo, no switching to AHCI, no driver installs EXCEPT the B120i storage driver for Gen8,...

- I put a 2TB drive in bay1 (because the machines are BIOS, so the first disk is limited to 2TB) replacing the small original disk

- I install Windows 10 PRO on disk 1, which recognises all the drivers needed for remote operations (bar the aforementioned B120i)

- I add disks of varying sizes in bays 2 through 4 ... 1TB, 2TB, 3TB, 6TB, 8TB ... via disk administrator on the Gen8 ... giving them partitions of type GPT in Windows (required for disks above .2TB)

The only problem I've had was leaving the original 2GB RAM in the Gen8 - SD solved that: it needs to be 4GB or DA will lose the array configuration whenever attempts are made to change it.

Otherwise no problems.

Link to comment
Share on other sites

Thanks for your help JackoUK.


The problem in my case is switching to AHCI (and I need it), if I leave the B120i in RAID mode the disks are recognized in bay1 and 2. Very strange error.


However thanks for you help. It's useful to me to know some configurations that works with the Gen8.

Link to comment
Share on other sites

  • 3 weeks later...

I use WD Red 4TB drives in my Gen8 with J06 BIOS and this has worked fine for about a year or so. I run Xpenology on it, which boots from a USB stick. I didn't do any configuration to the B120i, Xpenology recognised the drives and I could set up RAID from there. I have changed the CPU and RAM, but I doubt that would Make a difference. Could it be a firmware thing on the drive itself? I don't know if you can update it, but the Red drives have some sort of firmware called NASWare, but I don't think this is updatable. I have run the latest SPP but it only updated iLO. The only other thing I have is the iLo4 Advanced license, but again, I don't see how this would affect the hard drives. 


CPU: Intel Xeon E3-1265L


Slot 1 : WD Red 4TB NASWare 3.0

Slot 2 : WD Red 4TB NASWare 3.0

Slot 3: WD Red 4TB NASWare 2.0

Slot 4: WD Red 4TB NASWare 3.0 recertified

ODD port: Kingston 960GB SSD

OS: Xpenology 6.1.2

RAID: SHR (Synology Hybrid RAID) on all 4 drives


could use set up the drives as RAID 0 and use them like that?

Link to comment
Share on other sites

@Tyon3r did you get anywhere with this? ive got exactly the same issue with my new gen8 not reading drive 1 on boot with AHCI. I have tried the service pack update but no joy. All drives show up if i change to a raid mode.

Link to comment
Share on other sites

  • 4 years later...



I also got crazy having this problem (no sata disks were recognized at all), but then I found out what the reason was: The Gen8 has its 5.th disk slot on the top. This slot gets his energy via the 4 pin cable that comes from the ground. But there are two wires coming from the ground. One from the mainbord (for power delivery), the second GOES to the internal sata disks. So doublecheck that these two cables are connected again after removing you 5th disk. Otherwise, the 4 internal sata slots dont have power at all.


Best regards dontspeak

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Haxsource
      By Haxsource
      Good afternoon folks!
      I have a question I was wondering if someone would know about. I have a Microserver Gen 8 with Vmware ESXI 7 currently installed on the MicroSD with AHCI enabled instead of RAID mode (dont find anything usefull in raid mode in my current setup other than booting from ODD, which I can just use as another Datastore instead).
      With that context being said, Im trying to enable the Agentless Management Service from the ILO with the drivers on the Vmware ESXI 7, but unfortunetly after installing and trying to start the service with:

      /etc/init.d/hp-ams.sh start  
      I get the following error:
      /opt/hpe/ams/amshelper: error while loading shared libraries: libnicmgmt.so.0: cannot open shared object file: No such file or directory  
      Makes sense following the Vmware ESXI HPE support matrix, since its only supported until Vmware ESXI 6.5U2 Pre-gen. But I´ve been reading lots of people having working setups doing the following:
      Install Vmware ESXI HP Custom Image 6.5U2 -> Offline Update to Vmware ESXI 6.7.
      I was wondering if installing HP Custom Image 6.5U2 with the drivers Agentless Management Service working and doing a full upgrade to ESXI 7.0 would do the trick, since its an upgrade not a clean install...so libraries should stay supporting older drivers installed.
      Does this make any sense?? Has anyone gone trough this alredy?
    • netware5
      By netware5
      ***CRITICAL*** iLO 4 update available here. HPE requires users update to this version immediately. Potential vulnerabilities in network stack.
      A potential security vulnerability has been identified in Integrated Lights-Out 5 (iLO 5), Integrated Lights-Out 4 (iLO 4), and Integrated Lights-Out 3 (iLO 3) firmware. The vulnerability could be remotely exploited to cause memory corruption.
      HPE has released updated firmware to mitigate these vulnerabilities.
      References: CVE-2020-27337
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
      Hopefully this information will prove useful to some looking to update their MicroServer.

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
  • Create New...