Jump to content
RESET Forums (homeservershow.com)

My First Review of HPE ProLiant Gen10 MicroServer BETA


Recommended Posts

11 hours ago, Lallkopf said:

I did Turn Off UEFI and also Set the SSD as First Boot device. Still it does not boot from SSD. 

Is the SSD the only drive in the server?

Link to comment
Share on other sites

On 9/16/2017 at 7:04 PM, schoondoggy said:

Is the SSD the only drive in the server?

My setup looks like this. I have 2 RAID HDD with 3TB each. I use it for data backup and multimedia purposes. The other two bays I like to use as a normal storage for multimedia only - both data content are expandable. All these drives are HDDs (2x3TB RAID;; 1 x3TB & 1x4TB). For the OS I wanted to use the 5th SATA interface with my SSD (120GB - I know it's big...).

Originally idea was to install NAS4Free on the SSD. Unfortunately there are some issues with the compatibility of this OS, but I saw that the booting process worked with SSD. Therefore I wanted to install Linux. I tried to install either Debian and Ubuntu distribution. Interesting was, that via internal USB it worked like a charm. I could see and install both distributions on the SSD. Once I rebooted with SSD as boot device it hang up stating that there is no OS installed. I guess that there is still a BIOS problem, but I'm not sure.

By the way thanks for helping! :)

Link to comment
Share on other sites

I am not as Linux knowledgeable as I should be, but when I have boot issues I try to get back to the basics. I would remove all of the drives other than the SSD and I would clear all partitions from the SSD. Then I would do a clean load of a OS and see if it boots. If I get a chance I will try to load Ubuntu on a SSD in my Gen10. 

Link to comment
Share on other sites

I tried this before. I removed all drives and made a clean Linux setup on the ssd without any other partitions. Same result. I was puzzled since starting Linux with USB seemed to be no problem. This is why I assumed it might be a BIOS issue. Another possibility might be that the server is broken. I considered this as a low chance possibility. 

Link to comment
Share on other sites

  • 1 month later...

Hi, has anyone used Gen10 as HTPC here? I am interested to know if it's graphic card can do bit-streaming for DTS capable AVR or TV?


I read it is the best choice for media servers and HTPC, if compared with Gen8. I hope it is true so far after its release. Thanks

Link to comment
Share on other sites

On 11/15/2017 at 6:18 AM, Lord Raven said:

Hi, has anyone used Gen10 as HTPC here? I am interested to know if it's graphic card can do bit-streaming for DTS capable AVR or TV?


I read it is the best choice for media servers and HTPC, if compared with Gen8. I hope it is true so far after its release. Thanks

Not sure if it does. Unfortunatley, I do not have a good way to test it right now.

Link to comment
Share on other sites

Does anyone know if HPE Smart Array P420 controller will work on the Microserver Gen 10?
I have not tried a P420, but I did try a P222 and it did not work.
Link to comment
Share on other sites

Thanks schoondoggy.


Can you elaborate a little more. Didn't work at all?

I know there is some problem enabling the Smart Array Pxxx controllers ROM on a non Proliant server (I remember reading that it is related to some iLo hooks). Was that the problem?


My goal would be to build a home NAS with 4x4Gb WD Red SATA disks at RAID 5. I don't want software raid (been there) but I'm cool with hardware RAID as I use it a lot on work (mainly with P400 on a DL380 with SAS).


What are my options for a hardware RAID controller that works on the Microserver Gen10? (online RAID expansion would be a nice bonus).


Thanks you,

Paulo Carmo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • BooyaK
      By BooyaK
      Hi all
      Apologies for hijacking a new thread as I couldn’t easily find an existing post which described this..
      I have an original HP Microserver N36L from 2012 that am Iooking to upgrade to a Gen 10 Plus.
      In the N36L I have added a Smart Array P410 with 256MB FBWC (via ebay) configured with 4 x 2TB WD Green drives with RAID5 (6TB logical) along with a 256GB SSD as a boot system drive in the ODD bay (with the BIOS mod of course) plus a PCIe x1 video card.
      The server is running Windows Server 2012 R2 but looking to uplift to 2019 (and maybe 2022 once it comes out) for general home enthusiast use mainly as a file server and to test VMs for labs.
      Am I able to “lift and shift” the drive array subsystem from the old to new server? I have done this on the DL380s in the past as the controllers and drives hold the RAID config.
      I guess I’m happy to get a new boot SSD if required (maybe boot issues between AMD and Intel CPU) but may have constraints mentioned below with the 5th interface.
      Have read from the various great posts by schoondoggy etc. that the P410 has issues with UEFI etc, so looking at a compatible option that’s not the “latest and greatest” eg something that can bought via ebay second-hand and relatively inexpensive (the E208i-p maybe stretching it…) and can of course read the existing RAID5 array config from the drives.
      Once moved across, I plan to progressively update them to larger HDD or SSDs and use the Smart Array expansion utility to expand the RAID-5 logical drive size once array rebuilds are complete.
      From what I understand I can’t add the 5th drive as there is no onboard NVMe or SATA connector. There is USB3 to boot off a thumb drive of course which is great for VMWare ESXi but maybe not for Windows…
      If I add the Smart Array card I guess it may limit my options as I understand it only has one PCIe x16 slot so can’t do both.
      Does anyone have any suggestions or other techniques (for example I’m not fussed with the expansion iLo slot but I think dedicated for that purpose only)?
      I have also looked at some of the great Servethehome reviews and benchmarks too but these are early 2020 and things may have evolved since then.
      Thanks in advance!
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
      Hopefully this information will prove useful to some looking to update their MicroServer.

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
      Has anyone around here been successful in setting up Proxmox on a Gen8 using a HBA for storage?
  • Create New...