Jump to content
RESET Forums (homeservershow.com)

Comparing the HPE ProLiant Gen10 MicroServer BETA to Previous MicroServers

Recommended Posts

26 minutes ago, yodafett said:

Think I will be moving to a Dell T130 or a ML30 if I move to new platform.  Rather get 64MB with iLO/Drac and options compared to a soldered chip.   Or possible a Xeon-D and Virtuallize everything.

thats what i'm thinking of, buy a Supermicro SuperServer 5028D-TN4T , or HPE realize their mistake, and do a quick rework of microserver to a V2 version. I hope sales will tell that they're wrong this time...

Share this post

Link to post
Share on other sites

Well, this V10 looks really ugly and cheap. That kind of black plastic does not look the same as the old V8. And I also prefer the old HDD cages with bracket.

Anyway, I receive:

- 32GB RAM vs 16GB in the old one

- better GPU and DP (I do not need it)

And I loose:

- iLO + IP

- integrated RAID controller B120i

- swappable CPU (comparison here between AMD Opteron X3421 APU and Intel Xeon E3-1265L V2: http://cpubenchmark.net/compare.php?cmp[]=3026&cmp[]=1486 )

The RAM limit cannot be extended, but for a better GPU I will definitely prefer GT 1030 with 4K resolution supported for 70$ instead of the integrated one from APU.

In conclusion, I think I will buy a new Gen8 just to have. Last time I found it for 250$ (stock G1610T + 2GB ram) but the upgrades were also decently priced. I do not think this one will be cheeaper.

Maybe this one can be an option for someone who needs a small PC/media server but usually when you need a small PC you need also a good gaming video card to play on, and then you need cooling and there are much better options there for small cases with good ventilation.

Edited by OctavianH

Share this post

Link to post
Share on other sites

My use case of  2 x HP Microservers Gen8 :

1. Bare metal FreeNAS 9.10 in a DR site. i3-3240 / 6GB RAM

2. ESXi 6.0u3 with E3 1230 V2 / 16GB RAM . IBM M1015 IT passtrough in a FreeNAS 9.10 VM. Plex and other stuff in Freenas jails. Several VMs of Win10 and Windows server 2012 R2 and SQL on ESXi.  All serving my home as a lab server , test server , practice and etc.   Both is working very well , performance is good. Very good indeed.

I can't buy Gen10 because : no iLO, FreeBSD not supported ( marvell has issues with ZFS) , ESXi not supported and i think if you need ESXi on Gen10 you will need new disk controller and network card, no custom HP image also. So both slots PCIe will be used. So no advantage at all. Even if you get ESXi installed, APU is not strong enough. What a loss compared to a Gen8... And it took 4 years to HP to release this....


Edited by FreeN@S

Share this post

Link to post
Share on other sites

How about power consumption under load and idle?

(barebone system without drives)


7 hours ago, OctavianH said:

- swappable CPU (comparison here between AMD Opteron X3421 APU and Intel Xeon E3-1265L V2: http://cpubenchmark.net/compare.php?cmp[]=3026&cmp[]=1486 )

Edited by Notbugged

Share this post

Link to post
Share on other sites
29 minutes ago, Notbugged said:

How about power consumption under load and idle?

(barebone system without drives)


I was seeing 29.7W this morning idle but it wasn't bare bones

That's slightly higher (as I recall) than what I was seeing when it was bare bones with only the Samsung OS drive and 8GB RAM and one monitor -- I was watching the power a lot early on -- I need to check thru my pics and videos


  • Like 1

Share this post

Link to post
Share on other sites

And compare to 1265L v2? 

Share this post

Link to post
Share on other sites
3 hours ago, Notbugged said:

And compare to 1265L v2? 

Comparison of CPU PassMark Performance Indices -- the Xeon E3-1265Lv2 has an average PassMark score of 8142 (8142 is what I measured in my Gen8 3+ yrs ago, PassMark now shows a score of 7745 for the 1265Lv2) or about 159% of the 5108 I saw with my first PassMark test of the Gen10 (though the 2nd time I tested it the Gen10 came out a little higher at CPU 5147 & System 2225).

The overall PassMark Performance of the Gen10 was 2208 compared to the Gen8 at 614 -- so by that measure the Gen10 is 360% of the Gen8 with a E3-1265Lv2 (or if the Gen10 is 100% the Gen8 is 28%.

2017-06-09 PassMark Performance.JPG

2017-06-09 Gen8 PassMark total System.JPG

2017-06-09 Gen10 PassMark total System.JPG

Share this post

Link to post
Share on other sites

Thanks! How about the power consumption?

Share this post

Link to post
Share on other sites

I really like this new Gen10!!!. Its going back to its original G7 roots and design concepts.


  • No extortionate Intel pricing. Back to AMD with an impressive 5k passmark (better than your modern ultrabook i5s and i7s) This was the original reasoning behind a microserver.
  • 2 PCI slots, presumably you can buy an iLO solution if you really need one, just like in the past.
  • 6 Sata ports. With some modding, you can have an SSD and a 5th LFF drive.
  • iGPU which supports 4k (and beats Intel iGPU based on the passmark). Perfect for HTPC, CCTV, Encoding etc. In Gen8s there was an iGPU but it couldnt be used due to the iLO architecture. 


I would even argue that for most people there is no need for 2 PCI slots now that we have an impressive iGPU, 6 SATA ports and dual NICs. The two slots are now just a bonus feature for "real" expansion and not compensating for the lack of an iGPU or single NICs or adding more internal drives.

The Gen8 "RAID" controller was a CPU based software RAID causing further overheads. I dont really consider this a loss. You now have 2 PCI slots if you need real RAID.


The only real downside is the soldered APU, but the 5k bench/4cores are nothing to be scoffed at. Intels options were marginally better and this APU is light-years ahead of the original NL54 CPU, WHICH PEOPLE STILL USE TO THIS DAY :D


Best of all. You are not paying Intel. Yes Please.

  • Like 1

Share this post

Link to post
Share on other sites

don't forget that one slot is not usefull at all : it is x1 electrical. So you can't add 10Gbe network card and you can't add controller/HBA together.

x1 slot is more for serial ports. if you need to add serial port. Nothing more here compared to Gen8.


On a Gen8 you could always add video card. 


B120i is HP custom controller on C204 chipset. It is far better for ZFS (Freebsd, FreeNAS) using in AHCI mode than Marvell. 

And Marvell is on PCIe x2 connection, so all ports will not work at full speed. 


AMD IOMMU is probably not supporded. In another thread here waiting on answer from HPE. 


And in total you pay more: you can't buy small and upgrade. With upgraded CPU on Gen8 you have up to ~9000 Passmark, not 5000.


There is still no info from HPE about additional Remote Management solution.


On 6/6/2017 at 5:57 PM, Ricimer said:


This is *very* bad news for anyone not running Windows. There are a number of unresolved NCQ issues with the Marvell controller on Linux and Freebsd.

I've seen long running threads with no solutions, the issue is some commands (like scheduled SMART scans) will cause the drives to timeout when using NCQ. Not good for ZFS etc.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Sokoban
      By Sokoban
      I have problem to rebuilding a disk for Windows Server 2016 Essentials  C:\ disk. I have replace a disk with same diskspace (160GB) and running with RAID1. 
      Have restart the server and have select F2 for rebuilding and the server wont rebuild the disk, I have now got the same message, 
      776 Logical Drive 1 is queued for rebuilding.
      Where can I found the logfiles for troubleshooting ? and what can I do further with that problem  ?
      Thanks in advance 😉
    • GoHerdIBG
      By GoHerdIBG
      I also posted this on the HPE forums.
      Just bought my first HP Microserver and got a decent deal on a Gen10 x3421.  I am using a USB key to try and install either CentOS or RHEL 7 on it and neither install sees any of the disks in the front slots.  I am using 1TB WD Caviar Green drives.  I have also tried a Seagate drive but nothing seems to work.
      I have gone back and forth between EUFI and Legacy hoping that would help.  Nothing.
      I am currently installing on a 500B USB drive and hope to see if the drives are visible when I fully boot.
      I also looked through the drivers and firmware and did not see anything directly related to my problem.  I was going to download the SPP but couldn't igure out how to register my system manually to allow me to download the SPP.
      Am I missing anything obvious or does the system not yet support RHEL 7 or CentOS 7?
      Thanks for any information.
    • rubenbb
      By rubenbb
      Hi all,
      I have a HP Microserver Gen 8 upgraded to Xeon E3 1265 v2, 16Gb RAM, SSD 256 Gb on the ODD Port and 2 x 3 TB WD RED disks
      In the SSD I have an ESXi 6.5 U2 (HP custom image) version installed (driver downgraded to 5.5.088 from 5.5.102) and the WD Disks are in RAID 1 for datastore of vmware related files
      I just bought a HP 410 Raid Controller with 1gb FWBC and battery 
      I did read a lot about this subject, I know that isn't possible to be monitored by ILO 4....but I would like if someone can confirm me my thoughts about how to made this migration
      1) Plug HP410 on the mobo
      2) Connect Cable used in the disks WD to the lower port of the P410
      3) Connect ODD cable used for the SSD Disk in the upper port of the p410
      4) Turn On microserver and enter in the SSA and check if arrays created in the b120i are visible for the p410
      5) If is OK, restart
      - I have that to do something for to boot the SSD that has ESXi installation when boot up server?
      - Driver 5.5.088 hpvsa will see the datastores on the p410 without no action from my side?
      - Must I disable b120i on bios or is possible co-live with the P410
      It'll be very apreciated the help 
    • in2thepit
      By in2thepit
      Hi Folks,
      I am hoping that you can help with an issue I am having with my new HP Microserver Gen 10. Apologies if I am posting in the wrong place. 
      The microserver CPU is constantly running at 100%. It occasionally dips but normally is maxed out. I have build the server from new using Samsung SSD drives in a Raid 1 configuration initially. I have also tried the following.
      1. Single SSD with windows 10 Pro
      2. Single SDD with Server 2016
      3. Raid 1 with Server 2016.
      4. Single SATA with Windows 10 pro.
      I have updated the firmware. I have downloaded all the latest drivers from HP's portal.
      I have tried to get support from HP but they are providing one excuse after another to explain why they cant support the server. Currently the server is about a month or so old.
      HP Support responses..
      1. Windows 10 isn't supported.. ( Despite having windows 10 drivers for this server on their portal)
      2. SSD drives are not supported
      3. SATA drives are not supported unless they have HP branding. ( The Gen 10 is being sold on Amazon with Western Digital drives included)
      We have tried killing of several services in Windows 10 as per articles that we have found online. We have set the Virtual Memory to refresh on reboot.
      None of the above have achieved anything. 
      As a result of the CPU running constantly at 100% the system is unbearably slow and cant be used to run even the most basic of tasks.
      It looks like we have been left holding an expensive tin box.
      I have attached a screen dump showing the CPU utilization. 
      Any help or advice at this point would be greatly appreciated.
      Kind Regards