Jump to content
RESET Forums (homeservershow.com)

HP MS Gen8 AHCI 8TB drives not recognized in slot 1 and 2 but fine in slot 3 and 4


Caat
 Share

Recommended Posts

Hi,

I have recently bought a MS Gen8 as I was impressed with the quality and built of the machine and wanted to make a small home-server for back-ups and central file storage. I want to run the server with Ubuntu server and decided to set the drives to AHCI mode and use software raid for the controlling the storage drive. The installation went fine and OS is working properly.

I wanted to max out on the storage capacity so bought 2 8TB drives and tried to install those in the front slots 1 and 2. I have the OS installed on a small USB 1TB HDD that I installed on the internal USB drive and that sits nicely in the DVD player slot.

Then strange things happen. When I boot the server the HDD drives (WD RED 8 TB) are not recognized in slots 1 and 2 and not mounted when the OS is running. However, if i flip them out of the drive slots and push them back in (kind of a hot-swap) they do mount and seem to be fine.

Then - if I reboot the server and stick them in slots 3 and 4 and start up the drives are recognized by the AHCI adapter (S.M.A.R.T. drives detected etc..) and all seems fine from the beginning. 

 

I tried shipping the sever back to the vendor, who replaced hardware and sent it back to me - with the same persisting behavior. I tried contacting HP - but they told me 8TB must be the problem...

 

Has anyone an idea what causes this behaviour and what I can do about this?

 

Also - I downloaded the latest SPP ISO to install, but I am such a newbie I don't know how to make it a bootable USB stick. I tried using Rufus and booting from it doesn't seem to work. I tried under Ubuntu to just insert the usb and run the setup utility but it appears not executable so I am a bit at a loss - any hints how to do that the right way?

 

Many thanks - I highly appreciate any help or suggestions!

 

CAAT

Link to comment
Share on other sites

If you have iLO configured you can remotely mount the ISO image from another machine and boot it remotely. 

Link to comment
Share on other sites

  • 1 month later...

This seems to be a bug with the first two slots of these servers and the wd 8tb red drives. 

 

Did you find any fix for running in AHCI mode? 

Link to comment
Share on other sites

  • 4 weeks later...

I think I have the same problem with mine. I have tried to install a Western Digital GOLD 4TB on first slot with controller configured in SATA AHCI mode and the drive isn't recognized...or better it was recognized only one time (the first) with a strange message added to it: "ATA security state of this disk is invalid" then nothing, it isn't recognized anymore.

 

I have done a post with details of my case.

 

If I change again the controller to RAID mode it is recognized, only in SATA mode it isn't.

 

I'm interested too if someone have found a solution. Many thanks

Edited by Tyon3r
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...