Jump to content

Windows 10 Pro on HPE ProLiant ML30 Gen9

Recommended Posts


It works and the install was relatively easy.  I installed Windows 10 Pro x64 on HPE ProLiant ML30 Gen9



I used iLO4 to remote into the ML30 Gen9 and began to install Windows 10 Pro x64 manually (i.e. without using IP) in the following general steps:

Since I had just recently done steps 1-6 not long ago I skipped down and began with Step 5 then skipped to 7 thru 16 below.

  1. Download Service Pack for ProLiant (SPP) from Hewlett Packard Enterprise Support Center – Drivers & Software – the current version is 2016.10.0 (24 Oct 2016) – check also threads about SPP at HSS Forum MS Gen8
  2. Load the SPP ISO in “virtual drives” in remote desktop of iLO4
  3. Boot the ML30 Gen9 – with no drives in the ML30 Gen9 in my case – and let SPP run automatically and update all firmware.
  4. Shut down the ML30 Gen9
  5. Next: I removed the Samsung 840 Pro 256GB that I had loaded Server 2016 on (giving me the flexibility to switch OS’s by switching SSD’s in the ML30 Gen9) and loaded another Samsung 840 Pro 256GB into drive 1 of the Icy Dock ToughArmor MB994SP-4SB-1
  6. Go to the Hewlett Packard Enterprise Support Center – Drivers & Software – and download the file cp028631.exe that is the Dynamic Smart Array B140i Controller Driver for 64-bit Microsoft Windows Server 2012/2016 Editions (This is the same driver I plan to use for a manual installation of Windows 10 64-bit Pro in the ML30 Gen9 – the HPE Drivers & Software site does not have Drivers & Software for non-server OS’s) – the current version is (24 Oct 2016)
  7. Extract the files in cp028631.exe and load those into a file folder that I then attach/load in “virtual drives” of remote desktop of iLO4 (during Windows install this will be the folder I browse to so that Windows 10 can pull in the driver and see the Samsung 840 Pro
  8. Load the Windows 10 Pro x64 ISO in “virtual drives” of remote desktop of iLO4
  9. Boot the ML30 Gen9
  10. During boot go into IP (press F10) and select SSA (Smart Storage Administrator)
  11. In SSA I set up the Samsung 840 Pro as a single drive RAID0 to be used as my OS drive.
  12. Exit SSA & IP and Restart the ML30 Gen9
  13. Proceed with the normal Windows 10 Pro x64 install – During install Windows 10 will ask for location of drivers so it can see the drive(s) – in browse lead it to the location to the file folder of B140i driver(s) in the “virtual drives” C: -- if your OS drive had been previously formatted as MBR you will have to delete that so it can be formatted as GPT. 
  14. After Windows 10 is installed and updated – reattach SPP ISO in remote desktop of iLO4
  15. In the Windows desktop go to the SPP ISO in File Explorer and Execute the Batch file for HPSUM (i.e. execute: launch_hpsum.bat as Administrator) – I chose “Localhost Guided Update” – Automatic Mode
  16. After running HPSUM (and rebooting) the HPE software installed will be visible in iLO4.  Enjoy!
Edited by Joe_Miner

Share this post

Link to post
Share on other sites

More details and info in HSS Blog post "Install Windows 10 Pro x64 on HPE ProLiant ML30 Gen9" at http://homeservershow.com/install-windows-10-pro-x64-on-hpe-proliant-ml30-gen9.html








Let us know what you think!


What other OS's have folks loaded on their ML30 Gen9?

Edited by Joe_Miner

Share this post

Link to post
Share on other sites

Current issues I'm seeing with the B140i and SSDs 




Share this post

Link to post
Share on other sites

Hey Joe...any ideas for graphics cards on the ml30.  I like your write up, but am wanting to work at the console on this without paying for the two cards on the parts list: http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c04917058#N106E9
That would be a quadro M2000 or quadro k2200.  Both of those are around $500.  I don't need that high of an end gpu.  I'm going to try a quadro 620.  It's built on the maxwell architecture and is in the quadro line.  

So far I've tried an old ati 6350 with no luck.  The OS (win10) will install the drivers and it shows up in the device manager, although it sees a 7350.  Updating the driver fails with an unsupported os generic message.  I believe coming from the driver installation software.  No option to use this card in the display settings and forcing the bios to use it caused the bios to halt at post.  fun.fun.


Any thought other than use the supported hardware?

Is hardware validation baked into the system??



Share this post

Link to post
Share on other sites

I haven't tried any video cards in the ML30G9 -- I have used some little ones in the ML10v2 that also worked in the N40L & Gen8 MS's

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • JackoUK
      By JackoUK
      After 2 days and no problems with the Windows 10 Fall Creators Update I thought I'd report my conversion experiences.
      The upgrade was offered immediately on N36, N54 and Gen8 microservers, which in my case are running Windows 10 Pro.
      I accepted the 'in place' upgrade on 3 of my 4 machines ... with some trepidation since the last upgrade destroyed my shared folder configurations.
      No problems of any sort thus far: only the splash screens for the new features in Edge makes one aware that things have changed.
      'In place' with HDD's for the OS drive is .... very slow ... we're talking hours.
      The 2nd of my Gen8 machines stalled mid way through upgrade ...but I don't think that was a server or Windows problem: when I reverted to the old OS version disk errors were reported so I suspect the OS disk is on its way out.
      After repairing bad blocks I tried a clean reinstall. This is much faster (40 minutes) but one has to reinstall programs and reconfigure. Not a problem since this is only a file server, so only shared folders to reset. I'm glad this happened in one way ... good I think to remind oneself of how to handle a rebuild ... since I could not find the B120i driver file ... or indeed any other HP drivers for the Gen8, which should have been in my machine installation archive. Corrected.
      The usual sites were reporting that the new version of Onedrive requires manual installation. Worked fine.
      Time to explore the new features then.
      I've had it in the back of my mind to try REFS via Storage Spaces for some time. Unfortunately this is another case of NASDAQ:MSFT going backwards for consumers: that option is now removed and only available in the new Windows Pro for Workstations edition. Which I won't be buying.
      To be fair though the upgrade has worked without problems on LINX 1010 tablets and my old DELL PC, SAMSUNG laptop, so my initial reaction is to give MSFT the thumbs up.
      Hope everyone else has good experiences too!
    • jcollison
      By jcollison
      WARNING - I updated my Windows 10 box to 1709 FCU tonight and it would only recognize one of the two Nvidia GTX 1060s that I had in the box. I have not done any troubleshooting, but when I rolled it back, it worked again. There could be issues with this update.
    • Joe_Miner
      By Joe_Miner
      Unbox ML110 Gen10 at RESET Meetup
      This is a video of the unboxing of the HPE ProLiant ML1100 Gen10 at the RESET Meetup #Indy2017 on September 30, 2017.  More to follow in the Forums in the future.

    • Joe_Miner
      By Joe_Miner
      Unboxing the HPE ProLiant ML350 Gen10 at #BestMeetUpEver
      This is a video of the unboxing of the HPE ProLiant ML350 Gen10 at the RESET Meetup #Indy2017 on September 30, 2017.  More to follow in the Forums in the future.