Jump to content
RESET Forums (homeservershow.com)

Surface Pro 3 Sleep/wake Issues...nearly Suicidal.. Help, Please...


PanzerMan
 Share

Recommended Posts

Hi everyone, ok joking about the suicidal part, but damn near ready to rip out my hair over this nagging issue..

 

So, I've installed Windows 10 a month or so ago, things have been overall pretty smooth except for one nagging issue...

For whatever reason, when I attempt to wake my SP3, nothing will happen. Press power button again, nothing happens. Press and hold power button. Nothing happens. Press and hold longer. Nothing happens. Plug charger in, wait a second, press power button few more times, FINALLY "Surface" logo appears, and it's starting to boot up now. Even though I've put it on SLEEP prior, it's still restarting. 

Now, that's not to say that it doesn't come awake from sleep as it should most of the time; but this issue is occurring enough to make it an extreme annoyance.

I am well aware of the sP3's 'low-power' state that's enabled after 4 hours of sleep, but this has ocurred well within the 4 hours. I do have hibernation enabled on my Sp3, but after pressing power button once it should bring it out of hibernation. I have not messed with the Hyper-V settings, so whatever the Sp3 comes with default, that's what I have it set on. I also wake up to phantom battery drains, extremely hot back panel, unintentional wakes, and other fun things. The power settings have been an issue for me since day 1.

I wish it would just function like my iPad. Unless I press that frickin' button, it will STAY ON STANDBY and wake upon demand, and stay sleeping throughout the night, etc... Oh how I wish...

Any ideas how to fix this problem? Thank you.

Link to comment
Share on other sites

well considering win 10 is new there is bound to be bugs. I see a lot of people clean installing win 10 after the upgrade have you tried that? I have win 10 on surface 3 and the only bug Im experiencing is restarting the surface with the keyboard attached then removing it before bootup sometimes causes the onboard keyboard not to appear so I have to re-attach the keyboard to log in

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...