Jump to content
RESET Forums (homeservershow.com)

Upgrade Venue 11 I5 From 8.1 Pro To 10 Pro


jsox
 Share

Recommended Posts

The purpose for this post is to share my personal experience with upgrading a Dell Venue 11 Pro i5 (model 7130) from Windows 8.1 Pro to Windows 10 Pro and then experimenting with Reset and Clean install. I am not trying to say this is the only way to do it, or the right way, just sharing what I got to work for me. In particular I suspect I really did something inefficient around the whole UEFI / legacy boot process from USB but I didn’t figure out what.

 

Dell site lists this device as upgradable to Windows 10.

I started with a stock 7130, reset it to factory image, then applied all available Windows and Dell updates (including BIOS to A16).

I used my Microsoft Account throughout except the one time there was no network connection.

Removed Dell’s encryption from the HDD (important).

Made a Windows 10 reservation and let the upgrade install without interference, including express settings.

Everything worked. The layout of icons on my desktop was even the same.

Checked Windows activation with [C:\slmgr /xpr] to confirm Windows 10 “permanently activated”

Updated things via Dell System Detect and available Windows updates

 

The upgrade added a new Recovery partition of 450 MB by shrinking drive space. It appeared that the original Windows 8 Recovery partition was left intact.

 

I created a Recovery USB following the Windows 10 process and selected “move Recovery content to USB” option.

The Recovery USB does not boot the 7130, perhaps I did something wrong? Heck with it, forge ahead…

  • Note: hold volume up during boot to enter BIOS or select a one-time boot

Complete Windows 10 Reset, nothing significant appeared to change on the hard drive

 

Use Windows Media Creator to create a Windows 10 Pro x64 install USB

  • Disable UEFI boot in BIOS
  • Enable Legacy ROMs in BIOS
  • Boot “legacy”

Followed build advice from these sites:

·         http://www.dell.com/support/article/us/en/19/SLN292679/EN

·         http://www.tenforums.com/tutorials/1950-windows-10-clean-install.html

 

Skip product key page

Deleted all existing partitions from inside Setup

Error on trying to install on empty SSD, “we couldn't create a new partition or locate an existing one. See the setup log files”

  • One post suggested the USB might be bad, so I built another on a different USB stick with no change in behavior\

Try booting UEFI (instead of Legacy) 

  • This appeared to allow instillation to proceed
  • On final reboot error message “Invalid partition table”
  • Remove USB, Restart into BIOS setup
  • Change Boot List option to UEFI
  • Disable Legacy Option ROMs
  • Secure boot enabled
  • Restart (no USB) gets to Windows

Device setup proceeded

Use Express Settings

Clicked “later” on the product key screen

No network connections

  • Create local account

Settings … Disk management showed

  • 450MB Recovery Partition
  • 100MB EFI System Partition
  • 118.69 GB NTFS Bitlocker Encrypted (C:)

 

Fair number of issues in Device Manager, off to support.dell.com and Windows 10 OS drivers for this device

  • Install WIFI-7130_Network_Driver_0JJ8H_WN32_3.7.2.59_A00.EXE, Restart
  • Wi-Fi now works, connect to home network

Dell System Detect using this device’s Service Tag

Can’t do Dell System Detect automatic driver detection from inside Edge, must use IE11

  • Install Intel Video driver Video_Driver_7W9YT_WN32_10.18.15.4240_A00.EXE
  • Setup says current versions are newer? Install the Dell package anyway…

Install Intel Display Audio 6.16.00.3177

Install Intel HD Graphics Family 10.18.15.4240

Restart to BIOS, disable Intel SpeedStep to have processor run full speed for now

  • Note: seems much faster but really suck down the battery, faster than the batteries will recharge at 0.45A

Dell System Detect indicated no missing drivers

Check Windows activation

  • C:\slmgr /xpr yields Windows is “permanently activated”

 

Create recovery drive (USB)

  • Settings > “recovery drive” > create
  • Still can't boot to it

Restart to BIOS, turn Intel SpeedStep back on

Device Manager (Settings > “device manager”) shows one problem  item “SM Bus Controller”

What to do about the lack of a "real" recovery partition?

  • Some articles say you don’t really need one? Not sure what this means...

Cursory test and everything seems to work

 

Full Windows 10 Reset of tablet

  • Remove files (no to disk cleaning)
  • Reset TPM
  • 28 minutes to “Installing Windows”
  • 53 minutes, the screen has been without display for a while…
  • 58 minutes, Restarted?
  • 72 minutes, hold power button down until it shuts down
  • Restart… completes startup in another 5 minutes or so
  • Provide wireless password, “Getting critical updates”
  • Sign in with Microsoft Account, create PIN
  • No Device Manager issues

Dell System Detect (via IE11): No driver updates required and everything seems to work

  • No visible changes to disk partition layout

The next test I intend to do (I will update this post) is a repeat of Full Reset but with "Remove files and clean drive" included. I want to see if all the drivers are still there after it is done.

 

 

 

       

 

 

 

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

Full Reset of tablet

  • Remove everything
  • Remove files and clean the drive
  • 24 minutes: Volume up to clear TPM
  • 27 minutes: Installing Windows
  • 31 minutes: Select US / time zone, enter Wi-Fi password
  • 33 minutes: sign in with Microsoft Account
  • 35 minutes: desktop available
  • [C:\slmgr /xpr] “the machine is permanently activated”
  • No change to partition structure

So somehow it recovers even with "clean the drive" selected.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Rodf
      By Rodf
      Last weekend I set up a new Windows 10 Professional box. I took my old Windows 10 Professional box, put it onto another desk, and got it going without a monitor, keyboard, or mouse. It seems to be working fine, with one problem. It tends to shut down soon after no one using it. That surprises me, I thought it would stay up and running, whether anyone was using it or accessing it. (I've got a SQL Server 2019 Developer Edition database on that machine, which I want to have access to from any other machine in my home network.)
       
      So, why is it shutting down so quickly? Or is that some sort of hibernation or sleep mode that I'm unfamiliar with?
    • Rodf
      By Rodf
      I've got a new desktop, which I'm going to use to replace an old Windows 10 desktop. Both are running Windows 10 Professional. At this point I don't have a spare monitor, keyboard, or mouse. On the weekend it's not a problem, because I can disconnect my work laptop, to which I've got a second monitor attached to the docking station, and the mouse and keyboard are also attached to the docking station. That's fine, on the weekends.
       
      But how about during the week, when I must have the work laptop docked to the docking station, and the mouse, keyboard and second monitor also connected to the keyboard? So, I'm wondering, can I leave the old desktop running, connected by Wi-Fi to my router, but with no mouse, keyboard, or monitor? Or must it have at least a mouse and keyboard connected to it?
    • JackoUK
      By JackoUK
      I have become somewhat lazy (using the in-place rather than the clean-build route) and bullish (reckless?) so made changes to all my machines this morning.
      In general everything went slowly and smoothly ...
       
      - DELL 7920 Windows Pro for Workstations
      - HP Microserver N36 W Pro
      - HP Microserver N54 W Pro
      - 2x HP Microserver Gen8 W Pro
      - LINX 1010 Leather Tablet W Home
      - LINX 1010 Tablet W Pro
      - CHUWI Hi13 Tablet W Home
       
      … the only exceptions being 2 x LINX 1010Education tablets which run W Pro: here I received error 0xa0000400 after a message saying I was compatible and good to go.
      Something to look at later … or wait for my turn.
       
      So far the usual annoyances such as changes to windows positioning in Explorer and Edge but nothing substantial.
      I also find it necessary to switch Network Discovery off and back on to make sure the shared file systems are visible in Explorer/Network.
       
      Couple of nice, if small, things I’ve noticed already:
      -          GPU temperature and disk type (SSD, SD, HDD) in Task Manager/Performance
      -          In Security Settings one can dismiss warnings that there are no MSA accounts for Onedrive, giving a green tick in the notification area
      Still no CPU performance graph for the Gen8 – maybe that’s my fault for not being at the latest BIOS level?
       
      While I am critical of MSFT on other counts, I think W10 is one of the best things the company has done. Over the last month I’ve upgraded two old (7 and 9 years) laptops from W7 to W10 (still FOC producing a genuine activated licenses) and am pleasantly surprised how good the driver detection and provision is.
       
      HAND (have a nice download)
    • ZZzzGeorge
      By ZZzzGeorge
      I have a HP MicroServer N40L:
       
      Windows 7 in 120G SSD as boot drive;
      TWO identical 4TB disks with hardware RAID 1 set up;
      Only ONE 4TB disk can be seen in Windows 7.
       
      It's been working perfectly for almost 8 yrs.
       
      Recently i upgraded to Windows 10 and then strange things happened:
      1. Two 4TB disks cannot be recoganised in Win10, i have to treat them like a new disk, to re-format them, which is strange, but it's ok luckily i backed up everything;
       

       
      2. After re-formated them and RAID 1 set up again, TWO 4TB disks appears in Windows 10. Isn't one supposed to be hidden?!
       
      It seems like N40L Raid 1 is not working on Windows 10? Do I need a new raid driver? but i couldn't find one.
       
      Is anyone using N40L with Win10 and hardware Raid 1? Please help!
      Thanks
    • Rodf
      By Rodf
      I've had the attached appear on two of my Windows 10 machines today. The picture I captured from my laptop, which I've had for two years. What does this mean?

×
×
  • Create New...