Jump to content
RESET Forums (homeservershow.com)

Self-Inflicted Bricking Of Surface Pro 2...


Recommended Posts

I bricked my Surface Pro 2 all by myself.  I have tried various techniques from the Microsoft site.  Basically, I get to a point where either my system drive is locked or I am asked for drivers so the machine will recognize drives. If I don't use a USB drive to boot, the machine goes to the UEFI screen.   Any ideas or help available? - Steve

Link to comment
Share on other sites

Maybe someone else can chime in on this to give you some more detail, by i believe Microsoft released a tool, or an image for a bootable flash drive that is a full recovery for each of the Surface products. If I am wrong, please let me know.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • TwoWheels
      By TwoWheels
      I'll try to give a l the pertainent details.
      I have a Lenovo Flex 4 1580 that came with a 512GB Liteon SSD. That drive failed, and I'm trying to replace it with a 1TB Sandisk SSD.
      I used network PE boot to launch the restore, and then used ctrl-alt-shift to run diskpart. In diskpart, I created the two partitions on the existing drive, a 1GB WINRE_DRV partition and the remainder of the disk (I think) as a primary NTFS partition (which came out to 930GB approx).
      After restoring 100% (0% remaining, more precisely), it timed out and gave this error:
      [08/19/2019 00:33:04 664] RestoreHelper::FixBootBlock: fixing boot block [08/19/2019 00:33:04 664] RestoreHelper::ExtendVolume: extending the volume [08/19/2019 00:33:27 664] Restoring ESP [08/19/2019 00:33:27 664] existing offset: 0x0, size: 0x4400 [08/19/2019 00:33:27 664] existing offset: 0x4400, size: 0xfbc00 [08/19/2019 00:33:27 664] existing offset: 0x100000, size: 0x6400000 [08/19/2019 00:33:27 664] existing offset: 0x6500000, size: 0x8000000 [08/19/2019 00:33:27 664] existing offset: 0xe500000, size: 0xe891900000 [08/19/2019 00:33:27 664] Found existing volume [08/19/2019 00:33:27 664] existing offset: 0xe89fe00000, size: 0x41000000 [08/19/2019 00:33:27 664] existing offset: 0xe8e0e00000, size: 0x1fbe00 [08/19/2019 00:33:27 664] FormatPartitionEsp called for disk \\?\PhysicalDrive0 [08/19/2019 00:33:27 664] Formatting ESP partition at offset 0x8100000 [08/19/2019 00:33:27 664] ERROR: FormatPartitionEx failed, error 0x80042405 [08/19/2019 00:33:27 664] ERROR: FormatPartitionEsp failed, error 0x80042405 [08/19/2019 00:33:27 664] RestoreHelper::T_Restore: failed to restore ESP, error 0x80042405 [08/19/2019 00:33:27 664] RestoreHelper::T_Restore: restore complete with return value 536870914 [08/19/2019 00:33:27 664] ERROR: CDialog_Restore::Completed failed, HR=0x80070002 (at func: CDialog_Restore::Completed, admin\serveressentials\backup\pc\bmr\restorewizard\dialog_restore.cpp (97) I tried the instructions in Client BMR failed for UEFI machine in advanced mode , but the calculation in powershell yielded a non-integer, negative number of -2048.74120616913. 
      Based on the article, I'm assuming that instead of padding, I need to reduce the size of SOMETHING by 2GB, but I'm not clear how to do that so it lands on precisely the same address, particularly because of my fractional results from the powershell calculation.
      Is there a way to determine the EXACT sizes for the WINRE_DRV, Windows, EFI, and MSR partitions from the backup itself. It seems odd that it handles what should be a straightforward restore so poorly (and manually). the Restore UI provides "human readable" sizes, but what is really needed are exact sizes in MB blocks, apparently.
      Thanks for your assistance. This was my primary client machine and I really need it back!
    • Calby
      By Calby
      Here is some new drivers and Firmwares that I have find that are newer then the once that was on the SPP.
      The new drivers are
      Ethernet Firmware (Only Windows) (EXE-file) Ethernet Driver (Only Windows) (EXE-file) Graphifc Drivers (Only Windows) (EXE-file)  
      The link also inkludes
      Intelligent Provisioning 1.70.63 (All OS) (ISO-File)  
      Install instruktions
      If you 'll download and install the Firmware and driver for the Ethernetcard, make sure that you install the Firmware and reboot the server before you update the drivers.
      The Intelligent Provisioning update is a bootable ISO-file.
      So just mount the file in your iLO remote console and then choose to boot the server from the DVD (mounted ISO-file) then follow the instructions.
      Download link
      Download instruktions
      You can if you want donwload each file by it self or you can download all of the files in one zip-file.
      If you want to download the files in a zip-file just click on the Green link that says "ZIP" at the right on the download site and the server will zip the files for you and start a download for you.
      Every file is named like this HPesOwnPacketName_Version_FW/driver.exe everything so you can see the info about the files.
      I'll continue to upload the newest drivers and firmwares for our beloved HPe Microsoerver gen8.
    • tinkererguy
      By tinkererguy
      Once in a while, I write something, not expecting much. Months later, I realize the article's popularity continues to grow. Here's just such a piece, from back in Sep 2013 called:
      Rufus takes 5 minutes to create a UEFI bootable USB 3.0 flash drive for Windows 8.1 installation
      Visitor davepermen was reading an article about using Rufus to create a bootable ESXi USB drive, for installation to itself. He apparently also owns a Surface Pro, decided to give Rufus a go, and found success, then typed up this comment.
      Free software, no adware, no catch. Just a simple and effective and fast utility I thought I'd share. Especiallyl given there seems to be less and less of it for Windows these days.
    • pantoast
      By pantoast
      TL;DR Using Genius Pensketch 9x12 with Surface seems to cause driver conflict with Photoshop CS6.  It appears that only the Surface itself or the Genius tablet can have pressure sensitivity in Photoshop, not both.  Wondering if anyone has encountered a similar issue and if it can be fixed.
      My wife is a professional illustrator and we recently bought a used Surface Pro 2 from a co-worker of mine.  The thought was to make the Surface her primary desktop, with the added benefit of portability.  We bought her a USB3 docking station and overall everything worked great.  That is until last weekend we went away and she wanted to sketch in Photoshop (CS6) while on the go.  We had done this successfully before setting it up as her primary workstation, so we assumed there would be no issue now.  When she tried to sketch there was no pressure sensitivity in Photoshop, but it works in other apps like Fresh Paint.
      She has a drawing tablet she uses day to day, the Genius Pensketch 9x12.  You have to install new drivers for it when you first use it in order to get pressure sensitivity to work for it in Photoshop.  Uninstalling the drivers for that tablet appears to fix the issue with the Surface's digitizer, but that's not ideal as she uses the Pensketch every day for work.  It's also not ideal to lose pressure sensitivity when using the Surface itself in Photoshop, as that was the whole point of buying one in the first place.
      Anyone experience something similiar to this?  Sorry for the long winded post, thanks.
    • dvn
      By dvn
      New i7-2600K system - ASRock Z68 PRO3 board, Mushkin 2 x 4GB, Crucial C300 RealSSD...
      When I first put this system together, I just dropped in the SSD with the OS from my old system and after it detected and installed the new hardware, I was up and running. But a weird video thing caught my attention. The HDMI video feeding my main screen would go to white, flashing from almost black to some kind of white mess.
      Ok, maybe I'll just monitor (pun intended) the situation and see how it goes since it only did this a couple times, right?
      But then I ran into a file transfer problem between my desktop and WHS 2011. I was trying to transfer a 40GB folder with a DriveImage XML backup image of a recently repaired computer to my server where I keep the rest of these file types. The copy function got hung up on 'Discovering files' to be transferred. It'd just hang. So I'd kill it in Task Manager and that would crash Windows explorer.exe every time. Not a very reassuring feeling about my new system. I had thought to made sure the driver was updated via Windows update. Yes, I can hear you now. But unfortunately I didn't think to get drivers from the manufacturer's site right away, so... I had a Intel NIC sitting in a box nearby. I stuck it in and the problem disappears. Files now transfer, speeds look good. So I figure something's wrong with the ASRock board.
      Between flashing video and the onboard NIC snafu, I figure I'm looking at an RMA. But then, finally, it dawns on me to check the manufacturer's site and yes, there is a newer version. So I dl and install it. What do you know? Problem solved. Geez! Where's pcdoc when I needed him? Oh, I can hear him now, "...always check the manufacturer's site for the latest drivers." Got it.
      So to continue this Murphy's Law kind of day, I misplaced (deleted) an important file. The file in question was my FF json, the bookmarks backup with all my customized keywords, those short 2- and 3-letter shortcuts I use in the address bar to quickly navigate. Somehow or other, I had accidently deleted it from Dropbox. Great... Except, this episode turned out well, too, as I discovered (thankfully) that Dropbox lets you recover deleted files.
      So that's how I spent my day off, locked up in an arm wrestling contest with my technology. Someone tell me why I love this stuff?
      I suppose this means I should look on the manufacturer's site for video drivers, eh?
  • Create New...