Jump to content
RESET Forums (homeservershow.com)

Dell Venue 8 Pro Not Charging


roberthleeii
 Share

Recommended Posts

I have had a Dell Venue 8 Pro for about a year and a half now but it has stopped charging. It is just an interesting looking Dell branded paper weight now. I have tried to plug it in to multiple different chargers but nothing seems to make a connection and charge it. Does anyone have any ideas on a way to get it working or am I just out of luck?

 

Thanks in advance,

 

Robert

Link to comment
Share on other sites

I would suspect the port on the tablet is worn, I had a htc phone that was very particular and would not charge if the plug was loose at all. Maybe contact dell and see what you can have done? then decide if it's worth your time and effort to have it fixed. Myself, I would take the tablet apart and attempt to fix the charging port but that's just me. I look at tablets as a 2 maybe 3 year device

Link to comment
Share on other sites

I would suspect the port on the tablet is worn, I had a htc phone that was very particular and would not charge if the plug was loose at all. Maybe contact dell and see what you can have done? then decide if it's worth your time and effort to have it fixed. Myself, I would take the tablet apart and attempt to fix the charging port but that's just me. I look at tablets as a 2 maybe 3 year device

 

Thanks for the replay. How would i go about taking it apart? I have never done that to a tablet before. If i need to pay to repair it i will just buy a new HP Stream 7 or 8 , so it is fix it myself or buy a new one eventually. 

Link to comment
Share on other sites

https://youtu.be/N6AMRy4di0s

Thanks for the replay. How would i go about taking it apart? I have never done that to a tablet before. If i need to pay to repair it i will just buy a new HP Stream 7 or 8 , so it is fix it myself or buy a new one eventually.

https://youtu.be/N6AMRy4di0s

 

also it could be your battery

Edited by callihan44
Link to comment
Share on other sites

  • 1 year later...

Hold down the power button (with charger disconnected) for 4 minutes. Plugged it back in, wait for few minutes and booted it up. May be there is a defect in a charging port that's why this issue happen. You can also do other hit and try troubleshooting methods from Dell Venue 8 Pro Manual to resolve your issue. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...