Jump to content
RESET Forums (homeservershow.com)
smitty403

Surface 2 Internet Explorer Issues

Recommended Posts

smitty403

I am new to the forum I just bought the surface 2 on Sunday. I bout the device for my wife to use for school since the ipad lacked some features for productivity. The first time she tried to access one of her online classes thru the webstudy website,  I got a message stateing that I needed to update internet explorer or use firefox or safari. She has no issue accessing the site from our Ipad or computer. When I click continue without updating nothing happens. I do not have a option to update explorer when I try to access the site the only button I have is to continue. . I tried to download firefox with no success. Can anyone walk me thru what I need to do? I can access other sites like the school website and CNN.

Share this post


Link to post
Share on other sites
ShaunKL

Have you tried using the desktop version of IE?

Firefox and Chrome will not work on a Surface 2 as it is using the Windows RT operating system.

Share this post


Link to post
Share on other sites
FinsUpDNC

Agree with above.  Click on the "desktop" tile on your start screen, and then open Internet Explorer on the desktop.  I have found many websites work better in that environment. 

Share this post


Link to post
Share on other sites
smitty403

I tried accessing the site from the internet explorer from the desktop and the message that I get is " warning: the browser you are using is not supported. This site uses technologies (I.e. JavaScript, cookies and java) that may not be supported in the browser. You need to use a supported browser to enter. However it is highly recommended that you use the latest version of one of the following:

 

Internet explorer

Firefox

Safari

 

Then when I click on internet explorer it says that I have the latest version

 

Any help would be appreciated

Share this post


Link to post
Share on other sites
WolfJT

On the desktop portion of IE click on the gear icon (upper right hand side) and select compatibility view settings. Add the website you are trying to access to the compatibility view list. Also, go to Internet options and on the security tab un-enable "enable Protected mode". Then go to the advanced tab and un check Use software rendering instead of GPU. Try that let us know what happens.

Share this post


Link to post
Share on other sites
pfinter

Surface 2 is a windows RT device. As such, you will not be able to access websites that use browser plugins, such as Java. This was a design decision as to the inherent issues with plugins. Java has had a huge number of issues with security and Oracle has not been doing a great job in handling this issue technically and with the media.

 

I'm sorry if you need to use a website that requires the use of Java. But, the Surface 2 won't do it. My suggestion, if you are liking Windows 8.1 on a tablet, look at getting a tablet that runs a full version of Windows 8.1.  There are many options and many price ranges. Some of these tablets run using HP's Atom processor. These will cost similar to a Surface 2 and will have similar battery life and performance. Also, they will allow you to use Brower plugins (like java). You could also move up to a Surface Pro 2 which is essentially a full powered Core I5 processor ultra book like laptop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...