Jump to content
RESET Forums (homeservershow.com)

Typecover Sometimes Goes Unresponsive On My Surface Pro


RMansfield
 Share

Recommended Posts

Ok, I've only had the Surface Pro about three days, so it's difficult to figure out a definitive cause for this, but sometimes my TypeCover will stop working. I -think- it's when I've gone back and forth between the touchscreen keyboard and the TypeCover keyboard. I can fix the problem by detaching the TypeCover and then reconnecting it, but I don't remember ever having to do this on my Surface RT. 

 

Is this just me or do other folks have the same problem? If it's just me, I'm going to take back the TypeCover and exchange it.

Link to comment
Share on other sites

I virtually never use the on-screen keyboard so I've not had this issue.

But do you "physically" use it?

Link to comment
Share on other sites

FWIW, I've never had this problem.  I do use the onscreen keyboard from time to time (with the type keyboard folded back),  but this has never happened to me that I can recall.  Try replacing it, and see if that helps.

Link to comment
Share on other sites

It happened to me last night... I may have switched between the two.  It's only happened once, so I didn't look for a pattern.  The onscreen keyboard was unresponsive too (I could touch keys, but there were no resulting characters).

 

I rebooted and that resolved the problem.

Link to comment
Share on other sites

I've been able to solve it every time just by unattaching and reattaching the keyboard. It rarely happens to me, but it stood out because the keyboard didn't work the first time I attached it to the SP. However, that time, I attached it and then folded it back. When I pulled it back around to type on it, the keyboard had no response.

 

I would say it happens less than once a day, but it still happens now and then. But I often go back and forth between keyboard and screen, and it just may be an issue. I doubt I could go into a store and repeat the problem on cue, so I think it will just be one of those things to live with for right now.

Link to comment
Share on other sites

I've been able to solve it every time just by unattaching and reattaching the keyboard. It rarely happens to me, but it stood out because the keyboard didn't work the first time I attached it to the SP. However, that time, I attached it and then folded it back. When I pulled it back around to type on it, the keyboard had no response.

 

I would say it happens less than once a day, but it still happens now and then. But I often go back and forth between keyboard and screen, and it just may be an issue. I doubt I could go into a store and repeat the problem on cue, so I think it will just be one of those things to live with for right now.

I have a similar experience but only one every couple weeks maybe. But I don't use mine very often.

Link to comment
Share on other sites

Probably happens once or twice daily. Reconnecting it work for me. It used to happen a lot more consistently after waking it, but a firmware update resolved this, mostly.

Link to comment
Share on other sites

I seldom see this issue with the type cover. But like everyone else, I just disconnect and reconnect the keyboard. no problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...