Jump to content
RESET Forums (homeservershow.com)

Use Surface To Charge Your Phone


Recommended Posts

I guess there is no reason why this would not have worked, but I can confirm that the Surface RT USB port can charge a cell phone (Lumia 900) while running on battery. Nice when you need it.


I suppose it could charge/power any USB device.

Link to comment
Share on other sites

Yeah I came across this while testing out if my Surface would connect to my Lumia 900. Short answer is, No it won't. But like Indy said, I does charge it so that is good.

Link to comment
Share on other sites

  • 1 year later...

I tried plugging my Nokia Lumia 900 into the USB port of my Surface RT, but it only charges it for a few seconds then stops. What is causing this and is there any way to prevent/ fix it?

Link to comment
Share on other sites

You may want to try another USB cable. I can confirm both my Surface RT and Surface 2 will charge pretty much any cell phone or accessory I plug into the port.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • MarkFlagman
      By MarkFlagman
      Hi, everyone!
      Hoping someone can help me out with this one!
      I have a simple RDS setup of 2 servers. One is the connection broker/gateway etc (RDS001), and the other is the session host (RDS002). These are both Server 2012 R2, in the same OU, with the same GPO's applied.
      I am using HP T510 clients (running ThinPro 5.2), with an RDP connection to the farm address (rds.domain.local). The connection is working fine, however usb devices (ie memory stick) will not redirect to the session host. All the redirection options in the collection properties are ticked. Audio redirects to the client with no problem. 
      I have also tried connecting directly to the session host (RDS002) with no difference. 
      I believe the redirect settings on the T510 to be correct, as if i set up another rdp connection from the client to another server or even the connection broker (RDS001) , the usb device i have plugged to the client redirects fine. 
      So, it seems as though it is only the session host (which is where i actually want to redirect a device to..lol) having this problem. 
      However, if i connect to the session host from a windows 10 pc, everything redirects as expected - just not from the t510!
      Any help appreciated!
    • Al_Borges
      By Al_Borges
      For sale , Microsoft Surface 3 tablet , 4 gigs memory, 128 gig storage
      good  used condition
      Urban Armor Gear scout case for surface 3
      Blue type cover for surface 3
      Surface 3 pen
      and charger/cable
      Asking $200 Plus actual shipping from Central Indiana, USA 
      I love the tablet, but had to get an Ipad so I could facetime with my granddaughter !
    • Al_Borges
      By Al_Borges
      Been on Project Fi for almost 2 years  --   really like the service and price.   
      Coverage all across the country has been excellent.  Even my occasional trips into Canada
      What I like about it most is the low cost consistent pricing -  I just don't worry about my cell coverage , regardless of where I am 
      Been Trying to get my daughter on my project Fi "family plan"  the holdup has been the availability of lower cost phones
      They discontinued the medium cost   LG Nexus 5X phone and the only phones available have been the  $700 plus  Pixel phones
      Well, last month they announced the "Moto X4 Android One"  phone available  on Project FI and I just got it the past week.
      The 32 gig model was $400 bucks -  about the same price as the LG Nexus 5x at launch.    
      ( I really missed the boat when I didn't pick up extra 5X's  when google was selling them for 199 bucks!!!)
      anyway -   there are several project Fi  users on the this forum and I thought I'd pass along my impressions
      Solid Phone -    About the same size and feature set of the phone it replaces ( Nexus 5x)    
      Plus's   -   
      Gorgeous  OLED Screen
      Micro SD Capable -   can use high speed cards as system memory or portable storage
      Dual Camera lenses -    both a standard and a "wide" angle lens are built in. 
      3 gig of memory -    runs fast and smooth.
      Front mounted Fingerprint Sensor.     I really liked the rear mounted finger print sensor on my 5X.    However after a couple of days use, I have gotten used to having the sensor on the front, but still believe that the rear mounted sensor is preferable
      Slick, slippery  -   the slightly curved, metallic body  falls out of  your hand or pocket effortlessly.     I won't be using this with a protective, rubbery case.  First phone I've ever considered getting a "protection plan" for.      I know I will drop it   
      Lack of accessories -    You shouldn't expect the same ecosystem as the Iphone or Samsung phones -   but at least the Nexus line had some support.     Google doesn't even offer a case for it on its store.     A handful of 3rd party  accessories are available on Amazon.
      Anyway,  if you where considering Project Fi, but didnt want to spend  $700-$800 bucks or more on a phone -   you now have something to consider. 
    • Moreplavec
      By Moreplavec
      I have new Gen8 and installed SSD do 5th bay, trying to boot via USB Grub. But i can't get it to work. I switched in BIOS to USB boot and tried to install Ubuntu server 16 + /boot set to USB drive, partition created on USB (ext3). Not working.
      So i deleted all and tried to install Proxmox to SSD, without problem. Then i used tutorial to create USB bootable https://jarrodla.blogspot.cz/2014/04/hp-microserver-gen8-boot-from-5th-sata.html but again, no luck. I tried to create another three USB flash drives, still not booting, USB is skipped to next medium.
      Please, can you help me what's crucial to USB to be working as GRUB loader to boot from SSD? Thanks!

    • EON1488993291
      By EON1488993291
      I have a Surface RT (32 GB) and it only has 1.69 GB of space left on the HD. The thing is that I have almost nothing on it (just a few apps that I check and do NOT take a lot of space, and small files), so I don't know what is taking so much space. Does anyone knows where is all that memory going? I have not being able to find it (I have checked the size of the apps, delete the trash can, delete the internet history/cookies)...
      Also, I want to upgrade to Windows 8.1. These are the two ways that I have think of doing it, but I will like your opinion on which option is better (or if there is a better way):
      Plan 1: take the tablet to its original status (in PC settings > General > Remove everything and reinstall Windows), move the recovery files to a thumb drive (http://www.surfacegeeks.net/forums/index.php?/topic/192-surface-rt-how-to-free-up-4-gigabytes-of-storage-space-on-your-rt/), and do all updates to take it to Windows 8.1
      Plan 2: free some space by moving the recovery files to a thumb drive, make the upgrade to Windows 8.1, run a cleanup disk and defragment the drive
      Making a backup of the files in the tablet is easy b/c there is not much in it, but my main concerns for the process are: I am going to loose microsoft office? is it going to ask me for any key/license number (if I ever had one, I don't know where it is)? anything else that I am missing?
  • Create New...