Jump to content
RESET Forums (homeservershow.com)

Bought a new HPE Gen8 – Now I want SAS...


Ugly-051
 Share

Recommended Posts

Its officially supported

 

Make a dos boot disk and extract this to it

https://drive.google.com/file/d/0B8-hfA9ycQNob1VPTkZ3cHVvQXc/view?usp=sharing

 

boot from it

cd p20

9217.bat to flash 9217 firmware

9207.bat to flash 9207 firmware

 

the rar has the best version for the microserver gen8

20.00.07.00 FIrmware

7.39.00.00 MPTSAS2 (7.39.02.00 Causes an NMI on the Gen8)

7.27.01.01 UEFI

 

Make sure you dont flash (not included in the rar i posted btw)

7.39.02.00 MPTSAS2 on 9207 if you enter the sas bios the gen8 will nmi

7.39.02.00 MPTSAS2 on 9217 the gen8 will nmi on powerup without entering the sas bios and will have to be flashed from another pc

 

also read this if you want spindown enabled in windows

http://homeservershow.com/forums/index.php?/topic/11859-lsi-spindown-win-81win-10win-2016/

 

the Windows 10 inbox driver 2.0.79.80 is great dont bother with drivers from lsi they are older

 

latest MegaRAID Storage Manager 16.11.00.03 (if you want it)

https://docs.broadcom.com/docs/16.11.00.03_MSM_Windows.zip

 

Do still have the download available in your first link? It's broken now. I’ve installed the MegaRAID client but I don’t think the server is available for BSD.

Link to comment
Share on other sites

look 5 posts up

 

Do still have the download available in your first link? It's broken now. I’ve installed the MegaRAID client but I don’t think the server is available for BSD.

Edited by Shonk
Link to comment
Share on other sites

  • 1 year later...

@Shonk - Can you upload again the files from your post because the link is not valid anymore.

 

Btw: Is it possible to flash the HP LSI 9217-4i4e to IT mode ?

Link to comment
Share on other sites

  • 10 months later...
On 3/11/2017 at 6:22 AM, Shonk said:

Here's the P18 IR + IT firmware for anyone who picked one up and wants raid

 

It turns out they came from intel 1u socket 2011 servers

I have asked him the exact model with a bit of luck i will be able to sniff down some P20 firmware at some point

.

.

.

 

https://drive.google.com/file/d/0B8-hfA9ycQNoUU1DV2tIN1BJcnM/view?usp=sharing

 

 

 

 

Hey Shonk

 

Do you still have a copy of this 9207-4i4e P18 IR + IT firmware? I've just run into the reversed ports issue myself and would like to reflash, but unfortunately your link is dead.

 

Any chance you might be able to re-upload it, or send it my way?

 

Cheers,

J.M

Link to comment
Share on other sites

https://mega.nz/#!9jADwaaL!TmHFMBFw7ts74U5MdgyycEXxASVSKIjOlJBrGAw8JnU 

 

 

On 3/27/2018 at 10:10 AM, PPETKOV said:

@Shonk - Can you upload again the files from your post because the link is not valid anymore.

 

Btw: Is it possible to flash the HP LSI 9217-4i4e to IT mode ?

 

 

sorry i didnt see your post you should have pm'd me like J.M. did

Edited by Shonk
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

 

On 1/30/2019 at 11:22 AM, Shonk said:

read my post 5 here for more info on the port reverse

  

https://forums.servethehome.com/index.php?threads/hp-9217-4i4e-ports-swapped-around.12191/

 

Did you manage to correct the port numbers? I have a similar problem in a LSI SAS 9207-8i (I think it's a OEM part, but who knows) where the labels in my cables do not match the order that they are "scanned" by the OS. Just a minor nuisance, but it would be nice to have this fixed.

 

Also, you are the first person I found online that reported the nmi problem in the Gen8 :)

Link to comment
Share on other sites

  • 2 weeks later...
On 2/18/2019 at 2:55 PM, skandal said:

 

 

Did you manage to correct the port numbers? I have a similar problem in a LSI SAS 9207-8i (I think it's a OEM part, but who knows) where the labels in my cables do not match the order that they are "scanned" by the OS. Just a minor nuisance, but it would be nice to have this fixed.

 

Also, you are the first person I found online that reported the nmi problem in the Gen8 :)

 

only by using the factory p18 i didnt manage to edit a p20 image

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

 

@Shonk

 

Hoping you may be able to help!

 

I bought a 9217-4i4e card off ebay. It arrived and it seems it is a HP220.

 

I have installed it in my Gen8 microserver.

 

I had an issue initially whereby I updated the BIOS and ended up with a NMI error.

 

I fixed that by going back to 7.39.0.0 BIOS.

 

Flashed the IT firmware, but the card only detects 3 drives. Plugging the mini SAS back into the B120i shows all 4 drives again.

 

The LSI card shows drives on slot 4,5 & 6.

 

I'm kinda aware of the port swapping issue. Have I missed something or is the card faulty?

 

EDIT: I didn't do anything with the SBR - I'm not sure if I should have done?

 

Edited by psykix
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...