Jump to content
RESET Forums (homeservershow.com)

HP Smart Array P222 Controller - What's the biggest hard drive for this?


Recommended Posts

I was about to buy 4 x 8TB WD Red's (for my HP MicroServer Gen 8) when my friend asked me to double check if my HP Smart Array P222 Controller can actually support this...

Does anyone know the answer for me please?

 

 

Edited by phillai
Link to post
Share on other sites

I was about to buy 4 x 8TB WD Red's (for my HP MicroServer Gen 8) when my friend asked me to double check if my HP Smart Array P222 Controller can actually support this...

Does anyone know the answer for me please?

 

As long as you have the latest firmware update the answer is yes :)

Link to post
Share on other sites

Thanks for the fast reply!

One last thing, what version is the last firmware update and where can I get it from?

 

I'm running V6.68 on my P222 using 4 x 4TB WD Red internal, and 1 x 8TB WD Red in an external Sans Digital TR4X6G enclosure connected to the external P222 port.

 

As far as getting the firmware you'll need to try and find a copy of the iso for HP SPP 2016 which will update all the drivers in the system when the server is booted from it. Where you can get a copy of it I can't say, but do a google search if your HP warranty on your server has expired.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • Giuseppolino87
      By Giuseppolino87
      Hi everyone, today I wanted to install esxi 6.7 to try out the various functions, my question is the following, I have a server where I have installed esxi in an SSD and I have two other 4 tb disks so 8 tb total.  I would like to make sure that when I create a virtual machine in this case I will install the various virtual machines in the SSD and use the two disks for data.  So how can I do this?  Thank you very much for those who can help me.
    • E3000
      By E3000
      Looking for a quick answer here from someone in the know...
       
      I upgraded some of the internals of my Gen8 server and at the same time I did a BIOS reset as I had forgotten the password that I had set years ago. When booting back up the upgraded hardware was detected and fine but I received Error 1784 - Drive Array - Logical Drive Failure. I believe this is due to a setting change in the BIOS and not anything hardware related. I have gone into IP/SSA and see the array needs to be rebuilt. I had all drives configured as single RAID0. It says all data will be lost if I reconfigure this but I remember reading somewhere on here that the data will be fine if I reconfigure as RAID0.
       
      I do have a backup of course, but it’s not a high availability mirror and will take some time to get back the way I had it, so just want to know if it’s safe to reconfigure the RAID0 without erasing the drives. I have tried pulling the drives out and connecting them to another PC and they are fine. Can anyone tell me which options to choose to get these back to normal and remove the flashing red light?
       
      Thanks 😶
    • Mark Belanger
      By Mark Belanger
      Greetings,
       
      I'm new to the HPMSG8 world and so far I'm loving it. I have a stock Xeon with 16G of aftermarket memory with iLO patched to 2.70. Next up is adding a RAID card, so I can put my boot SSD on the onboard RAID. I picked up a LSI SAS9211-8i on Amazon, but am struggling to flash it to IT mode on the MicroServer. Is this even possible? Unfortunately, the only other system I have with PCI slots is 32-bit.
       
      Any pointers would be greatly appreciated.
       
       
      -MB
    • TakiBot
      By TakiBot
      I've got my hands on a HP N40L.
      Can i use raid 1+0 on my 4 2TB WD RED or only 1 and 0.
      Thanks for the help.
    • tswalker
      By tswalker
      So, it has been a very long time since I've been able to contribute to this community...  but I creep in every so often
       
      Some may know of this NAS that Western Digital offered back in 2012 called the DX4000.. flavors included storage up to 16TB and it ran Windows Server 2008 R2.  I made a few articles on my blog, showing how to convert it to use Windows Server 2012 R2 back then, and it had been running like a champ ever since, last month.  I decided to re-purpose it as a firewall, and began searching for alternatives to pfSense...  I naturally gravitated to OPNsense, and experimented with getting it to run on the metal.

      It may seem strange to want to do this with a device built to be a storage server, but I've outgrow the storage... and it actually had decent adapters on-board (2x Intel 82574L), the form factor was small, and included redundant power supply capabilities.

      To make it possible, there had been some advancements by the community on how to access the BIOS on the machine, found here on YT posted by Martin Meise.  A BIG "Thank You" to that guy for showing how to mod the PCB to include a serial converter.  I picked up a USB to TTL serial cable from Adafruit.com, soldered some extension wires to the PCB on the DX4000 (which currently stick out the side).. and had instant terminal bliss.  I can plug/un-plug the adapter when needed this way, just a note...  the RS on board will plug into the TX on the adapter, as does the TX onboard to the RS on the cable.. anyway.  works great.  (just a note, the PCB has what seemed like a polyurethane coating on the pads, and I had to dissolve/scrape it off to get the solder onto them)

      The only setting on the BIOS that needed to be changed was to switch the controller from RAID mode to AHCI.. which allows you to use independent storage without the needed RAID setup.

      I picked up one of those ICY DOCK 2.5" to 3.5" converters a while ago to use for this, and an in-expense Kingston 120GB SSD on Amazon for 20$USD.  It was a tight fit, but works great.

      The difficult part in this setup was to get FreeBSD installed on this thing...  I tried dozens of times using the OPNSense ISO and serial versions to get it going, and gave up after while defeated.  I also tried other FW flavors like pfSense, and Sophos.. all failed to use the serial terminal to complete installations.  I gave IPFire a shot and actually got it working accidently after modifying the serial console to use TTYS1 instead of TTYS0.. and a light in my head got turned on...  it had that I.D.10.T message.
       
      I went back and built a USB with OPNsense serial version image on it.. fired up a FreeBSD VM on my windows workstation.  note, the USB must be 'offline' in windows to use as an attached disk in hyper-v... just take it offline in disk manager, and add the usb as an iscsi disk in the vm settings.

       
      * startup FreeBSD in the VM, logon as root and mount the device.  For me this ended up being device /DEV/DA1A   (mount /dev/da1a /mnt/usb )
      * cd to /mnt/usb/boot , you can copy the loader.conf file to loader.conf.local or just VI a new file called "loader.conf.local"  (it is important to have a local file so your changes are not auto-overwritten)
      * include the following into loader.conf.local:
      hw.uart.console="io:0x2f8,br:115200" bitmap_load="NO" comconsole_port="0x2f8" comconsole_speed="115200" console="comconsole" boot_serial="YES" ** it is important to note that after installation is complete, you may NEED to do this again and add a loader.conf.local file to the system to access the things via ttyS1
       
      I was now able to use my usb to serial cable connected to my workstation to open PuTTy (mod the BIOS) and step through a serial installation of OPNsense...  it was defaulting to use ttyS0, instead of ttyS1 which is what is needed for this machine.
       
      The only things I have NOT been able to manage getting to work are the fan speed controls, and my BackUps powersupply over USB for monitoring power.. other than those, this little thing has been solid.
       
      So far, I've been able to get the LCD working great using LCDd... i get all the goodies i need being displayed... and I apologize that I have no pictures of my lovely PCB soldering nor of the LCD working.  I'll try to get some in the coming days, and post a new blog on my blugged.wordpress.com site.. but i've been super busy with a new software engineering position these past 9 months, and just don't get much free personal time anymore.
       

       
      I hope someone has enjoyed this quick write-up!
       
      -tswalker
       
×
×
  • Create New...