Jump to content
RESET Forums (homeservershow.com)

Getting VPN working ....


gremlin
 Share

Recommended Posts

Hi all - I've been through the TechNut videos to set up my Gen8 - all good until I try VPN.

 

I've got Server 2012 running off an SSD and have created virtual machines for a domain controller and file server.

 

When installing remote access and trying to add VPN I get the message in the attachment.

 

I've tried everything I can find online to disable ICS but can't stop this message appearing.

 

Can anyone help?

 

Capture.PNG

 

 

Link to comment
Share on other sites

as you have not listed what has not worked, you may get some suggestions about what you have already tried ;)

 

have you ensured that on all connections that the ICS is unchecked from the sharing tabs ?

Link to comment
Share on other sites

Good point - half a story - apologies.

 

I've tried:

 

unchecking ICS in the sharing tabs.

stopping and disabling the ICS serves in the services manager

disabling ICS related items in the group edit policies

 

I think that's it.

  • Like 1
Link to comment
Share on other sites

Taken from Technet - HERE

 

i cant see how the last part was affected but just have a read and see if anything matches.

 

A Microsoft Support Technician recommended the following registry key change, which finally forced the ability to configure RRAS NAT after the ICS fiasco:

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess

Look for a key called ConfigurationFlags

If it has a value of "0", replace, it with "1"

If the DWORD ConfigurationFlags doesn't exist, create it by making a new DWORD key calledConfigurationFlags and set the value to "1Decimal (without the quotes).

  • Also check if there are any "Incoming Connections" configured in Network Interfaces. If you see it, delete it.
  • Once the registry changes are done, please reboot server and then try to reconfigure the RRAS.

The key had a 0 value, so I replaced it with 1, which enabled RRAS NAT configuration.

Unfortunately, the process disabled the DHCP management tool, which I couldn't fix by removign and reinstalling DHCP. So I had to repave the server in the end.

Link to comment
Share on other sites

I'd missed that one from my list.

 

I did give that a go - once the registry setting is changed I can the configure remote access but not VPN specifically

Link to comment
Share on other sites

not sure then mate, possibly better if a mod moves this to the windows forum, you may get more visibility on it and hopefully someone that has had the same issue previously.

Link to comment
Share on other sites

I can get Remote Access installed - it's when I go through the setup wizard - "configure and enable routing and remote access" gives me the ICS message 

 

So it falls over on step 2 of the "Enable RRAS as a VPN Server" guide

Link to comment
Share on other sites

Run "services.msc", find the 'Internet connection sharing' service. Right click on it and select "Properties".  Set the startup type to "disabled", and reboot. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...