Jump to content
RESET Forums (homeservershow.com)

Windows 10 VPN before login


marky9074
 Share

Recommended Posts

Hmm wrote a massive post, then lost it on posting ^_^

 

Anyway, trying to get VPN up before login on Windows 10 Anniversary. New client has a windows server 2012, though I did not get any handover info, so just enabled VPN in their Draytek Vigor 2820 router and tested from my laptop OK However, their domain users cannot access any resources when they login through VPN. I tried adding host files for a test, but still they cannot access anything (yet they can ping OK). Can only assume this is because they are logging in prior to establishing the VPN, so credentials are not being passed.

 

Tried new connection in Control Panel ticking share (as the share option is not available in the new UI). Tried a PS cmdlet to add the connection. Enabled the CTRL-ATL-DEL option by editing registry. Copied phonebook from the local App directory to the appropriate C:\ProgramFiles location. All the threads I have searched have permutations of these, but none of them seems to work. The VPN just does not show as an option prior to login.

Edited by marky9074
Link to comment
Share on other sites

not sure this is your solution. but from the logon screen on my corporate windows 10 laptop at work i can select the network Icon at the bottom right of the screen and execute the vpn logon from there. when its successfully connected i can then logon to the domain on windows, is that what you are trying to achieve.

 

i spoke to the team that manages the corporate side of the IT and they told me in no great detail that they set up a vpn connection in windows allowing it to be used by other users (Check Box) this then allows any user to connect the vpn before using their domain credentials to log in to windows. only works with manual vpn logon, if you are using certificates it does not work, or did not for our guys.

 

sorry, not much more on this but hope it may lead you in the right direction.

 

***Update***

 

i jarred one of the guys over a coffee and he told me that you have to do the following.

 

start> type change dial-up settings to search. select it.

 

set up a new connection

 

choose connect to a workplace

 

use my internet connection (VPN)

 

enter the details for your draytek external IP or Domain Name depending how you are configured, give it a name and ensure only allow other people to use this connection is selected.

 

once this has been created, go into the network and sharing centre and edit the properties to your preference. once complete you can log off your machine and then you will now see the dial up connection symbol (looks like 2 computers overlapping).

 

select that, login to vpn, once established, login to windows/domain.

Edited by eddie563
Link to comment
Share on other sites

Hi Eddie,

 

Thanks for the help. I did this, and I can see the rasphone.pbk in the right place under C:\ProgramData\Microsoft\Network\Connections\Pbk however it just does not show up from the lock screen. I'm assuming you see it at the top of the network lists, as you would when logged in and clicking on the network/WiFi icon?

 

Cheers,

 

Mark

Link to comment
Share on other sites

Hi Mark,

 

no mate, it shows up next to the network/wifi icon as its own entity. let me grab some photo's and i'll upload them.

Link to comment
Share on other sites

this is the icon

 

XNbg4_yA3pcYc9RKfq5pMhIxtKdajnd6mJ1z-wEz

 

when i select it, i get this VPN Login

 

JFhyV6xxYdyhmXcC0x9_6dIskjly1YFVeUTTMOTz

 

once it logs in to the VPN i am then prompted back to my domain login screen

 

1u1lMGQGeWsPDBqSkR8fBr7t92-s5aldfejOVFGP

Link to comment
Share on other sites

Hi Eddie,

 

Can't see the photos? I do wonder if I can create a local user (or just another domain user) log in and enable the VPN then switch users and log into the domain. That said, it must be possible as its on your workstations? I'm assuming your up to date and on the Anniversary update?

 

Cheers,

 

Mark

Edited by marky9074
Link to comment
Share on other sites

Been having issues using the codes i know from previous forums but have sussed it out.

 

this is the icon

 

DialIcon.jpg

 

when i select it, i get this VPN Login

 

DialLogin.jpg

 

once it logs in to the VPN i am then prompted back to my domain login screen

 

DomainLogin.jpg

Link to comment
Share on other sites

Thanks for that... at least I know what I should see now!

 

Just out of interest if you go into your properties for the VPN and go to the sharing tab, is the 'Allow other users to connect....' actually checked? Even though I selected this when I created it, its not checked, and if I enable it an error comes up 'Error 75: the parameter is not correct'. This is the same on both my Dell and SP3.

 

Cheers,

 

Mark

Link to comment
Share on other sites

if i go to the network connections from the network and sharing centre, i only have 4 tabs. General/Options/Security/Networking, there is no sharing tab.

 

if i use the new windows 10 settings "Change Virtual Private Network Settings" and go to the "advanced options" for the VPN again there is nothing that shows sharing with other users.

Link to comment
Share on other sites

That's mad..!!  I have the same, but a sharing tab at the end. Did you say you were on Enterprise instead of Pro? Maybe I'll flash that up in a VM and see if I can do it from that...  This is getting quite painful now!!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...