Jump to content
RESET Forums (homeservershow.com)

Cannot access WHS console?


Grant B
 Share

Recommended Posts

I just received a call from a friend who owns an EX485 MediaSmart server. Here is the scenario he gave me:

 

- He thinks he has a failing drive on the server but all the lights are blue.

- He can see and has access to all the shared folders.

- He cannot access the console or RDP in.

 

Understandably, he is a little worried for all the data on the system and has asked me to come over and help.

 

Any suggestions on how to troubleshoot the issue or at least get the console working again to see if there is a failing drive?

 

If you shut the system down, removed the drives one by one and connected them to you system via USB to scan them - would that mess the drives up for the server? That may at least tell him if there is an issue with the OS drive or one of the pool drives?

 

How would running a server recovery affect the system? Would it even work?

 

Last thing I want to do is to make matters worse.

 

Thanks,

Grant

Link to comment
Share on other sites

Run "mstsc /v:servername /admin", use "SERVERNAME\Administrator" as the username. And it's password is the server password. 

 

If this works, use the Task Manager to log off of the disconnected session. 

 

If the shares are still accessible, then the system is up and running. it's the user session that is the issue. The console may crash, but the session doesn't close properly.  Logging off the section manually, or power cycling the system will fix this, usually. 

Link to comment
Share on other sites

Not sure what he has in way of backups of the server. Most likely he has stuff on the server he does not have backed up.


I will tell him to try the run mstsc - thanks.

Link to comment
Share on other sites

OK... I tried the "run mstsc" to RDP into the server and that was a no-go. It kept telling me that there was no network connection to the server. Here is what I observed:

 

When I looked at his PC, the console icon was grey. I tried to access the console and it told me there was no connection to the server. I tried to run the RDP the "usual" way and received the same. The odd thing is that it keeps saying that there is no connection to the server but you can see the server on the network and still look at / access the shared folders and files. Since I had access to the shares, I copied the connector software from the server to his desktop and tried to run the repair - no-go. I uninstalled the connector and tried to reinstall - nope. Now this PC does not have the connector software installed because it cannot connect to the server to finish the install. Of the three systems in his house that I tried to connect to the server on, all of them cannot connect to the server via console or RDP and only two of the three can access the shared folders in file explorer. Two of the systems are Win 8.1 and one is Win 10.

 

While he still has access to the shares, I am currently getting him to manually back up the files he wants / needs to keep before we try anything that may end up totally cutting off access to the server altogether. This way he will not lose anything if things go terribly wrong.

 

While we were doing this, I was explaining that I am currently migrating all my data from my server and plan on doing a complete factory reset on it. The more we discussed the more he seemed interested in this option. While it still is an option, I am perplexed as to the odd connection issue between the client systems and the server - why there is no access to the server via the console or DRP but you can still see / access the shares. Makes me worried about going to all that work and not getting access to the server again.

 

I suppose the next logical question I have for you fine people is, now that we are safeguarding the data against loss, what would be the best way forward? While it means the most work, I think that a factory reset of the server and totally removing and redoing the client systems console and access to the server may be the most complete solution. Would the following be a sound way of continuing?

 

1. Back up all the data

2. Remove the connector software from one of the clients (what all should be uninstalled)?

3. Direct connecting the server to that system and running the factory reset.

4. Returning the server to the network and installing the connector on the PC from it (if it allows access)

5. Running the updates to it until it is fully updated.

6. Putting the data back onto the server.

 

Are there any steps I have missed or a better way to do it? Should I try and suss out the connection issue before I attempt this?

 

Thanks again for any help on this.

 

Grant

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...