Jump to content
RESET Forums (homeservershow.com)
migueltg

ESXi 6.5 B120i (hpvsa) HP Microserver Gen8 Low performance

Recommended Posts

Gunnm19

Okay so I can add two more test.

 

First one : 

1HDD 1To / 7500 rpm / RAID0 (one disk) / Bay 3 / RDM 

 

 

Second one :

2 HDD 1To / 7500 rpm both / RAID1 / Bay 1 & 2 / RDM

 

Watch out the pictures seems to be inverted. Move your mouse in front of the picture to get the configuration name.

RAID-0-Bay-3.PNG

RAID-1-Bay-1-&-2.PNG

Edited by Gunnm19
  • Like 1

Share this post


Link to post
Share on other sites
Gunnm19

And one more benchmark with ATTO tools.

ATTO.PNG

  • Like 1

Share this post


Link to post
Share on other sites
Gunnm19

You'll find attached a bunch of test I made on my configuration with 6.0 and 6.5 version.

 

I tested on RAID0, RAID1 (both RDM conf) and SSD. 

 

The performance on the SSD is half better with the new version for all file size. For RDM disk I have a huge difference on small size file and it's pretty the same for bigger file.

 

I did the rollback to 6.0 U2 version yesterday evening.

Speed test_ESXI version.zip

Edited by Gunnm19

Share this post


Link to post
Share on other sites
Rayman

Hello,

 

Yesterday I installed HPE Custom Image of ESXi 6.5 with the embedded 5.5.0-102 (the newest) version of the hpvsa driver, and got very bad (and unstable) performances copying over the network a large file to a freshly created Debian VM running an SMB share. The transfer started at 55 Mo/s and quickly dropped around 10 Mo/s.

On the hardware side, I currently have only one old 2 To WD GREEN HDD plugged into the 4th bay (SATA II - 3 Gb/s) of my Gen8, declared as RAID 0 in HP SSA.

I tried to rollback to 5.5.0-88 version of the driver, but after the reboot all my storage volumes in ESXi are wrecked and my VM obviously won't start... I spent the whole weekend on my Gen8 and had all the possible issues with it. So it had to be that way I suppose...

 

Does anyone has tried building a custom image of ESXi with the 5.5.0-88 driver?

Share this post


Link to post
Share on other sites
Hytri

@Rayman,

 

I had the same problem yesterday.

 

Here's what I did :

 

- Uninstalled the hpvsa 5.5.0-102

- Installed the hpvsa 5.5.0-88

- Rebooted

- All storage volumes were down because ESXi was using the AHCI Driver vmw_ahci

- I disabled the AHCI driver to force ESXi using the downgradedhpvsa drviver --> command from "http://www.nxhut.com/2016/11/fix-slow-disk-performance-vmwahci.html"-- " esxcli system module set --enabled=false --module=vmw_ahci".

- Reboot and voilà ! ESXi is using the hpvsa 5.5.0 - 88 which is much better

 

Let me know if it works for you.

Edited by Hytri
  • Like 2

Share this post


Link to post
Share on other sites
Rayman

@Hytri

 

Wow, I didn't think this could be done. I'll check it out and let you know! Thanks!!

Share this post


Link to post
Share on other sites
ohrstedt
@Hytri

 

Thanks! Disabling the vmware native ahci driver allowed the scsi-hpvsa to load correctly.

 

ATTO Benchmark from a VM on local SSD attached below.

 

ATTO - Local SSD datastore - ESXi 6.5.0 - hpvsa 5.5.0-88OEM.png

  • Like 2

Share this post


Link to post
Share on other sites
mind12

Hi,

 

Im planning to upgrade my 6.0 ESXi to 6.5 version. 

Can we declare that it's running smoothly on the Gen 8 with the restrictions (hpvsa version 88 and vmkusb disabled) mentioned above?

 

If your ESXi boot USB is not found during the install the following will help you (have not tried yet):

http://www.virtuallyghetto.com/2017/02/no-suitable-disk-was-found-when-upgrading-to-esxi-6-5-on-usb.html

Share this post


Link to post
Share on other sites
odrakir

I've followed @Hytri steps and it works well with 6.5... 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Mark Belanger
      By Mark Belanger
      Greetings,
       
      I'm new to the HPMSG8 world and so far I'm loving it. I have a stock Xeon with 16G of aftermarket memory with iLO patched to 2.70. Next up is adding a RAID card, so I can put my boot SSD on the onboard RAID. I picked up a LSI SAS9211-8i on Amazon, but am struggling to flash it to IT mode on the MicroServer. Is this even possible? Unfortunately, the only other system I have with PCI slots is 32-bit.
       
      Any pointers would be greatly appreciated.
       
       
      -MB
    • npapanik
      By npapanik
      FYI, I have just installed Windows Server 2019 Standard (Desktop Experience) using the latest (WS2016) HP AMD chipset & VGA driver. Everything is recognised in Device Manager and stable.
    • TonyTheTechie
      By TonyTheTechie
      I need to update the firmware on a HP Proliant Microserver Remote Access Card installed in my N40L.
       
      Can someone please explain what I need to do to create a boot device that will update the firmware on the Remote Access Card?
       
      Thanks
       
      Tony Self
    • pksparks
      By pksparks
      Good evening,
       
      after checking my ILo4, version2.61 on my Gen8 hp microservet, i saw an exclamation mark at cpld-pal0. It is now version 0x06.
      i have read that there is an version 0x32.
       
      anybody who has this version, and can provide me with a download link?
       
      Attached my firmware configuration. Any suggestions for any updating? Think most is up to date?
       
      rgds
      patrick
      Sorry can’t upload photo, error 200.


×
×
  • Create New...