Jump to content
oj88

Windows Server 2016 Essentials

Recommended Posts

DonTen    0
DonTen

An update:

 

Accessing http://myserver/connect from IE on the server receives the following error message (copied partially below). I do not know what permissions ASP.NET should have in a correct installation and would be very grateful if someone more knowledgeable could to tell me how to check whether they are correct and if not how to change them. There is a ConnectWebsite txt file in the logs but the last modified date is from before I first attempted to connect the new PC.

 

Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.8045909b-db18-4bd5-8a53-238242d375fa.log' is denied.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the path 'C:\ProgramData\Microsoft\Windows Server\Logs\ConnectWebsite.8045909b-db18-4bd5-8a53-238242d375fa.log' is denied.

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET access to a file, right-click the file in File Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access

Share this post


Link to post
Share on other sites
Drashna Jaelre    152
Drashna Jaelre

On the server, go to "C:\ProgramData\Microsoft\Windows Server", and reset the permission for the Logs folder (right click on it, select properties, and then the "Security" tab).

 

Make sure that "WseNtfSvc" and "NETWORK SERVICE" both have read and write permissions on the folder.  If not, assign them and save. 

 

This should fix the permission issue. (IIS in general runs under "NETWORK SERVICE", or as part of that "group")

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
DonTen    0
DonTen

Dear Drashna

 

Thank you for the post. WseNtfSvc did't seem to exist but changing the permissions for NETWORK SERVICE seemed to work and I have now successfully connected a new client.

 

Is there fools guide to enabling Windows Hello features on the client (domain connected)? The PIN, face recognition etc are all greyed out. Does one have to fix the client or is there some group policy thing one needs to do in Windows Server 2016 Essentials? I would be grateful for any insight you can offer.

 

Thanks again.

 

DonTen

Share this post


Link to post
Share on other sites
Drashna Jaelre    152
Drashna Jaelre

Welcome!

 

As for the Windows Hello, I have no idea.

 

As for the Pin number and stuff, that's disabled on a domain by default, for security reasons.  But this can be re-enabled by a group policy, actually. 

 

To enable it, create a new group policy (in the "Group Policy Management" console, on the server).  Name it "Windows Pin" or the like.  Edit it, and under "Computer Configuration" -> Policies -> Administrative Templates-> System -> Logon, find the "Turn on convenience PIN sign-in." option and enable that.  

 

Close it, and run "gpupdate /force /target:computer" on both the server and the client systems.   Then reboot. 

 

For the Windows Hello stuff, check out this link:

https://docs.microsoft.com/en-us/windows/access-protection/hello-for-business/hello-manage-in-organization

 

Which basically ... you'd do the same thing for, but under "Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Hello for Business"

 

I hope that points you in the right direction.

Share this post


Link to post
Share on other sites
Drashna Jaelre    152
Drashna Jaelre

You're very welcome. And let me know how well that works out!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×