Jump to content
RESET Forums (homeservershow.com)

wmpnetwk.exe driving up CPU usage


dvn
 Share

Recommended Posts

This is something I've been noticing over the last week or so. A process call wmpnetwk.exe has been driving CPU usage up significantly. On one laptop, it was consuming 75-77% CPU for extended periods of time, leaving the laptop unusable. I disabled the service behind it and things went back to normal. On my gf's computer it was also driving CPU usage up around 10-12%, so I disabled it on there as well and things went back to normal. I know this process/service is related to media sharing between computers. Disabling the service doesn't cause any problems for us because we use WHS as the central share point.

 

I'm wondering if anyone else is noticing an unusual increase in CPU usage by this process/service. Maybe it's just a coincidence, but then again maybe MS updates has mangled something.

Link to comment
Share on other sites

That's part of Windows Media Player's Media Sharing. The proper way to turn it off is to do so from withing WMP, rather than disabling the service directly. For instructions: http://www.howtogeek.com/howto/windows-vista/what-are-wmpnscfgexe-and-wmpnetwkexe-and-why-are-they-running/

Yes, I know it's Window Media Player's network sharing service. And thanks for the info on how to turn it off from within Media Player. But, I was asking if anyone has observed the associated process using a lot of CPU lately. I'm trying to pin down what causes this.

Link to comment
Share on other sites

No clue on the cause. Do you use WMP to share content on your network?

No, we don't use it. It may have been enabled but that's probably because it's a default setting when you first use WMP. As I mentioned, the first time I really noticed this was on a laptop I was repairing. I had just uninstalled McAfee and was checking out the rest of the situation when I noticed wmpnetwk.exe doing its thing. That's when I decided I'd better look at the other computers in the home.

Link to comment
Share on other sites

That's part of Windows Media Player's Media Sharing. The proper way to turn it off is to do so from withing WMP, rather than disabling the service directly. For instructions: http://www.howtogeek.com/howto/windows-vista/what-are-wmpnscfgexe-and-wmpnetwkexe-and-why-are-they-running/

fwiw - That article was written on 03/12/08. It's out of date. The screen shots are of a version prior to WMP 12, and the regedits he mentions at the end of the article are invalid. The DWORD 'DisableDiscovery' has been replaced with 'UserWantsRemoteSharing'. Which I don't. haha

 

However, towards the end, he does talk about how to disable the service like I did. ;)

Link to comment
Share on other sites

I think (not sure) the issue could be a corrupt file that it's indexing. Just like Twonky could get stuck on a file and keep processing the same file. Try removing your media files off the machine and see if that resolves it. Then start adding your collection. I also saw this with FirePlay/FireFly until they added some debugging routine.

 

Also it could be a file that is NOT a audio or video file but it is in one of the folders that is being indexed. So since the service is confused about the file, it just keeps thinking "one more time, maybe this time".

Link to comment
Share on other sites

I think (not sure) the issue could be a corrupt file that it's indexing. Just like Twonky could get stuck on a file and keep processing the same file. Try removing your media files off the machine and see if that resolves it. Then start adding your collection. I also saw this with FirePlay/FireFly until they added some debugging routine.

 

Also it could be a file that is NOT a audio or video file but it is in one of the folders that is being indexed. So since the service is confused about the file, it just keeps thinking "one more time, maybe this time".

Interesting. :P Seriously, that's an interesting thought. I'll have to check it out on the gf's computer.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...