Jump to content
RESET Forums (homeservershow.com)

Booting CentOS 7 1511 minimal/net install iso CD/USB


BJWTech
 Share

Recommended Posts

Hello all,

 

I recently wanted to upgrade my HP n36l from the Ubuntu 12.04 that was installed a few years ago. I now run mostly all my gear on CentOS 7 software, so I tried to install CentOS 7 1511 minimal. To my surprise both a CD and USB install ISO failed to boot with a kernel panic.

 

Seems to be related to setting the system timer. I found a relevant bug and got a clue to help me get it installed.

 

I had to edit the grub entry on the livecd to append the following line (use the TAB key to edit the grub boot command);

initcall_blacklist=clocksource_done_booting

Once added, the install went as normal. I rebooted after install and was met with the same bug and had to edit the grub command once again using the "e" key this time to edit. It seems a newer kernel is needed to move past the bug.

 

I then set off to update the system with;

yum -y update

After updating and subsequent reboot the grub edit was no longer necessary and the new kernel booted up without issue. Save for a missing amd bin file. I will post a fix for that too.

 

Brian

 

edited for tags....

Edited by BJWTech
  • Like 1
Link to comment
Share on other sites

That was a good save.  I have had trouble with nic's before in the past.  Inconvenient to update when you can't get online to update. 
How do you like CentOS compared to Ubuntu?  I have been wanting to run CentOS in a VM on my computer to try it out.  I have been using Debian for 14 years.  I started on Slackware, moved to FreeBSD to OpenBSD then finally to Debian.  I tried Ubuntu Server a couple years ago.  It was nice but I like the minimalist/install only what you need feel of Debian.

  • Like 1
Link to comment
Share on other sites

That was a good save.  I have had trouble with nic's before in the past.  Inconvenient to update when you can't get online to update. 

How do you like CentOS compared to Ubuntu?  I have been wanting to run CentOS in a VM on my computer to try it out.  I have been using Debian for 14 years.  I started on Slackware, moved to FreeBSD to OpenBSD then finally to Debian.  I tried Ubuntu Server a couple years ago.  It was nice but I like the minimalist/install only what you need feel of Debian.

 

 

It had me stuck for a while actually. On my n40l, which was having the same issue I ended up installing Ubuntu 16.04 until I could spend some time to figure it out. It was my media server and It had to be up or my family would kill me!! Heh...

 

I have been using Centos since 6.4 I think.... I love it for the bare basic approach it takes for a minimal install. It is as bare as you can be I think. I switched full bore when Ubuntu moved to upstart with 14.04. Too many incompatibilities with various software I was using. I much prefer systemd to upstart. Canonical must have agreed with me as they switched too! :)~ That being said, as a MSP, I have clients who run everything from Ubuntu, Centos, Slackware.... And of course MS Windows/Server.

 

Brian

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

After running ESXi5.0 for several years, including CentOS and WHS2011 as ESXi guests, I'm trying to install the same native Centos release as you, and then create a virtual WHS2011 KVM, but I haven't been successful so far, failing at the CentOS install. I was hoping that you may be able to help.

 

I seem to have a problem with the AHCI driver, which causes the install to hang unless I exclude it, and I also get an i8042 no controller found error. To overcome both these on the linux install command line, I'm using 

linux nomodeset initcall_blacklist=clocksource_done_booting modprobe.blacklist=ahci inst.dd

I have found these parameters by using google, I'm by no means an expert on Linux!

The install gets to a point where it is asking me where it can find driver updates, and offering me a choice of /dev/sdaX (the existing partitions on the hard disk where I want to install), and /dev/sdb1 (the boot USB).

If I choose just to continue, rather than choose a partition that contains drivers, eventually I get dozens of dracut timeout messages. and finally the Dracut Emergency shell starts with warnings that the system won't boot and /dev/root cannot be found.

 

Please can anybody help with explaining how to get the correct drivers. I'm imaging it is something like this link http://josafatisai.blogspot.co.uk/2016/01/installing-centos-7-on-hp-proliant.html but that page is about the next generation of Microserver, and I'm uncertain which drivers I should get.

 

I've attached the completerdsosreport.txt  rdsosreport.txt

 

 

Link to comment
Share on other sites

  • 1 month later...

NVM, turns out the USB I had created was corrupt. Not corrupt enough to fail to run though!

Sorry I did not see this... Yes, that is how a corrupted USB will boot sometimes. Usually when writes were not synced before ejecting said USB drive.... I always use;

dd if=SOURCE of=DESTINATION bs=4M && sync

Brian - HTH!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • hhvdwatt
      By hhvdwatt
      Hi I am new to forum.
       
      I have an HPE 40L Microserver and would like to upgrade the motherboard to something a bit more modern. 
       
      From what is can find on this topic it would appear that the motherboard is mini-ITX like but not exactly. Has anyone ever resolved upgrading this with something new that works or should I just replace the server?
       
      Thx in advance
    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • chickenlip007
      By chickenlip007
      Hi Guys, have a strange issue whereby my N54L won't turn off, it just reboots. The same behavior is seen when using Windows or Vmware, when shutting down, the server proceeds to start the shutdown process but powers itself up again immediately. I have tried resetting the Bios, removed the board and all components, re-installed and still the same. 
      I moved the mainboard into a spare Microserver Chassis with the same result (to rule out any cabling issues). I have changed the RAM modules as well, with no luck.
      It is worth mentioning that the onboard NIC no longer works either, I have replaced with a PCIex card that works fine. Holding down the power button for 5 seconds will turn off the server but immedately starts back up when it is released. I have compared BIOS settings to another working Microserver in my LAB, same results.
      I am honestly out of ideas, spent way too many hours scratching my head over this one. the only way to get it to stay off is wait till the splash screen loads then pull the power plug, which is not ideal.
      Anyone else have any ideas?
      thank you!
×
×
  • Create New...