Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
Dwain Pipe

ESXi 6 - Can't Degrade the hpvsa driver to v.88

Recommended Posts

Dwain Pipe

I'm at the end of my patiences.  Please can you clever people help me?

 

I'm a newbie to VM stuff, I've been playing but I find it all a bit slow, so worked out I need to downgrade the hpvsa driver (100 currently installed as I've got the HPE latest image installed).

 

So I've found various post with the ssh commands to install the .88 driver, but after maintenance mode and try the command 'esxcli software vib remove -n Hewlett-Packard:scsi-hpvsa' but get "[installationError]

 The transaction is not supported: VIB Hewlett-Packard_bootbank_scsi-hpvsa_5.5.0.100-1OEM.550.0.0.1331820 cannot be removed live.
 Please refer to the log file for more details."
 
I'm in Maintenance Mode!!!  I've tried a fresh install of ESXi 6 and have not created any VMs yet, still the same error.
 
I've got a USB memory stick in the internal USB inside the Gen 8 microserver where I've installed the ESXi hypervisor and booted to it.  I've removed the datastore so that is not the issue.
 
I've googled big style but none of the ideas same to work.
 
Any kind of remove command gives this kind of error.
 
Any ideas guys, please?
 
 

  

Share this post


Link to post
Share on other sites
Dwain Pipe

Yes, those are the instructions I'm using.

 

I enter maintenance mode (via the web client, CLI or vSphere Client) then using Putty I connect and put in...

esxcli software vib remove -n Hewlett-Packard:scsi-hpvsa

 and get the error message...

 

 [InstallationError]
 The transaction is not supported: VIB Hewlett-Packard_bootbank_scsi-hpvsa_5.5.0.100-1OEM.550.0.0.1331820 cannot be removed live.
 Please refer to the log file for more details.

I'd like to check the log file but there appears to be 100's of them so I need to know which log file to look in.

Share this post


Link to post
Share on other sites
Dwain Pipe

Which of the HP custom images contains the .88 driver?  I don't feel the need to be on the latest and greatest version so may be a rebuild to an older version with that driver in it is an idea as this is frustrating.  I've just rebooted the host and can't get to the web client now.  :unsure:

Share this post


Link to post
Share on other sites
rotor

This works for me every time:

# To roll back to hpvsa build 88 (for MicroServer Gen8 compatibility)
esxcli system maintenanceMode set --enable true
esxcli network firewall ruleset set -e true -r httpClient
esxcli software vib remove -n scsi-hpvsa -f
esxcli software vib install -v http://vibsdepot.hp.com/hpq/nov2014/esxi-550-drv-vibs/hpvsa/scsi-hpvsa-5.5.0-88OEM.550.0.0.1331820.x86_64.vib
esxcli system shutdown reboot -r "Rolled back to scsi-hpvsa build 88"

Share this post


Link to post
Share on other sites
GotNoTime

If you're getting that error then it means your bootbank is not accessible. Your ESXi is running off the ramdisk copy only and can't access the bootbank it actually starts from.

 

Have you tried to do DirectPath I/O passthrough of all our USB controllers?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...