Jump to content
RESET Forums (homeservershow.com)

microSD is not recognized after CPU upgrade


marat_n
 Share

Recommended Posts

Hello guys,

 

I have a strange problem on my MS Gen8 - after upgrading my CPU from Celeron G1610T to Xeon E3 1265L V2 my server stopped recognizing microSD cards. I used microSD for booting Proxmox.

At first I thought there was a problem with microSD card itself (some of them are used to dying suddenly). So I tried other microSD cards but my server didn't recognize any of them.

 

Can it be related to the CPU upgrade? Maybe system bus frequency raise (from 1333 to 1600MHz) made it impossible to use cheap 3rd party microSD cards and I have to use original HP memory cards?

 

Thanks in advance!

 

With the best regards,

Marat

Clip2net_160514171227.png

Link to comment
Share on other sites

Can it be related to the CPU upgrade? Maybe system bus frequency raise (from 1333 to 1600MHz) made it impossible to use cheap 3rd party microSD cards and I have to use original HP memory cards?

No to both. The microSD reader is unrelated to the CPU.

 

What does matter is that the microSD reader is attached in some way to iLO. If you've reset or updated iLO then it temporarily breaks the microSD reader on the Gen8 Microserver. Unplug the microserver from the mains, wait 5 seconds and plug it back in again. Restarting or turning off via the power button on the front doesn't work. You have to disconnect it from the mains.

Edited by GotNoTime
  • Like 1
Link to comment
Share on other sites

No to both. The microSD reader is unrelated to the CPU.

 

What does matter is that the microSD reader is attached in some way to iLO. If you've reset or updated iLO then it temporarily breaks the microSD reader on the Gen8 Microserver. Unplug the microserver from the mains, wait 5 seconds and plug it back in again. Restarting or turning off via the power button on the front doesn't work. You have to disconnect it from the mains.

 

Thanks. I will check that asap.

Link to comment
Share on other sites

Unfortunately unpluging the server from the mains didn't help. I also re-inserted microSD card while the server was with no power.

Btw I didn't reset or upgrade ILO or any other system components before it happened. The only thing I made was replacing the CPU

 

I found similar issue http://homeservershow.com/forums/index.php?/topic/11104-gen8-weird-microsd-fault-ish/but as i said above removing/inserting microSD didn't help :(

Link to comment
Share on other sites

It is hard to say at which point SD card disappears. Once I'd have problems just after entering in array configuration utility (at boot). Removing main power for some 10 s helped that time.

I would suggest to reset ILO first and then remove power.
If it doesn't help, reset the BIOS also. I think it can be done in BIOS or with system maintenance switch S6 (http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c03783380-6.pdf  - pages 74-76) http://www.running-system.com/how-to-clear-or-reset-a-hp-server-gen9-nvram-using-system-maintenance-switch-on-the-system-board/

  • Like 1
Link to comment
Share on other sites

It is hard to say at which point SD card disappears. Once I'd have problems just after entering in array configuration utility (at boot). Removing main power for some 10 s helped that time.

 

I would suggest to reset ILO first and then remove power.

If it doesn't help, reset the BIOS also. I think it can be done in BIOS or with system maintenance switch S6 (http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c03783380-6.pdf  - pages 74-76) http://www.running-system.com/how-to-clear-or-reset-a-hp-server-gen9-nvram-using-system-maintenance-switch-on-the-system-board/

 

Thanks, I will try

Link to comment
Share on other sites

Thanks, I will try

you tried removing the microsd card.

 

I had a weird one, after a power outage!

 

microsd card disappeared, until I removed it physical and inserted back in!

 

no idea why!

Link to comment
Share on other sites

Unfortunately resetting ILO, resetting BIOS settings, disconnecting the mains, removing/inserting microSD card didn't help - any microSD card is not detected by the server.

I will try to open a case on HPE support.

Link to comment
Share on other sites

Unfortunately resetting ILO, resetting BIOS settings, disconnecting the mains, removing/inserting microSD card didn't help - any microSD card is not detected by the server.

I will try to open a case on HPE support.

You can try to use internal USB stick near SD slot instead of SD card.  

Link to comment
Share on other sites

You can try to use internal USB stick near SD slot instead of SD card.  

yeah, i know about that USB port and i dont mind using it.

but anyway i'd like to know what's happened with my microSD card slot

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Haxsource
      By Haxsource
      Good afternoon folks!
       
      I have a question I was wondering if someone would know about. I have a Microserver Gen 8 with Vmware ESXI 7 currently installed on the MicroSD with AHCI enabled instead of RAID mode (dont find anything usefull in raid mode in my current setup other than booting from ODD, which I can just use as another Datastore instead).
       
      With that context being said, Im trying to enable the Agentless Management Service from the ILO with the drivers on the Vmware ESXI 7, but unfortunetly after installing and trying to start the service with:

       
      /etc/init.d/hp-ams.sh start  
       
      I get the following error:
       
      /opt/hpe/ams/amshelper: error while loading shared libraries: libnicmgmt.so.0: cannot open shared object file: No such file or directory  
       
      Makes sense following the Vmware ESXI HPE support matrix, since its only supported until Vmware ESXI 6.5U2 Pre-gen. But I´ve been reading lots of people having working setups doing the following:
       
      Install Vmware ESXI HP Custom Image 6.5U2 -> Offline Update to Vmware ESXI 6.7.
       
      I was wondering if installing HP Custom Image 6.5U2 with the drivers Agentless Management Service working and doing a full upgrade to ESXI 7.0 would do the trick, since its an upgrade not a clean install...so libraries should stay supporting older drivers installed.
       
      Does this make any sense?? Has anyone gone trough this alredy?
       
      Thanks!
    • netware5
      By netware5
      ***CRITICAL*** iLO 4 update available here. HPE requires users update to this version immediately. Potential vulnerabilities in network stack.
      VULNERABILITY SUMMARY
      A potential security vulnerability has been identified in Integrated Lights-Out 5 (iLO 5), Integrated Lights-Out 4 (iLO 4), and Integrated Lights-Out 3 (iLO 3) firmware. The vulnerability could be remotely exploited to cause memory corruption.
      HPE has released updated firmware to mitigate these vulnerabilities.
      References: CVE-2020-27337
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • gru
      By gru
      Hi! I am planning to buy a Microserver Gen10 Plus E-2224 for a small business, and want to add as much disk space as possible. I already have the older Gen10 with 4x4TB HDDs in RAID10 (effective capacity 8TB) and a 2TB SSD in the 5th slot (which is missing on the new G10 plus). The max stated capacity on the HPE site seems to be limited with their own enterprise HDDs, so I'd like to see if I can go for bigger disks. The server would be running a sort of an application which collects lots of data from devices, and the data tends to grow over time (1-2TB per year), and I'd prefer not to worry about the capacity for the next several years.
       
      My primary concern is the max capacity (max single drive capacity + max total RAID capacity with the Smart Array S100i) I can reliably install. If possible, some actual setup which has been shown to work with 32GB RAM and its limited 180W power supply? I was also planning on upgrading it to 32GB. If I am buying a 16GB RAM server, does this means it has both slots occupied with 8GB modules and I need a 2x32GB kit? For the os SSD, I won't have the PCIe slot available because we need to insert a certain GPS PCIe card that the server uses for time synchronization. So, if I want an SSD, this means I should use something like 1xSSD + 3xHDD in RAID5, instead of RAID10?  
      I've been planning to install 16TB Seagate Exos X16 drives, with rated max operating power at 10W (6.3W for random reads/writes). Does this seam feasible?
       
      Thanks a lot for your tips!
×
×
  • Create New...