Jump to content
RESET Forums (homeservershow.com)

IBM ServeRaid M1015 LSI SAS9220-8i, W8 will not boot


Andy16
 Share

Recommended Posts

I've got a W8 pc that I use as a home server.  I ran out of SATA ports and after doing some reading decided to purchase the IBM ServeRaid M1015 46M0861 SAS/SATA PCI-e RAID Controller LSI SAS9220-8i. 

I have no interest or intentions of using RAID.  I currently use Drive Bender and was hoping to add a few more drives to my server.

After installing the card and the drives, the computer boots to the LSI MegaRAID BIOS.  I can get into the configuration utility.

Adapter No. 0

Bus No. 9

Device No. 0

Type ServeRaid M1015 SAS/SATA Controller

Firmware Version 2.130.354-1664

 

My drives are visible in the physical view:

Backplane

Slot: 0, SATA, HDD, 7.277 TB, JBOD

Slot: 1, SATA, HDD, 7.277 TB, JBOD

 

The drives listed above are new and should be empty, I'm not worried about losing any data on those drives.  I've tried adding the drives where they show as Unconfigured Good drives and as JBOD, as long as this card is installed I can not get my pc to boot.  I've gone into the BIOS of the PC to check the boot order and the M1015 is not selected.

 

I've looked and looked for a solution and cant find anything, the only thing I keep running across is cross flashing the card.

http://www.servethehome.com/ibm-serveraid-m1015-part-4

 

Any suggestions are greatly appreciated.

Link to comment
Share on other sites

Per the Servethehome article the card needs to be in IT mode. It may already be in IT mode as it is showing your drives as JBOD. Many times when you add a card with a BIOS, like the IBM card, it can conflict with resources in your PC. Can you share more info on your PC?

Link to comment
Share on other sites

If the card is not flashed at all, it's not in IT mode. In fact, it can ONLY do RAID, and won't pass through the disks.  You would have to add each disk to it's own array/JBOD to get it to show up.

 

Flashing it to IT mode puts the firmware into HBA mode, allowing you to pass through the disks to the host without having to do anything. 

Link to comment
Share on other sites

  • 11 months later...

Hi guys.... I'm having a similar issue with an LSi 9420-4i.  As purchased (OEM), no hand over to finish POST (boot) after initialization. It just stalls, although CTRL-ALT-DEL is responsive.  Flashed as a 9211 IT, no BIOS, it works fine since no bootROM.  Flashed as 9211 IT with the Boot BIOS, it hangs after initialization.  It's seen as a SAS9211-IT and I can access it's bios, change settings, and see drives attached, so controller is operating.

 

I've got myself in a bind now.  In it's current configuration, I cannot boot whatsoever with the controller installed, so I cannot flash it.  Spent days trying every option in my mobo BIOS, disabling everything, to no avail. Tried all 3 PCIe 2.0 x16 slots.  Even purchased a NOS "ATi Rage XL PCI VGA adapter" to open all 3 PCIe slots! :P  Doesn't seem to matter with/without drives attached, or whether the controller is enabled/disabled in it's BIOS.

 

I read a forum post from a guy who had the same situation and let the system sit at POST overnight, and some 10-12 hrs later it booted!  I will try that as a last resort just for giggles and see.  If I can boot to my DOS stick I should be able to clear and re-flash w/o the damn BOOT ROM, although this defeats my purpose since my initial goal was to add SATA III to an old SATA II motherboard and boot from an SSD at SSD speeds. 

 

Thanks in advance.....

 

Evga nForce 780i SLi (LGA775)

Intel E8500 (now Xeon x5470)

8gb Gskill matched DDR2-1066 (4 x 2gb)

Evga GTX 660 Ti  2gb

SanDisk Z400 256gb SSD

Win 7 x64 Ultimate

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...